email receiving died ??? + report a bug in ispconfig email add/remove

Discussion in 'Installation/Configuration' started by coolen, Oct 31, 2008.

Thread Status:
Not open for further replies.
  1. coolen

    coolen New Member

    I did set up ispconfig and suse 11.0 from scratch again, after some initial tries, and to avoid the errors I made earlier.

    Everything seemed to work fine after I was ready, and also after the restart of my box (after having solved that I had to add some extra ports for proftpd to my firewall)

    now suddenly after 2-3 days, I still am able to send mail from all the domains, but receiving mail doesn't seem to work anymore. I sure didn't change anything to the box as far as I know, and I am not able to see any error messages in the log files I think i need to check (mail.log, mail.warn, mail.error,mail.info)
    since I'm new to ispconfig and pretty new to mailserver isssues I was wondering if one of you ppl could give me some clues about where to start looking.


    Furthermore I want to report a bug:
    I added a new mailuser in one of my webs, but forgot to set a pwd. So I deleted that email user again. Now it seems impossible to add that email user new again, since ispconfig keeps complaining that the email still exists. I have no clue where to look to remove that erreneous email user, so I can add it again.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which messages appear in the mail log when you send a message from a account on your server to another account on your server?

    Thats no bug. You just missed to empty the recycle bin :)
     
  3. coolen

    coolen New Member

    Hi Till, thanks for answering so quickly.

    Oops :)

    ok no bug then, just never could have thought that it would go to the recycle bin first.


    As for the email, I do not have users that can log into the box, nor an email program there. But I'll try to set that up as test first.

    I'll be back at you
     
  4. coolen

    coolen New Member

    Hi Till,

    this is in /var/log/mail when I try to send from one till another client:

    Oct 31 13:27:58 idefix postfix/pickup[32081]: 67AF1A563: uid=10003 from=<web2_arthur>
    Oct 31 13:27:58 idefix postfix/cleanup[6998]: 67AF1A563: message-id=<[email protected]>
    Oct 31 13:27:58 idefix postfix/qmgr[32084]: 67AF1A563: from=<[email protected]>, size=505, nrcpt=1 (queue active)
    Oct 31 13:27:58 idefix postfix/smtp[7000]: 67AF1A563: to=<[email protected]>, orig_to=<[email protected]>, relay=none, delay=0.23, delays=0.13/0.02/0.08/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=server1.example.com type=AAAA: Host not found)
    Oct 31 13:27:58 idefix postfix/cleanup[6998]: A008CA564: message-id=<[email protected]>
    Oct 31 13:27:58 idefix postfix/qmgr[32084]: A008CA564: from=<>, size=2527, nrcpt=1 (queue active)
    Oct 31 13:27:58 idefix postfix/bounce[7001]: 67AF1A563: sender non-delivery notification: A008CA564
    Oct 31 13:27:58 idefix postfix/qmgr[32084]: 67AF1A563: removed
    Oct 31 13:27:58 idefix postfix/smtp[7000]: A008CA564: to=<[email protected]>, relay=none, delay=0.14, delays=0.06/0/0.08/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=server1.example.com type=AAAA: Host not found)
    Oct 31 13:27:58 idefix postfix/qmgr[32084]: A008CA564: removed



    for now I (try) not to use DNS, I have no clue what to prepare for it, and I want to configure the server step by step, hoping to solve the problems one by one.
    So

    I have set DNS in manager to off (hoping that all DNS issues are set aside with that) but obviously they haven't :( )


    My dns services are done via afraid.org, and I did add smtp/pop3 and mail entries there.

    on the websites on my server the MX boxis set to off but I do seem to have DNS entries in the DNS part of the ISPConfig UI
     
  5. coolen

    coolen New Member

    Nobody any suggestions anymore ?
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Please create an A record for server1.example.com. As a temporary workaround, you can add server1.example.com to /etc/hosts.
     
  7. coolen

    coolen New Member

    Hi Falko,

    Mhh, maybe some prior info.

    I run my webs via afraid. So I do not need a DNS on my site atm. So I set DNS/Bind in ispmanager to off.

    I do seem to have entries in the DNS part of ispconfig, but I figured that is no concern since bind isn't running ?

    the server1.example.com was changed allready to server1.idefix.lan, but that is a local name, it shouldn't be visible on the outside of the web.

    So the current error I see when sending LOCAL email from one of my webclients to another is also reflecting server1.idefix.lan:

    Nov 1 18:49:27 idefix postfix/smtp[11696]: DC909A564: to=<[email protected]>, orig_to=<[email protected]>, relay=none, delay=0.2, delays=0.13/0.02/0.05/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=server1.idefix.lan type=AAAA: Host not found)
    Nov 1 18:49:27 idefix postfix/cleanup[11694]: 1A6ACA565: message-id=<[email protected]>
    Nov 1 18:49:27 idefix postfix/qmgr[3146]: 1A6ACA565: from=<>, size=2462, nrcpt=1 (queue active)
    Nov 1 18:49:27 idefix postfix/bounce[11697]: DC909A564: sender non-delivery notification: 1A6ACA565
    Nov 1 18:49:27 idefix postfix/qmgr[3146]: DC909A564: removed
    Nov 1 18:49:27 idefix postfix/smtp[11696]: 1A6ACA565: to=<[email protected]>, relay=none, delay=0.09, delays=0.07/0/0.03/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=server1.idefix.lan type=AAAA: Host not found)
    Nov 1 18:49:27 idefix postfix/qmgr[3146]: 1A6ACA565: removed


    I added the server1.idefix.lan in my hosts:

    # Syntax:
    #
    # IP-Address Full-Qualified-Hostname Short-Hostname
    #

    127.0.0.1 localhost

    # special IPv6 addresses
    ::1 localhost ipv6-localhost ipv6-loopback

    fe00::0 ipv6-localnet

    ff00::0 ipv6-mcastprefix
    ff02::1 ipv6-allnodes
    ff02::2 ipv6-allrouters
    ff02::3 ipv6-allhosts
    127.0.0.2 idefix.lan idefix
    192.168.1.76 idefix.lan idefix
    192.168.1.76 server1.idefix.lan


    I still get the error in sending email
    mails are send, but not received.

    as for the A record ?? isn't that needed in DNS setup only ? and since idefix.lan is not an outside known name, should it be in an A record still??

    Or is it that you mean that the name I give to my local machine, should be one that IS visible in a real resolving internet name ?

    The strange thing is that everthing did work after install, it just suddenly stopped working, and I have no clue why.

    Just ask me for all logs.setups and even access to my box. I desperatly need to have this working and if possible, understand what I'm doing :)

    Thanks advance
     
  8. coolen

    coolen New Member

    BTW,

    sending mails from an internal web client out DOES work:


    Nov 2 08:48:38 idefix postfix/pickup[29729]: 79BB0A565: uid=10003 from=<web2_arthur>
    Nov 2 08:48:38 idefix postfix/cleanup[29750]: 79BB0A565: message-id=<[email protected]>
    Nov 2 08:48:38 idefix postfix/qmgr[29732]: 79BB0A565: from=<[email protected]>, size=463, nrcpt=1 (queue active)
    Nov 2 08:48:38 idefix postfix/smtp[29739]: 79BB0A565: to=<[email protected]>, relay=mailin.planet.nl[195.121.6.51]:25, delay=0.36, delays=0.12/0/0.14/0.11, dsn=2.6.0, status=sent (250 2.6.0 <[email protected]> Queued mail for delivery)
    Nov 2 08:48:38 idefix postfix/qmgr[29732]: 79BB0A565: removed
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Please add server1.idefix.lan to the
    Code:
    ::1 localhost ipv6-localhost ipv6-loopback
    line /etc/hosts as well.
     
  10. coolen

    coolen New Member

    Falko,

    I did:

    #
    # hosts This file describes a number of hostname-to-address
    # mappings for the TCP/IP subsystem. It is mostly
    # used at boot time, when no name servers are running.
    # On small systems, this file can be used instead of a
    # "named" name server.
    # Syntax:
    #
    # IP-Address Full-Qualified-Hostname Short-Hostname
    #

    127.0.0.1 localhost

    # special IPv6 addresses
    ::1 localhost server1.idefix.lan ipv6-localhost ipv6-loopback

    fe00::0 ipv6-localnet

    ff00::0 ipv6-mcastprefix
    ff02::1 ipv6-allnodes
    ff02::2 ipv6-allrouters
    ff02::3 ipv6-allhosts
    127.0.0.2 idefix.lan idefix
    192.168.1.76 idefix.lan idefix
    127.0.0.2 server1.idefix.lan server1
    192.168.1.76 server1.idefix.lan server1


    And no, it didn't help : (I also took a restart of the server, just 2b sure)

    Nov 2 18:38:35 idefix postfix/pickup[2902]: 367D2A565: uid=10003 from=<web2_arthur>
    Nov 2 18:38:35 idefix postfix/cleanup[4467]: 367D2A565: message-id=<[email protected]>
    Nov 2 18:38:35 idefix postfix/qmgr[2905]: 367D2A565: from=<[email protected]>, size=462, nrcpt=1 (queue active)
    Nov 2 18:38:35 idefix postfix/smtp[4469]: 367D2A565: to=<[email protected]>, orig_to=<[email protected]>, relay=none, delay=0.25, delays=0.19/0.02/0.04/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=server1.idefix.lan type=AAAA: Host not found)
    Nov 2 18:38:35 idefix postfix/cleanup[4467]: 655C2A566: message-id=<[email protected]>
    Nov 2 18:38:35 idefix postfix/qmgr[2905]: 655C2A566: from=<>, size=2468, nrcpt=1 (queue active)
    Nov 2 18:38:35 idefix postfix/bounce[4470]: 367D2A565: sender non-delivery notification: 655C2A566
    Nov 2 18:38:35 idefix postfix/qmgr[2905]: 367D2A565: removed
    Nov 2 18:38:35 idefix postfix/smtp[4469]: 655C2A566: to=<[email protected]>, relay=none, delay=0.1, delays=0.07/0/0.03/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=server1.idefix.lan type=AAAA: Host not found)
    Nov 2 18:38:35 idefix postfix/qmgr[2905]: 655C2A566: removed


    more suggestions or logs/commands you want to know ?

    thx for your help so far!

    Arthur
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to disable ipv6 in postfix main.cf file if you not really need it.
     
  12. coolen

    coolen New Member

    Till,

    I think you meant that I should set
    inet_protocols = ipv4
    from the all
    it had after the install.

    I did that and did a restart of postfix.

    The problem has changed from the adding AAAA type to adding A type,
    but it still keeps the same, email receiving is rejected (locally)

    Nov 3 19:27:43 idefix postfix/pickup[28396]: CA93DA567: uid=10003 from=<web2_arthur>
    Nov 3 19:27:43 idefix postfix/cleanup[28424]: CA93DA567: message-id=<[email protected]>
    Nov 3 19:27:43 idefix postfix/qmgr[28398]: CA93DA567: from=<[email protected]>, size=459, nrcpt=1 (queue active)
    Nov 3 19:27:44 idefix postfix/smtp[28426]: CA93DA567: to=<[email protected]>, orig_to=<[email protected]>, relay=none, delay=0.22, delays=0.15/0.02/0.04/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=server1.idefix.lan type=A: Host not found)
    Nov 3 19:27:44 idefix postfix/cleanup[28424]: 0494AA568: message-id=<[email protected]>
    Nov 3 19:27:44 idefix postfix/qmgr[28398]: 0494AA568: from=<>, size=2459, nrcpt=1 (queue active)
    Nov 3 19:27:44 idefix postfix/bounce[28427]: CA93DA567: sender non-delivery notification: 0494AA568
    Nov 3 19:27:44 idefix postfix/qmgr[28398]: CA93DA567: removed
    Nov 3 19:27:44 idefix postfix/smtp[28426]: 0494AA568: to=<[email protected]>, relay=none, delay=0.09, delays=0.06/0/0.03/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=server1.idefix.lan type=A: Host not found)
    Nov 3 19:27:44 idefix postfix/qmgr[28398]: 0494AA568: removed


    I also checked the order in /etc/nsswitch, that's "files" 1st everywhere, so that should be ok.

    furthermore server1.idefix.lan IS reachable from local:
    web2_arthur@idefix:~> ping server1.idefix.lan
    PING localhost (127.0.0.1) 56(84) bytes of data.
    64 bytes from localhost (127.0.0.1): icmp_seq=1 ttl=64 time=0.117 ms
    64 bytes from localhost (127.0.0.1): icmp_seq=2 ttl=64 time=0.105 ms
    64 bytes from localhost (127.0.0.1): icmp_seq=3 ttl=64 time=0.109 ms


    only not via nslookup:
    web2_arthur@idefix:~> nslookup server1.idefix.lan
    Server: 192.168.1.254
    Address: 192.168.1.254#53

    ** server can't find server1.idefix.lan: NXDOMAIN

    web2_arthur@idefix:~> nslookup idefix.lan
    Server: 192.168.1.254
    Address: 192.168.1.254#53

    Name: idefix.lan
    Address: 192.168.1.76

    web2_arthur@idefix:~>

    maybe that gives some extra info.


    Not sure that it is Suse that makes it harder for you guys, but I'm leaning towards a new install (again) and this time probably CentOS (see my other tread you answered to)

    But, I really would like to KNOW what and why this is going wrong.

    thanks again for your help with this.
     
  13. coolen

    coolen New Member

    Ok, I seem to have managed something, but I have no clue exactly what.

    What I did:

    I changed all occurances in network setup and postfix from idefix.lan to adviesburau-beateam.nl (one of my existing domains)

    my hostfile now looks like:

    #
    # hosts This file describes a number of hostname-to-address
    # mappings for the TCP/IP subsystem. It is mostly
    # used at boot time, when no name servers are running.
    # On small systems, this file can be used instead of a
    # "named" name server.
    # Syntax:
    #
    # IP-Address Full-Qualified-Hostname Short-Hostname
    #

    127.0.0.1 localhost

    # special IPv6 addresses
    ::1 localhost ipv6-localhost ipv6-loopback

    fe00::0 ipv6-localnet

    ff00::0 ipv6-mcastprefix
    ff02::1 ipv6-allnodes
    ff02::2 ipv6-allrouters
    ff02::3 ipv6-allhosts
    127.0.0.2 server1.adviesbureau-beateam.nl server1
    192.168.1.76 server1.adviesbureau-beateam.nl server1


    main.cf in postfix:

    unknown_local_recipient_reject_code = 550
    debug_peer_level = 2
    debugger_command =
    PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
    ddd $daemon_directory/$process_name $process_id & sleep 5
    sendmail_path = /usr/sbin/sendmail
    newaliases_path = /usr/bin/newaliases
    mailq_path = /usr/bin/mailq
    setgid_group = maildrop
    html_directory = /usr/share/doc/packages/postfix/html
    manpage_directory = /usr/share/man
    sample_directory = /usr/share/doc/packages/postfix/samples
    readme_directory = /usr/share/doc/packages/postfix/README_FILES
    inet_protocols = ipv4
    biff = no
    mail_spool_directory = /var/mail
    canonical_maps = hash:/etc/postfix/canonical
    #virtual_alias_maps = hash:/etc/postfix/virtual
    virtual_alias_domains = hash:/etc/postfix/virtual
    relocated_maps = hash:/etc/postfix/relocated
    transport_maps = hash:/etc/postfix/transport
    sender_canonical_maps = hash:/etc/postfix/sender_canonical
    masquerade_exceptions = root
    masquerade_classes = envelope_sender, header_sender, header_recipient
    myhostname = server1.$mydomain
    program_directory = /usr/lib/postfix
    inet_interfaces = all
    masquerade_domains =
    #mydestination = $myhostname, localhost.$mydomain
    defer_transports =
    mynetworks_style = subnet
    disable_dns_lookups = no
    relayhost =
    mailbox_command =
    mailbox_transport =
    strict_8bitmime = no
    disable_mime_output_conversion = no
    smtpd_sender_restrictions = hash:/etc/postfix/access
    smtpd_client_restrictions =
    smtpd_helo_required = no
    smtpd_helo_restrictions =
    strict_rfc821_envelopes = no
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check
    _relay_domains
    smtp_sasl_auth_enable = no
    smtpd_sasl_auth_enable = yes
    smtpd_use_tls = yes
    smtp_use_tls = yes
    alias_maps = hash:/etc/aliases
    mailbox_size_limit = 0
    message_size_limit = 10240000
    #mydomain = example.com
    mydomain = adviesbureau-beateam.nl
    mynetworks = 127.0.0.0/8
    smtpd_sasl_local_domain =
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_tls_auth_only = no
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom

    virtual_maps = hash:/etc/postfix/virtusertable

    mydestination = /etc/postfix/local-host-names
    home_mailbox = Maildir/




    What goes and fails now is:

    When I send mail from local account to local account it works:


    web2_arthur@server1:~> mail [email protected]
    Subject: local test
    dfwqfwfc
    EOT
    web2_arthur@server1:~>

    --

    ov 4 06:42:35 server1 postfix/pickup[11325]: E749AA566: uid=10003 from=<web2_arthur>
    Nov 4 06:42:35 server1 postfix/cleanup[11446]: E749AA566: message-id=<[email protected]>
    Nov 4 06:42:36 server1 postfix/qmgr[5374]: E749AA566: from=<[email protected]>, size=504, nrcpt=1 (queue active)
    Nov 4 06:42:36 server1 postfix/pickup[11325]: 27FCFA567: uid=10005 from=<web3_henk>
    Nov 4 06:42:36 server1 postfix/cleanup[11446]: 27FCFA567: message-id=<[email protected]>
    Nov 4 06:42:36 server1 postfix/local[11448]: E749AA566: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=0.31, delays=0.16/0.02/0/0.13, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Nov 4 06:42:36 server1 postfix/qmgr[5374]: E749AA566: removed
    Nov 4 06:42:36 server1 postfix/qmgr[5374]: 27FCFA567: from=<[email protected]>, size=421, nrcpt=1 (queue active)
    Nov 4 06:42:36 server1 postfix/local[11448]: 27FCFA567: to=<[email protected]>, relay=local, delay=0.14, delays=0.1/0/0/0.03, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Nov 4 06:42:36 server1 postfix/qmgr[5374]: 27FCFA567: removed




    When I send from OUTSIDE account to [email protected] it also works:



    Nov 4 07:17:45 server1 postfix/smtpd[12477]: connect from hpsmtp-eml19.KPNXCHANGE.COM[213.75.38.84]
    Nov 4 07:17:45 server1 postfix/smtpd[12477]: warning: support for restriction "check_relay_domains" will be removed from Postfix; use "reject_unauth_destination" instead
    Nov 4 07:17:45 server1 postfix/smtpd[12477]: 21AE0A563: client=hpsmtp-eml19.KPNXCHANGE.COM[213.75.38.84]
    Nov 4 07:17:45 server1 postfix/cleanup[12481]: 21AE0A563: message-id=<DEE47E6B317046BBA1C22DDE6D629287@artix>
    Nov 4 07:17:45 server1 postfix/qmgr[5374]: 21AE0A563: from=<[email protected]>, size=1154, nrcpt=1 (queue active)
    Nov 4 07:17:45 server1 postfix/smtpd[12477]: disconnect from hpsmtp-eml19.KPNXCHANGE.COM[213.75.38.84]
    Nov 4 07:17:45 server1 postfix/pickup[11325]: 4EF7AA567: uid=10003 from=<web2_arthur>
    Nov 4 07:17:45 server1 postfix/cleanup[12481]: 4EF7AA567: message-id=<[email protected]>
    Nov 4 07:17:45 server1 postfix/local[12482]: 21AE0A563: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=0.24, delays=0.12/0.02/0/0.09, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Nov 4 07:17:45 server1 postfix/qmgr[5374]: 21AE0A563: removed
    Nov 4 07:17:45 server1 postfix/qmgr[5374]: 4EF7AA567: from=<[email protected]>, size=428, nrcpt=1 (queue active)
    Nov 4 07:17:45 server1 postfix/local[12482]: 4EF7AA567: to=<[email protected]>, relay=local, delay=0.13, delays=0.1/0/0/0.03, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Nov 4 07:17:45 server1 postfix/qmgr[5374]: 4EF7AA567: removed


    email from outside, send to another then the adviesbureau beateam.nl fails:
    I get NO undelivarable email back (as in sending to wrong address I get instantly a dns not found error.)

    But I also do NOT get ANY sign from an email in : mail, mail.warn, mail.info nor mail.err.

    Any new ideas please ?
     
  14. falko

    falko Super Moderator ISPConfig Developer

    If you don't see anything in the logs, then probably the MX records are pointing to different servers.
     
  15. coolen

    coolen New Member

    OMG!!!

    talked about misfortune :( If I had tried ANY of the other accounts I would have had no failure :(

    Turned out that in the mx records at my provider they made a typo and forwarded to .nl in stead of .com ALL other records are ip based, just the mx one has the address in it, and the typo :(

    This thread can be closed, I was able to solve the initial problems thx to it, and this last one was just a (*@^(*^@ typo.

    Thanks a bundle Till and Falco !
     
Thread Status:
Not open for further replies.

Share This Page