email problems

Discussion in 'Installation/Configuration' started by mrtornado79, Jan 26, 2008.

  1. mrtornado79

    mrtornado79 New Member

    First of all I must tell you that I'm really noob at linux. I have installed the linux using the perfect guide from this site but I didn't had a hostname then. I have updated the hostname today using the same guide I probably missed something and I have no ideea what :)

    I'm using Debian Etch (4.0) , postfix & courier and ispconfig. I have looked around some posts but I still couldn't make it work.

    When I send emails to other domains everything is ok except they arive in bulck folder or spam but that's another problem. But when I try to send an email to my domain for example from [email protected] to [email protected] nothing happens. The log is below. In the user home directory the folder Maildir is not created. When I create it and the 3 subfolders new, cur and tmp I can login using pop3, but still I can't receive any email.
    Settings in ISPconfig under Management > Server > Settings > Email > Maildir is on.

    MX records:

    ; <<>> DiG 9.3.4 <<>> mx usarmydt.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 36682
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;usarmydt.com. IN MX

    ;; ANSWER SECTION:
    usarmydt.com. 1275 IN MX 10 mail.usarmydt.com.

    ;; Query time: 1 msec
    ;; SERVER: 213.133.98.98#53(213.133.98.98)
    ;; WHEN: Sat Jan 26 21:07:50 2008
    ;; MSG SIZE rcvd: 51

    Let me know what else you guys need because I can't figure this out at all :)

    Jan 26 20:59:04 www postfix/qmgr[2998]: 1009E30C242: from=<[email protected]>, size=525, nrcpt=1 (queue active)
    Jan 26 20:59:04 www postfix/smtp[3872]: 1009E30C242: to=<[email protected]>, relay=none, delay=1.3, delays=1.2/0.02/0.01/0, dsn=5.4.6, status=bounced (mail for usarmydt.com loo$
    Jan 26 20:59:05 www postfix/cleanup[3871]: 01F4D30C247: message-id=<[email protected]>
    Jan 26 20:59:05 www postfix/qmgr[2998]: 01F4D30C247: from=<>, size=2298, nrcpt=1 (queue active)
    Jan 26 20:59:05 www postfix/bounce[3874]: 1009E30C242: sender non-delivery notification: 01F4D30C247
    Jan 26 20:59:05 www postfix/qmgr[2998]: 1009E30C242: removed
    Jan 26 20:59:05 www postfix/smtp[3872]: 01F4D30C247: to=<[email protected]>, relay=none, delay=0.01, delays=0.01/0/0/0, dsn=5.4.6, status=bounced (mail for usarmydt.com loops ba$
    Jan 26 20:59:05 www postfix/qmgr[2998]: 01F4D30C247: removed
    Jan 26 20:59:05 www postfix/smtpd[3867]: disconnect from AC853D93.ipt.aol.com[172.133.61.147]
     
  2. mrtornado79

    mrtornado79 New Member

    here is the log file from vim because with pico it wasn't all, btw here I have disabled Maildir from ISPconfig, also the spam protection.

    Jan 26 21:28:06 www postfix/qmgr[4572]: 42D2630C247: from=<[email protected]>, size=523, nrcpt=1 (queue active)
    Jan 26 21:28:06 www postfix/smtp[4766]: 42D2630C247: to=<[email protected]>, relay=none, delay=0.98, delays=0.95/0.02/0.01/0, dsn=5.4.6, status=bounced (mail for usarmydt.com loops back to myself)
    Jan 26 21:28:06 www postfix/cleanup[4765]: E903B30C24A: message-id=<[email protected]>
    Jan 26 21:28:06 www postfix/bounce[4767]: 42D2630C247: sender non-delivery notification: E903B30C24A
    Jan 26 21:28:06 www postfix/qmgr[4572]: 42D2630C247: removed
    Jan 26 21:28:06 www postfix/qmgr[4572]: E903B30C24A: from=<>, size=2293, nrcpt=1 (queue active)
    Jan 26 21:28:06 www postfix/smtp[4766]: E903B30C24A: to=<[email protected]>, relay=none, delay=0.02, delays=0.02/0/0/0, dsn=5.4.6, status=bounced (mail for usarmydt.com loops back to myself)
    Jan 26 21:28:06 www postfix/qmgr[4572]: E903B30C24A: removed
    Jan 26 21:28:07 www postfix/smtpd[4758]: disconnect from AC853D93.ipt.aol.com[172.133.61.147]
    Jan 26 21:28:09 www courierpop3login: Connection, ip=[::ffff:172.133.61.147]
    Jan 26 21:28:15 www courierpop3login: LOGIN, user=toro, ip=[::ffff:172.133.61.147]
    Jan 26 21:28:16 www courierpop3login: LOGOUT, user=toro, ip=[::ffff:172.133.61.147], top=0, retr=0, rcvd=12, sent=39, time=2
    Jan 26 21:28:19 www courierpop3login: Connection, ip=[::ffff:172.133.61.147]
    Jan 26 21:28:21 www courierpop3login: LOGIN, user=toro, ip=[::ffff:172.133.61.147]
    Jan 26 21:28:21 www courierpop3login: LOGOUT, user=toro, ip=[::ffff:172.133.61.147], top=0, retr=0, rcvd=12, sent=39, time=0
    Jan 26 21:30:14 www courierpop3login: Connection, ip=[::ffff:172.133.61.147]
    Jan 26 21:30:15 www courierpop3login: LOGIN, user=toro, ip=[::ffff:172.133.61.147]
    Jan 26 21:30:16 www courierpop3login: LOGOUT, user=toro, ip=[::ffff:172.133.61.147], top=0, retr=0, rcvd=12, sent=39, time=1
     
  3. mrtornado79

    mrtornado79 New Member

    Ok I fixed half of the problem. Now I can send mails from my own domain but I can't receive mails from let's say yahoo.com.

    I solved the problem by adding 2 lines in /etc/postfix/local-host-names

    I have added localhost.localdomain.usarmydt.com and
    usarmydt.com

    But still I can't receive email from other providers and the strange thing is that I can't find anything about that in the logs. Any ideas ?
     
  4. mrtornado79

    mrtornado79 New Member

    I don't know if this is important or not but I'm not using the default port for smtp I'm using the port 587 I can telnet on it with no problem.

    In /etc/postfix/master.cf I have the line

    587 inet n - - - - smtpd

    and when I look at ISPconfig at ISP Server Status SMTP Server seems to be offline. Here is a netstat

    netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost.localdo:mysql *:* LISTEN 2419/mysqld
    tcp 0 0 *:submission *:* LISTEN 4373/master
    tcp 0 0 *:webmin *:* LISTEN 3072/perl
    tcp 0 0 *:81 *:* LISTEN 2865/ispconfig_http
    tcp 0 0 www.usarmydt.com:domain *:* LISTEN 3021/named
    tcp 0 0 localhost.locald:domain *:* LISTEN 3021/named
    tcp 0 0 localhost.localdoma:953 *:* LISTEN 3021/named
    tcp 0 0 www.usarmydt.com:webmin AC853D93.ipt.aol.:51195 ESTABLISHED4880/perl
    tcp 0 0 www.usarmydt.com:webmin AC853D93.ipt.aol.:51194 ESTABLISHED4875/perl
    tcp6 0 0 *:imaps *:* LISTEN 2569/couriertcpd
    tcp6 0 0 *:pop3s *:* LISTEN 2588/couriertcpd
    tcp6 0 0 *:submission *:* LISTEN 4373/master
    tcp6 0 0 *:pop3 *:* LISTEN 2574/couriertcpd
    tcp6 0 0 *:imap2 *:* LISTEN 2557/couriertcpd
    tcp6 0 0 *:www *:* LISTEN 2895/apache2
    tcp6 0 0 *:ftp *:* LISTEN 3052/proftpd: (acce
    tcp6 0 0 *:ssh *:* LISTEN 2691/sshd
    tcp6 0 0 ip6-localhost:953 *:* LISTEN 3021/named
    tcp6 0 2224 www.usarmydt.com:ssh AC853D93.ipt.aol.:50515 ESTABLISHED3107/0
     
    Last edited: Jan 26, 2008
  5. mrtornado79

    mrtornado79 New Member

    Ok fixed this problem also. After I add in /etc/postfix/master.cf the line

    smtp inet n - - - - smtpd

    because I was using port 587 so now it looks like this:

    587 inet n - - - - smtpd
    smtp inet n - - - - smtpd


    I have only one problem left :) Why all the emails I send end up in bulk or spam folder at any provider. I tryed mailing to aol.com, yahoo.com and gmail.com. Same problem everywhere.
     
  6. falko

    falko Super Moderator ISPConfig Developer

  7. mrtornado79

    mrtornado79 New Member

    My server is not black listed. Now I have problems only sending mail to yahoo.com and hotmail.com . I have sent emails to server other providers like aol.com, mail.com, gmail.com and a few others and is working fine.

    Now I have another problem I have tryed to install postfixadmin I have installed with some success ... everything was working except the mail boxes where not created. So I've decide the give it up re roll back to original configuration. I have restored the files /etc/postfix/main.cf & /etc/postfix/master.cf the only problem I have now is that I can't login in with thunderbird or any other client by pop3 . I think that's because I have installed a new curier package. This is all I've installed :

    apt-get install courier-authlib-mysql
    apt-get install sudo php-pear php5-mysql php5-gd php5-cli php5-common php5-mcrypt
    apt-get install php-db php-net-socket php-log php-net-smtp

    I have also runned some command to configure them but I just can't follow where the mistake is.

    Log here.
    Jan 27 19:40:20 www courierpop3login: LOGIN FAILED, user=toro, ip=[::ffff:172.163.239.221]
    Jan 27 19:40:20 www courierpop3login: authentication error: Input/output error
    Jan 27 19:50:19 www courierpop3login: Connection, ip=[::ffff:172.163.239.221]
    Jan 27 19:50:20 www courierpop3login: LOGIN FAILED, user=toro, ip=[::ffff:172.163.239.221]
    Jan 27 19:50:20 www courierpop3login: authentication error: Input/output error


    So I don't want authlogin with database with courier I just want to roll back :)
     
  8. mrtornado79

    mrtornado79 New Member

    I have also did apt-get remove courier-authlib-mysql and still nothing.
     
  9. mrtornado79

    mrtornado79 New Member

    Ok I've fixed it.

    Changed the next line in the configuration file /etc/courier/authdaemonrc

    from authmodulelist="authmysql"
    to authmodulelist="authpam"

    Everything is ok now :)
     

Share This Page