Email problems: Cannt send and recieve! Help!

Discussion in 'Installation/Configuration' started by bardo, Feb 5, 2010.

  1. bardo

    bardo New Member

    My server is CentOS 5.3 with ISPConfig 3.0.1


    At first, I found the error information in the maillog:


    fatal: parameter "smtpd_recipient_restrictions": specify at least one working instance of: check_relay_domains, reject_unauth_destination, reject, defer or defer_if_permit
    Feb 5 18:44:15 wsttl postfix/master[18016]: warning: process /usr/libexec/postfix/smtpd pid 10592 exit status 1
    Feb 5 18:44:15 wsttl postfix/master[18016]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling


    So I add the option "reject_unauth_destination" to the smtpd_recipient_restrictions. Then i found:

    Feb 5 19:01:07 wsttl postfix/qmgr[10786]: 2587E3650073: from=<[email protected]>, size=2960, nrcpt=1 (queue active)
    Feb 5 19:01:07 wsttl maildrop[20598]: Cannot set my user or group id.
    Feb 5 19:01:07 wsttl postfix/pipe[20597]: 2587E3650073: to=<[email protected]>, relay=maildrop, delay=360924, delays=360924/0.02/0/0.01, dsn=4.3.0, status=deferred (temporary failure. Command output: /usr/bin/maildrop: Cannot set my user or group id. )


    And I had checked "dig mx", the response is OK.


    And I must tell you, that the Postfix I installed is a rpm (version 2.5.1) package with SPEC:

    POSTFIX_ALT_PRIO=30
    POSTFIX_CDB=0
    POSTFIX_DB=4
    POSTFIX_DOVECOT=0
    POSTFIX_LDAP=1
    POSTFIX_MYSQL=0
    POSTFIX_MYSQL_PATHS=0
    POSTFIX_MYSQL_REDHAT=1 #??Is this is a problem?
    POSTFIX_PCRE=0
    POSTFIX_PGSQL=0
    POSTFIX_SASL=2
    POSTFIX_SMTPD_MULTILINE_GREETING=0
    POSTFIX_SPF=0
    POSTFIX_TLS=1
    POSTFIX_VDA=1

    So i want to ask: Now I still can not send and rceieve any mail with my mail server. Is "POSTFIX_MYSQL_REDHAT=1" is a problem? How I could solve the problem "Cannot set my user or group id." ? And now except webmail, I cannt use any mail soft as outlook and so on. When I connection to the pop3 server, I got the error code: 0x800CCC0F.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You run a old ispconfig version (3.0.1), please update it to the current version 3.0.1.6 and choose to reconfigure services during the update.
     
  3. falko

    falko Super Moderator ISPConfig Developer

    How exactly did you install the server? Did you use a guide from HowtoForge? If so, which one (URL)?
     
  4. bardo

    bardo New Member

    I'd installed my server using the guid from the url:
    http://www.howtoforge.com/perfect-server-centos-5.3-x86_64-ispconfig-3
    but i must say that the php version in my server is 5.2.11 , and the mysql version is 5.1.42.
    And now all others are ok except the postfix.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Please do what I suggested in #2 if you want to solve this problem.
     
  6. bardo

    bardo New Member

    Sorry, now ispconfig had beeb updated to the current version 3.0.1.6 , and service reconfiged, but the error still exists.

    temporary failure. Command output: /usr/bin/maildrop: Cannot set my user or group id.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    And you have entered "yes" as the updater asked you to reconfigure services?
     
  8. bardo

    bardo New Member

    yes, i entered "yes" , and now i only fund these warnings and errors in the log:
    (temporary failure. Command output: /usr/bin/maildrop: Cannot set my user or group id. )
    warning: SASL authentication failure: Couldn't find mech NTLM
    warning: SASL authentication failure: Couldn't find mech GSSAPI

    and i found this in master.cf
    maildrop unix - n n - - pipe
    flags=R user=vmail argv=/usr/bin/maildrop -d ${recipient} ${extension} ${recipient} ${user} ${nexthop} ${sender}
    but in MAILDROP_README IS:
    maildrop unix - n n - - pipe
    flags=ODRhu user=vmail argv=/path/to/maildrop -d ${recipient}

    Are they problems?

    thanks!
     
    Last edited: Feb 22, 2010
  9. bardo

    bardo New Member

    i have a test, here the result:
    [root@wsttl ~]# su vmail
    [vmail@wsttl root]$ echo "test" |maildrop -V 10 -d [email protected]
    maildrop: authlib: groupid=5000
    maildrop: authlib: userid=5000
    maildrop: Cannot set my user or group id.
    [vmail@wsttl root]$

    and i found there is no mailbox_command config in my main.cf
    and in the MAILDROP_README
    i found:
    mailbox_command = /path/to/maildrop -d ${USER}

    when i use outlook i got the error: '-ERR Maildir invalid (no 'cur' directory)', 0x800CCC92

    when i use outlook i got the error: '-ERR Maildir invalid (no 'cur' directory)', 0x800CCC92

    pls give a help. How can i solve the problem? thanks
     
    Last edited: Feb 23, 2010
  10. bardo

    bardo New Member

    maildrop: authlib: groupid=5000
    maildrop: authlib: userid=5000
    maildrop: Cannot set my user or group id.

    for this error, i resolved by changing the config of postfix:
    virtual_gid_maps = static:5000
    virtual_uid_maps = static:5000

    virtual_gid_maps = static:504
    virtual_uid_maps = static:504

    504 is fact vmail usrid and groupid

    or u can edit /etc/passwd and etc/group/ to change vmail usrid and groupid to 5000.

    now i cant understand:
    in master.cf
    maildrop unix - n n - - pipe
    flags=R user=vmail argv=/usr/bin/maildrop -d ${recipient} ${extension} ${recipient} ${user} ${nexthop} ${sender}
    but in MAILDROP_README IS:
    maildrop unix - n n - - pipe
    flags=ODRhu user=vmail argv=/path/to/maildrop -d ${recipient}

    who can tell me? thanks!
     

Share This Page