Email Problem

Discussion in 'Installation/Configuration' started by tigerseyetech, Aug 19, 2007.

  1. tigerseyetech

    tigerseyetech New Member

    I'm not sure if this issue has been addressed or not, but I can't seem to find it. Please forgive me if this has already been addressed.

    I am having some strange issues with my email. I get about 30 undeliverable emails every minute whether I try to send something or not. If I send an email, it does go through. I can also receive email, but I also get these undeliverable emails.

    My setup is CentOS 5 using Falko's Perfect Setup. I did everything step by step. I also installed phpmyadmin and roundcube webmail.

    Please help. This email issue is getting rather irritating.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the exact error messages that you get in your mail logfile.
     
  3. tigerseyetech

    tigerseyetech New Member

    Ok, please forgive for how long this has taken. I have had many things to do. Plus, I did a full format and clean install (this time with Fedora 7, once again, using Falko's Perfect Setup). Even with the new OS and clean install, I am still getting same problem.

    The subject of the mail is "Undelivered Mail Returned to Sender"
    The sender of the mail is "[email protected]"
    The recipient of the mail is "[email protected]"
    The body of the undeliverable mail is only 1 number, usually 4 digits in length ("2743"), is coming from "[email protected]", and going to "undisclosed-recipients:;"

    Where do I go to find the mail log so that I can post it here?

    Thank you for your help.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post an excerpt of your mail log.
     
  5. tigerseyetech

    tigerseyetech New Member

    As asked in my previous post, where do I find my mail log so that I can post it here?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    /var/log/mail.log or /var/log/mail or /var/log/maillog
     
  7. tigerseyetech

    tigerseyetech New Member

    Attached, you will find an excerpt from my mail log. I hope it is enough to help me figure out what is going on. I really appreciate any info you can offer.

    Thank you
     

    Attached Files:

  8. erebus

    erebus New Member

    I had the same problem in the past. I assume you get mails like that:

    Code:
    From - Fri Oct 26 03:51:08 2007
    X-Account-Key: account6
    X-UIDL: 1193312666.524
    X-Mozilla-Status: 0001
    X-Mozilla-Status2: 00000000
    X-Mozilla-Keys:                                                                                 
    Return-Path: <[email protected]>
    X-Spam-Checker-Version: SpamAssassin 3.2.3 (2007-08-08) on nemesis.domain.tld
    X-Spam-Level: *
    X-Spam-Status: No, score=1.5 required=5.0 tests=ALL_TRUSTED,TVD_SPACE_RATIO
    	autolearn=no version=3.2.3
    X-Original-To: [email protected]
    Delivered-To: [email protected]
    Received: from nemesis.domain.tld (localhost [127.0.0.1])
    	(using TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits))
    	(No client certificate requested)
    	by mail.domain.tld (Postfix) with ESMTP id 75BD644022E
    	for <[email protected]>; Fri, 26 Oct 2007 03:49:40 +0300 (EEST)
    Received: (from [email protected])
    	by nemesis.domain.tld (8.13.1/8.13.1/Submit) id l9Q0neCQ020579
    	for [email protected]; Fri, 26 Oct 2007 03:49:40 +0300
    Date: Fri, 26 Oct 2007 03:49:40 +0300
    From: [email protected]
    Message-Id: <[email protected]>
    X-Loop: [email protected]
    Subject: Mailsize: domain.tld_support
    To: undisclosed-recipients:;
    X-Virus-Status: No
    X-Virus-Checker-Version: clamassassin 1.2.4 with clamscan / ClamAV 0.91.2/4595/Thu Oct 25 23:26:44 2007
    
    946
    If I recall correctly, the reason for this is the mail host you use. And I explain:

    1) Create a DNS entry (only) of a subdomain that you will never use as a web vhost, such us mail.domain.tld. Do not ever create a web account using that name -- keep it only as a DNS A record.

    2) Edit your /etc/postfix/main.cf and add/alter the following lines according to the dns you created above, i.e.:

    Code:
    myhostname = mail.domain.tld
    mydomain = mail.domain.tld
    myorigin = mail.domain.tld
    If some of them are commented out, uncomment them.

    3) Edit /etc/postfix/local-host-names. Be sure that 'mail.domain.tld' exists somewhere in this file. If not, added at the end (and only at the end) of that file, like:

    Code:
    #### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
    mail.domain.tld
    4) Restart postfix:

    Code:
    # service postfix restart
    Check and see if this does the trick (if not, leave it as is, it will not harm your configuration and this is the proper way to go anyway).
     
  9. tigerseyetech

    tigerseyetech New Member

    Thank you for that info. I did as you said, and it still isn't working correctly. I am still getting 1000's of emails a day from this. Is there something else I should do?
     
  10. erebus

    erebus New Member

    Can you please paste /etc/postfix/local-host-names ?
     
  11. tigerseyetech

    tigerseyetech New Member

    Code:
    ###################################
    #
    # ISPConfig local-host-names Configuration File
    #         Version 1.0
    #
    ###################################
    localhost
    mail.grargs.com
    localhost.mail.grargs.com
    localhost.grargs.com
    localhost.localdomain
    www.grargs.com
    grargs.com
    #### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
    NS1.grargs.com
     
  12. erebus

    erebus New Member

    First of all, never use capitalization in Linux (like NS1.domain.tld). You can break things easily -- so use ns1.domain.tld.

    Secondly, your file seems normal. What is the host you 've used in postfix's configuration?
     
  13. tigerseyetech

    tigerseyetech New Member

    well, I changed NS1 to ns1 in both local-host-names and postfix's main.cf

    in main.cf I have:
    Code:
    myhostname = ns1.grargs.com
    mydomain = ns1.grargs.com
    myorigin = ns1.grargs.com
    
    * not whole file, just items I've changed

    is this the info you were looking for?
     
  14. erebus

    erebus New Member

    Yes, thank you.

    If you 've restarted postfix and the problem persists, please paste the output of:

    Code:
    # cat /etc/aliases|less
    also the output of:

    Code:
    # cat /etc/postfix/virtusertable|less
     
  15. tigerseyetech

    tigerseyetech New Member

    cat /etc/aliases|less :
    Code:
    #
    #  Aliases in this file will NOT be expanded in the header from
    #  Mail, but WILL be visible over networks or from /bin/mail.
    #
    #       >>>>>>>>>>      The program "newaliases" must be run after
    #       >> NOTE >>      this file is updated for any changes to
    #       >>>>>>>>>>      show through to sendmail.
    #
    
    # Basic system aliases -- these MUST be present.
    mailer-daemon:  postmaster
    postmaster:     root
    
    # General redirections for pseudo accounts.
    bin:            root
    daemon:         root
    adm:            root
    lp:             root
    sync:           root
    shutdown:       root
    halt:           root
    mail:           root
    news:           root
    uucp:           root
    operator:       root
    games:          root
    gopher:         root
    ftp:            root
    nobody:         root
    radiusd:        root
    nut:            root
    dbus:           root
    vcsa:           root
    canna:          root
    wnn:            root
    rpm:            root
    nscd:           root
    pcap:           root
    apache:         root
    webalizer:      root
    dovecot:        root
    fax:            root
    quagga:         root
    radvd:          root
    pvm:            root
    amanda:         root
    privoxy:        root
    ident:          root
    named:          root
    xfs:            root
    gdm:            root
    mailnull:       root
    postgres:       root
    sshd:           root
    smmsp:          root
    postfix:        root
    netdump:        root
    ldap:           root
    squid:          root
    ntp:            root
    mysql:          root
    desktop:        root
    rpcuser:        root
    rpc:            root
    nfsnobody:      root
    
    ingres:         root
    system:         root
    toor:           root
    manager:        root
    dumper:         root
    abuse:          root
    
    newsadm:        news
    newsadmin:      news
    usenet:         news
    ftpadm:         ftp
    ftpadmin:       ftp
    ftp-adm:        ftp
    ftp-admin:      ftp
    www:            webmaster
    webmaster:      root
    noc:            root
    security:       root
    hostmaster:     root
    info:           postmaster
    marketing:      postmaster
    sales:          postmaster
    support:        postmaster
    
    
    # trap decode to catch security attacks
    decode:         root
    
    # Person who should get root's mail
    #root:          marc
    
    cat /etc/postfix/virtusertable|less :
    Code:
    ###################################
    #
    # ISPConfig virtusertable Configuration File
    #         Version 1.0
    #
    ###################################
    [email protected]    web1_paul
    [email protected]    web1_paul
    [email protected]    web1_paul
    [email protected]    web1_paul
    #### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
    
     
  16. erebus

    erebus New Member

    More or less I'm out of tricks here. I'm sure I had the same problem (I have still kept these mails in my Thunderbird) and I somehow resolve it. However I don't exactly remember how, but I can assure you that it was something simple.

    Anyway, here are my last proposals:

    1) Edit /etc/aliases and comment out these lines:

    Code:
    #info:          postmaster
    #marketing:     postmaster
    #sales:         postmaster
    #support:       postmaster
    2) Rebuild postfix's aliases database:

    Code:
    # postalias /etc/aliases
    3) Make sure that in ISPConfig's web panel, under Server - Settings, you have a real e-mail address set, not a local one (not root or user, but something like [email protected]).

    4) Restart ISPConfig and Postfix:

    Code:
    # /etc/init.d/postfix restart
    # /etc/init.d/ispconfig_server restart
    If the files you 've pasted are complete, I find no reason why it should not work. In any case, I really don't know what else to say, so maybe someone more experienced with postfix may have a hint for you.

    Good luck,
     
  17. tigerseyetech

    tigerseyetech New Member

    well, I will see what happens now. I did what you requested. I can say that I had to change the email in Server --> Settings. It was set to a local one. I'll post back what happens.

    Thank you for your help. I really do appreciate it.
     
  18. tigerseyetech

    tigerseyetech New Member

    still not working. I think I am just going to try a different setup. This one hasn't worked for me (and I have tried several times). I really appreciate the advice you all have given. I'm sorry I couldn't get it working.

    Thank you
     
  19. digerata

    digerata New Member

    I have this same problem, probably once a week. It drives me nuts.

    I noticed that there was one solution that wasn't mentioned. In your postfix local-host-names file you have:

    ##
    localhost.grargs.com
    localhost.localdomain
    ##

    Add an additional line for:

    localhost.localdomain.grargs.com

    If you closely examine the emails, you may see something mentioning that domain. Restart postfix and see if that fixes the problem.

    If it does fix the problem, good luck on keeping it fixed. Every time I modify anything in ispconfig's control panel, my change is lost and almost immediately I begin fill up my mailboxes again. I actually just hopped on this board to see if anyone else found a permanent fix.

    Also, if you have all of these emails and don't want to just delete your inbox to fix the problem, try this groovy script to delete these emails:

    http://phatness.com/node/1664

    Just add in your account info and run it. It might take a few hours, but it will clean out all that crap. (You'll need groovy installed, of course)
     
  20. till

    till Super Moderator Staff Member ISPConfig Developer

    You added the line on the wrong position in the file. You must add the line:

    localhost.localdomain.grargs.com

    as last line, after the comment. As the comment states "MAKE MANUAL ENTRIES BELOW THIS LINE!".
     

Share This Page