email problem. (virtusertable)

Discussion in 'Installation/Configuration' started by Billionstar, Mar 9, 2007.

  1. Billionstar

    Billionstar New Member

    I will try to explain the problem

    Site 1:
    domain: sub1.domain.tld
    user: web1_user
    mail-prefix: user

    Site 2:
    domain: www.domain.tld
    co-domain: domain.tld
    user: web2_anotheruser
    mail-prefix: anotheruser

    Site 3:
    domain: sub2.domain.tld
    user: web3_thirduser
    mail-prefix: thirduser



    and then in /etc/postfix/virtusertable I get
    ---
    [email protected]
    [email protected]
    [email protected]
    [email protected]
    [email protected]
    [email protected]
    [email protected]
    [email protected]
    [email protected]
    [email protected]
    ----

    So why does only site 1 and 2 get domain.tld and not site 3, when both site 1 and 3 doesnt have a co-domain, and how can I fix it?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please double check that site one has no co-domain with empty host and make sure that the recycle bin is empty.
     
  3. Billionstar

    Billionstar New Member

    I emptied the recyclebin and now only site 2 have @domain.tld.

    virtusertable:
    ---
    [email protected]
    [email protected]
    [email protected]
    [email protected]
    [email protected]
    [email protected]
    [email protected]
    [email protected]
    ----

    Now I got another question.
    Is it possible to get @domain.tld on site 1 and 3, while I have it on site 2?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    No, thas not pssible because you can not assign the same domain to more then one site.
     
  5. Billionstar

    Billionstar New Member

    oki.... Thanks
     

Share This Page