Email problem Perfect Server: Debian 10

Discussion in 'Installation/Configuration' started by till, Oct 10, 2020.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    Posted for rudydehaas:

    I posted this as a comment on the "Perfect Server: Debian 10.." article and got a response asking that I post it here. So...

    I did a new, from bear metal, install of Debian 10 on a Dell Xeon. DNS and the reverse ptr are correct for this new machine as .
    Then, being too lazy to look it all up for myself I used the instructions in the perfect server article to load everything. When finished, everything worked except email - localhost/webmail - that reported an smtp access error.
    So I re-installed (from scratch) and then followed the instructions again except that I did not install things like webalizer, phpmyadmin, and ISPconfig inself. Same error.

    So I installed dovecot and brought up thunderbird. Thunderbird reported that it would not connect because the certificate was self-signed. So I re-installed certbot using snapd and pushed certbot keys into the postfix /etc../live/ directory.

    Now thunderbird will send mail but the system will not accept (or store sent) mail. The error is:
    Final-Recipient: rfc822; <a href="mailto:[email protected]">[email protected]</a>
    Action: failed
    Status: 5.7.1
    Remote-MTA: dns; (, the server for the domain
    Diagnostic-Code: smtp; 554 5.7.1 <a href="mailto:[email protected]">&lt;[email protected]&gt;</a>: Relay access denied
    Last-Attempt-Date: Fri, 09 Oct 2020 11:46:28 -0700 (PDT)

    Roundcube, however, will not send mail. It's response is:

    SMTP Error (504): Failed to add recipient "[email protected]" (5.5.2 &lt;localhost&gt;: Helo command rejected: need fully-qualified hostname).

    At this point I have no idea whether the problem lies in the postfix or dovecot set-ups.. ? or somewhere else.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Plesae post the content of the /etc/postfix/ file.

    By default, a self-signed SSL cert is used, so it#s ok if your mail client shows a warning. You can replace the cert with one from LE like this:

    I'm not sure if this will work later, so in case you have any problems with SSL certs, you'll probably have to undo that and install it again as shown in perfect server guide.

Share This Page