Email Pipe

Discussion in 'General' started by parkerj, Jun 11, 2007.

  1. parkerj

    parkerj Member HowtoForge Supporter

    I am using a newsletter program that allows you to subscribe by email by using a piping script. At the top of the script is "#!/usr/share/php -q". I have used the following forwards:

    1. [email protected],"|/usr/bin/php -q /var/www/web1/web/12all/admin/subscribe_pipe.php"

    2. [email protected],"|php -q /var/www/web1/web/12all/admin/subscribe_pipe.php"

    3. [email protected],"|/var/www/web1/web/12all/admin/subscribe_pipe.php"

    When I use option 1 and 2, no confirmation email is sent to the subscriber. When I use option 3, the following error returns to the subscriber:
    <[email protected]>: Command died with status 1:
    "/var/www/web1/web/12all/admin/subscribe_pipe.php". Command output: local:
    fatal: execvp /var/www/web1/web/12all/admin/subscribe_pipe.php: Permission

    I am not sure if I am writing the forwards right but any help is greatly appreciated.
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    which php
  3. parkerj

    parkerj Member HowtoForge Supporter

    The output is "/usr/bin/php"
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The first version is correct. Maybe the the .php file is not accessible by the process.

    Version 3 can not work as you did not specify a php interpreter and the .php file is most likely not a executable shell script.

Share This Page