email on root

Discussion in 'Installation/Configuration' started by mccharlet, Jan 14, 2008.

  1. mccharlet

    mccharlet Member HowtoForge Supporter

    :confused:

    I have all invalid email address for all domain go to the root mailbox

    I will like that nobody receive these messages or the sender receive a error message

    I have debian with postfix (maildir) and ispconfig 2.2.19
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Add this to /etc/aliases:
    root: /dev/null
    Then run
    Code:
    newaliases
    /etc/init.d/postfix restart

    That's not a good idea because spammers use wrong sender addresses, so the error messages would reach the wrong people...
     
  3. mccharlet

    mccharlet Member HowtoForge Supporter

    Thank's its 'ok for the root message

    But how to disable this auto-reply error

    "This Message was undeliverable due to the following reason:

    Each of the following recipients was rejected by a remote mail server.
    The reasons given by the server are included to help you determine why
    each recipient was rejected.

    Recipient: <[email protected]>
    Reason: 5.1.1 <[email protected]>: Recipient address rejected: User unknown in local recipient table


    Please reply to <[email protected]>
    if you feel this message to be in error.
    "
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    This error message is fine. If someone sends a email to the email address [email protected] and you did not create a email address [email protected], this message is delivered back to the sending email server.
     

Share This Page