Email not working

Discussion in 'Installation/Configuration' started by willieray25, Sep 16, 2008.

  1. willieray25

    willieray25 New Member

    Everything else is dialed in but I can't get the email working.

    Fedora 8 followed the perfect server howto.

    I can't even email from one account on the domain to another. Need to get this up and running asap. Appreciate any help team!

    THanks in advance

    ~Willieray
     
  2. Br8knitOFF

    Br8knitOFF New Member

    What are you using to test? At what point does it fail? Is your server kicking back errors?

    What does your mail.log report?

    //Todd
     
  3. willieray25

    willieray25 New Member

    postfix/smtpd[19761]: warning: 24-197-228-230.static.stpt.wi.charter.com[24.197.228.230]: SASL LOGIN authentication failed: authentication failure

    lotsa this.

    messages has similar errors with saslauthd getting a PAM error. I do have all the users setup in /etc/passwd though.
    Any ideas?
     
  4. Br8knitOFF

    Br8knitOFF New Member

  5. willieray25

    willieray25 New Member

    Code:
    telnet localhost 25
    
    ehlo localhost
    250-'my.server.com'
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH LOGIN PLAIN
    250-AUTH=LOGIN PLAIN
    250-ENHANCEDSTATUSCODES
    250-8BITMIME
    250 DSN
    
    
    seems to check out compared to the howto...
     
  6. willieray25

    willieray25 New Member

    wait there is something that might be choking it out. Not sure

    ehlo localhost gives

    250-lianli.mydomain1.com
    ...
    ...

    but i'm trying to setup emails for mydomain2.com
    I have several domains on this one ip and i have installed a cacert on server2.com

    any help?
     
  7. Br8knitOFF

    Br8knitOFF New Member

    Not exactly.

    Did you actually try to authenticate a session via telnet localhost 25?

    Try the telnet localhost at port 25, and go through to try to authenticate as in that link- line begins with:

    AUTH PLAIN...

    If you can successfully authenticate there, I'd try another mail client.

    //Todd
     
  8. willieray25

    willieray25 New Member

  9. Br8knitOFF

    Br8knitOFF New Member

    Then you're good to go.

    web2_sales2 is the user name that email account needs to use to authenticate...

    //Todd
     
  10. willieray25

    willieray25 New Member

  11. willieray25

    willieray25 New Member

    I just checked postconf -v and the hostname was wrong.

    I changed it to mail.mydomain2.com and restarted.

    should this have any affect?
     
  12. willieray25

    willieray25 New Member

    I am able to telnet even remotely to mail.mydomain2.com

    Code:
    telnet mail.mydomain2.com 25
    Trying myIP...
    Connected to mail.mydomain2.com.
    Escape character is '^]'.
    220 mail.mydomain2.com ESMTP Postfix
    AUTH PLAIN 'hashed user /pw'
    235 2.0.0 Authentication successful
    
    but the webmail, and mail clients (OS X mail.app and Outlook 2003) can not receive or send. I have sent several mails from clients i know to be working that never reach the mailbox that i can see. Please help, this is driving me nuts.
     
  13. Br8knitOFF

    Br8knitOFF New Member

    What is the domain name? Do you have MX records setup that point to your new server? If so, do you have a firewall in front of it? If so, do you have tcp 25 open and pointing to it?

    //Todd
     
  14. willieray25

    willieray25 New Member

    pressure-parts.com

    I have MX records In ISPConfig for the site set to mail.pressure-parts.com
    I have MX records setup in ZoneEdit (my external DNS) for mail.pressure-parts.com
    I have port 25 open, and pointing to my servers internal static IP
     
  15. Br8knitOFF

    Br8knitOFF New Member

    Okay- tail your mail.log, and send yourself something.

    Need to see what postfix is saying about the inbound mail, where/what it's handing it off to, etc. to track the problem down.

    'tail -f /var/log/mail.log'

    Then, send something to a vaild email address on that domain- it should look something like this:

    Sep 16 18:12:38 liasis postfix/smtpd[9112]: connect from rv-out-0506.google.com[209.85.198.237]
    Sep 16 18:12:38 liasis postfix/smtpd[9112]: C140D6E80FC: client=rv-out-0506.google.com[209.85.198.237]
    Sep 16 18:12:38 liasis postfix/cleanup[9180]: C140D6E80FC: message-id=<[email protected]>
    Sep 16 18:12:38 liasis postfix/qmgr[12852]: C140D6E80FC: from=<[email protected]>, size=2082, nrcpt=1 (queue active)
    Sep 16 18:12:38 liasis postfix/pickup[8500]: E7DD96E8125: uid=10004 from=<web7_todd>
    Sep 16 18:12:38 liasis postfix/cleanup[9180]: E7DD96E8125: message-id=<[email protected]>
    Sep 16 18:12:38 liasis postfix/qmgr[12852]: E7DD96E8125: from=<[email protected]>, size=402, nrcpt=1 (queue active)
    Sep 16 18:12:38 liasis postfix/local[9198]: E7DD96E8125: to=<[email protected]>, relay=local, delay=0.04, delays=0.02/0.01/0/0.01, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Sep 16 18:12:38 liasis postfix/qmgr[12852]: E7DD96E8125: removed
    Sep 16 18:12:43 liasis postfix/local[9181]: C140D6E80FC: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=5, delays=0.41/0.01/0/4.5, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Sep 16 18:12:43 liasis postfix/qmgr[12852]: C140D6E80FC: removed

    //Todd
     
  16. willieray25

    willieray25 New Member

    here it is:
    Code:
    # tail -f /var/log/maillog
    Sep 16 16:20:57 lianli postfix/smtp[5469]: warning: host mail.pressure-parts.com[24.180.57.228]:25 greeted me with my own hostname mail.pressure-parts.com
    Sep 16 16:20:57 lianli postfix/smtp[5469]: warning: host mail.pressure-parts.com[24.180.57.228]:25 replied to HELO/EHLO with my own hostname mail.pressure-parts.com
    Sep 16 16:20:57 lianli postfix/smtp[5469]: 2624D47EE6D: to=<[email protected]>, orig_to=<[email protected]>, relay=mail.pressure-parts.com[24.180.57.228]:25, delay=0.76, delays=0.32/0.04/0.39/0, dsn=5.4.6, status=bounced (mail for mail.pressure-parts.com loops back to myself)
    Sep 16 16:20:57 lianli postfix/smtpd[5463]: disconnect from 24-180-57-228.dhcp.rvsd.ca.charter.com[24.180.57.228]
    Sep 16 16:20:57 lianli postfix/cleanup[5468]: E35A747EE71: message-id=<[email protected]>
    Sep 16 16:20:57 lianli postfix/qmgr[5332]: E35A747EE71: from=<>, size=3380, nrcpt=1 (queue active)
    Sep 16 16:20:57 lianli postfix/bounce[5470]: 2624D47EE6D: sender non-delivery notification: E35A747EE71
    Sep 16 16:20:57 lianli postfix/qmgr[5332]: 2624D47EE6D: removed
    Sep 16 16:20:58 lianli postfix/smtp[5471]: E35A747EE71: to=<[email protected]>, relay=sbcmx3.prodigy.net[207.115.21.22]:25, delay=0.77, delays=0.01/0.02/0.71/0.03, dsn=5.3.0, status=bounced (host sbcmx3.prodigy.net[207.115.21.22] said: 553 5.3.0 flpi090 - m8GNKvi1031128, DNSBL:521< 24.180.57.228 >_is_blocked.__For_information_see_http://att.net/blocks (in reply to MAIL FROM command))
    Sep 16 16:20:58 lianli postfix/qmgr[5332]: E35A747EE71: removed
    Sep 16 16:21:33 lianli dovecot: imap-login: Login: user=<web2_cs>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
    Sep 16 16:21:33 lianli dovecot: IMAP(web2_cs): Disconnected: Logged out
    
    thanks for your help again
     
  17. willieray25

    willieray25 New Member

    looks like i sent something from pp to pp.

    heres one from [email protected] on a different server:
    Code:
    # tail -f /var/log/maillog
    Sep 16 16:29:13 lianli postfix/smtpd[5616]: disconnect from 24-180-57-228.dhcp.rvsd.ca.charter.com[24.180.57.228]
    Sep 16 16:29:13 lianli postfix/cleanup[5620]: 072FF47EE71: message-id=<[email protected]>
    Sep 16 16:29:13 lianli postfix/qmgr[5332]: 072FF47EE71: from=<>, size=3341, nrcpt=1 (queue active)
    Sep 16 16:29:13 lianli postfix/bounce[5622]: 7E1F547EE6D: sender non-delivery notification: 072FF47EE71
    Sep 16 16:29:13 lianli postfix/qmgr[5332]: 7E1F547EE6D: removed
    Sep 16 16:29:13 lianli postfix/smtp[5623]: certificate verification failed for ccs247.com: num=20:unable to get local issuer certificate
    Sep 16 16:29:13 lianli postfix/smtp[5623]: certificate verification failed for ccs247.com: num=27:certificate not trusted
    Sep 16 16:29:13 lianli postfix/smtp[5623]: certificate verification failed for ccs247.com: num=21:unable to verify the first certificate
    Sep 16 16:29:14 lianli postfix/smtp[5623]: 072FF47EE71: to=<[email protected]>, relay=ccs247.com[70.84.85.66]:25, delay=1.4, delays=0.01/0.02/0.77/0.64, dsn=2.0.0, status=sent (250 OK id=1Kfjyg-0006jQ-89)
    Sep 16 16:29:14 lianli postfix/qmgr[5332]: 072FF47EE71: removed
    Sep 16 16:29:33 lianli dovecot: imap-login: Login: user=<web2_cs>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
    Sep 16 16:29:33 lianli dovecot: IMAP(web2_cs): Disconnected: Logged out
    Sep 16 16:30:01 lianli postfix/smtpd[5616]: connect from localhost.localdomain[127.0.0.1]
    Sep 16 16:30:01 lianli postfix/smtpd[5616]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
    Sep 16 16:30:01 lianli postfix/smtpd[5616]: disconnect from localhost.localdomain[127.0.0.1]
    Sep 16 16:30:01 lianli dovecot: pop3-login: Disconnected: rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
    
    dunno if it helps, but can't hurt :D
     
  18. Br8knitOFF

    Br8knitOFF New Member

    Okay- couple of things:

    1. Looks like the IP address you're using for your MX record is blacklisted by at least AT&T, and most likely others. That will certainly contribute to email problems. If the address you're using for your MX record is a statically assigned IP address, ask your ISP to add create a PTR record for you that matches your A record:

    Non-authoritative answer:
    228.57.180.24.in-addr.arpa name = 24-180-57-228.dhcp.rvsd.ca.charter.com.


    2. You need to check your /etc/postfix/main.cf- specifically, your 'myhostname', 'mydomain' and the 'mydestination' parameters:

    "Sep 16 16:20:57 lianli postfix/smtp[5469]: 2624D47EE6D: to=<[email protected]>, orig_to=<[email protected]>, relay=mail.pressure-parts.com[24.180.57.228]:25, delay=0.76, delays=0.32/0.04/0.39/0, dsn=5.4.6, status=bounced (mail for mail.pressure-parts.com loops back to myself)"

    //Todd
     

Share This Page