EMAIL not working

Discussion in 'General' started by rdtech, Jun 6, 2008.

  1. rdtech

    rdtech New Member

    I'm still having the same problem. I can't receive the mail or send out the mail.
     
  2. Rockdrala

    Rockdrala New Member

    Till did you see anything wrong with my main.cf?
     
  3. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    netstat -tap
    ? Did you enable Maildir under Management > Server > Settings > Email?
     
  4. rdtech

    rdtech New Member

    Here is the results

    Falko,

    Maildir is on. I was following what till was telling the other guy and so I disabled maildir and waited an hour before enabling it again. I did a test mail and it disappeared.

    here is netstat -tap results

    linuxserver:~ # netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State
    PID/Program name
    tcp 0 0 *:mysql *:* LISTEN
    2183/mysqld
    tcp 0 0 *:netbios-ssn *:* LISTEN
    3858/smbd
    tcp 0 0 *:sunrpc *:* LISTEN
    3513/portmap
    tcp 0 0 *:hosts2-ns *:* LISTEN
    2782/ispconfig_http
    tcp 0 0 *:ftp *:* LISTEN
    8624/proftpd: (acce
    tcp 0 0 rdtech-online.co:domain *:* LISTEN
    3881/named
    tcp 0 0 linuxserver:domain *:* LISTEN
    3881/named
    tcp 0 0 localhost:domain *:* LISTEN
    3881/named
    tcp 0 0 *:981 *:* LISTEN
    3815/rpc.rquotad
    tcp 0 0 localhost:ipp *:* LISTEN
    3120/cupsd
    tcp 0 0 *:smtp *:* LISTEN
    8575/master
    tcp 0 0 *:afs3-callback *:* LISTEN
    2740/nxagent
    tcp 0 0 localhost:953 *:* LISTEN
    3881/named
    tcp 0 0 localhost:6010 *:* LISTEN
    16598/sshd: [email protected]
    tcp 0 0 localhost:quotad *:* LISTEN
    3554/famd
    tcp 0 0 *:microsoft-ds *:* LISTEN
    3858/smbd
    tcp 0 0 rdtech-online.com:33975 208.49.199.19:www-http ESTABLISHED
    30691/firefox-bin
    tcp 0 0 rdtech-online.com:45888 208.50.79.113:www-http ESTABLISHED
    30691/firefox-bin
    tcp 0 0 rdtech-online.com:53060 208.49.199.35:www-http ESTABLISHED
    30691/firefox-bin
    tcp 0 0 rdtech-online.com:35578 208.50.79.96:www-http ESTABLISHED
    30691/firefox-bin
    tcp 0 0 rdtech-online.com:48770 208.50.79.114:www-http ESTABLISHED
    30691/firefox-bin
    tcp 0 0 rdtech-online.com:47757 208.49.199.64:www-http ESTABLISHED
    30691/firefox-bin
    tcp 0 0 rdtech-online.com:58016 65.55.15.242:www-http ESTABLISHED
    30691/firefox-bin
    tcp 0 0 localhost:commplex-link localhost:34765 ESTABLISHED
    2740/nxagent
    tcp 0 0 localhost:38358 localhost:ssh ESTABLISHED
    2558/ssh
    tcp 0 0 localhost:34765 localhost:commplex-link ESTABLISHED
    16599/netcat
    tcp 0 0 *:imaps *:* LISTEN
    3357/couriertcpd
    tcp 0 0 *:pop3s *:* LISTEN
    3393/couriertcpd
    tcp 0 0 *:pop3 *:* LISTEN 3376/couriertcpd
    tcp 0 0 *:imap *:* LISTEN 3341/couriertcpd
    tcp 0 0 *:www-http *:* LISTEN 1177/httpd2-prefork
    tcp 0 0 *:ssh *:* LISTEN 3857/sshd
    tcp 0 0 localhost:ipp *:* LISTEN 3120/cupsd
    tcp 0 0 *:smtp *:* LISTEN 8575/master
    tcp 0 0 localhost:953 *:* LISTEN 3881/named
    tcp 0 0 localhost:6010 *:* LISTEN 16598/sshd: [email protected]
    tcp 0 0 *:https *:* LISTEN 1177/httpd2-prefork
    tcp 0 2768 linuxserver:ssh ip67-91-213-178.z:husky ESTABLISHED 16596/sshd: nx [pri
    tcp 0 0 localhost:ssh localhost:38358 ESTABLISHED 2563/sshd: [email protected]
    linuxserver:~ #
     
  5. Rockdrala

    Rockdrala New Member

    man this email is just getting bigger and bigger in /var/spool/mail

    Is there a mysql association i need to check somewhere that connects Mysql users to a specific place to download there emails?

    all my users need there email. im stumped. Everything connects fine but this email is not being recieved and the email clients give no error messages.

    No changes were made to the server, it just stopped giving email on its own.
     
  6. Hans

    Hans Moderator ISPConfig Developer

    It's not recommended to switch Maildir on/off and on again on a production server!
     
  7. Rockdrala

    Rockdrala New Member

    THis is commented out in my main.cf

    Why is the email going there then?

    Where do i put the email to download it?

    This is the based on the pefect setup for centos 5.1.

    Where should postfix be storing the emails???
     
    Last edited: Jun 11, 2008
  8. Rockdrala

    Rockdrala New Member

    Till told me to do it >.>

    i have at least got to extract these administrative emails or place them in the correct que folder so people get them. Where is the email's supposed to be stored if ispconfig doesnt store them in /var/spool/mail.

    Where is mailuser option supposed to be storing them?
     
    Last edited: Jun 11, 2008
  9. rdtech

    rdtech New Member

    I'm testing everything before it goes on production. I need it working. Does the ISPconfig PERFECT setup works after following the installation or is there more configuration to it.
     
  10. Rockdrala

    Rockdrala New Member

    If i uncomment
    Code:
    # The mail_spool_directory parameter specifies the directory where
    # UNIX-style mailboxes are kept. The default setting depends on the
    # system type.
    #
    #mail_spool_directory = /var/mail
    #mail_spool_directory = /var/spool/mail
    to attemp to download our emails, Will it break the mailuser option and make things worse?
     
  11. rdtech

    rdtech New Member

    Rockdrala,

    Did you install everything using the Perfect setup? Did your mail worked at first?
    I might be missing sometihng
     
  12. Rockdrala

    Rockdrala New Member

    Yes it does.

    I used the perfect setup on centos 5.1 and have been running it on VMware for months with no issues.

    Ive been using ISPconfig for months and its been working well. I havent had a serious issue until. The only issues ive had with ispconfig are all third party plugin related like Remoting Plugins.

    This is the first serious issue ive had. No one touched the server, no one got error messages from there email clients telling them they couldnt connect, the email just wasnt being download or found.

    It was working great up until June 8th then bam no emails.
    Email clients were still connecting to the server and not giving no errors.
    But no email is to be found.

    I dont know why it would start going to /var/spool/email if thats not the intended directory for using the "mailuser" option.

    The server wasnt touched internally by any staff. There seems to be a few hack attempts out of Korea but they dont seem to have stolen or used the server to send spam.

    I need to know about the ispconfig mail structure and how it stores email's using the mailuser subsystem by ISPconfig to temporary move people's email and permenantley put in a solution to to get everyone there email.
     
  13. rdtech

    rdtech New Member

    okay That sounds good. I followed the Perfect setup for Suse. Maybe I should redo the server with Centos 5
     
  14. Rockdrala

    Rockdrala New Member

  15. rdtech

    rdtech New Member

    I've done that and its never worked for me.
     
  16. Rockdrala

    Rockdrala New Member

    The one email account that does work out of all of them has a file in it called
    dovecot-uidlist

    in web1/user/web1_account/maildir

    i asked around and someone told me that the ISPconfig is not linking the uid list to the naming convention (web1_namehere). and i need to ask you guys how to correct the connection between the uid and the naming convention (web1_namehere). Until then all my emails are going to sit in /var/spool/mail.
     
  17. Rockdrala

    Rockdrala New Member

    I wish i would have heard this sooner. The email accounts that are not working dont have a procmail file. What controls the generation of this file?
     
  18. falko

    falko Super Moderator ISPConfig Developer

    Please try this:

    Code:
    postconf -e 'home_mailbox = Maildir/'
    postconf -e 'mailbox_command ='
    /etc/init.d/postfix restart
     
  19. Rockdrala

    Rockdrala New Member

    no one wuvs meh o0o
     
  20. Rockdrala

    Rockdrala New Member

    I had to open all those emails that went /var/spool/mail

    and had to glean emails out of large single files with a notepad.


    Allright till / falko This is what i did.

    I deleted the email address in ispconfig. And then i restored the email address out of the recycle bin and it works now.

    Now tell me what caused this so it can be secured?

    By deleting and restoring the email address out of ispconfig refreshes what?

    Help me out here. I don't wanna pick through 80 mb files with a txt pad ever again.
     

Share This Page