Email not working after fresh install of Ubuntu server

Discussion in 'Installation/Configuration' started by Dennis_sp, Apr 5, 2018.

  1. Dennis_sp

    Dennis_sp New Member

    I created a new VPS with Ubuntu 17.10 and followed this guide installing ISPConfig 3.1:
    https://www.howtoforge.com/tutorial...l-pureftpd-bind-postfix-doveot-and-ispconfig/
    By the way, my compliments for this guide, excellent!

    However e-mail is not working. What i did was:

    1. Created a domain under Email>Domains
    2. Created an Email mailbox under that domain
    3. Pointed my MX records to my A record and my A record to the IP of my VPS
    4. Opend Roundcube webmail and tried to send an email but it's stuck on the Sending... popup, no error
    5. Sent an email from my mail client to the email address that i had created, i do not get a bounce so i assume the e-mail is arriving somewhere but looking at the Statistics>Mailbox traffic menu everything is 0.
    I'm using Dovecot daemon.

    I do not see anything relevant in mail.log. I only see this when i'm trying to send an email:


    Apr 5 16:55:04 noc dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=::1, lip=::1, secured, session=<4aDyHxtpur8AAAAAAAAAAAAAAAAAAAAB>
    Apr 5 16:55:04 noc dovecot: imap-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=::1, lip=::1, secured, session=<KN3yHxtpgJgAAAAAAAAAAAAAAAAAAAAB>
    Apr 5 16:55:06 noc postfix/smtps/smtpd[667]: connect from localhost[::1]
    Apr 5 16:55:06 noc postfix/smtps/smtpd[667]: SSL_accept error from localhost[::1]: lost connection
    Apr 5 16:55:06 noc postfix/smtps/smtpd[667]: lost connection after CONNECT from localhost[::1]
    Apr 5 16:55:06 noc postfix/smtps/smtpd[667]: disconnect from localhost[::1] commands=0/0
    Apr 5 16:55:14 noc postfix/smtps/smtpd[667]: connect from localhost[::1]
    Apr 5 16:55:21 noc dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=::1, lip=::1, mpid=712, secured, session=<b0bxIBtphpgAAAAAAAAAAAAAAAAAAAAB>
    Apr 5 16:55:21 noc dovecot: imap([email protected]): Logged out in=50 out=505
    Apr 5 16:56:21 noc dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=::1, lip=::1, mpid=736, secured, session=<GtiCJBtpiJgAAAAAAAAAAAAAAAAAAAAB>
    Apr 5 16:56:21 noc dovecot: imap([email protected]): Logged out in=50 out=505
    Apr 5 16:57:21 noc dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=::1, lip=::1, mpid=784, secured, session=<WbgWKBtpipgAAAAAAAAAAAAAAAAAAAAB>
    Apr 5 16:57:21 noc dovecot: imap([email protected]): Logged out in=50 out=505
    Apr 5 16:57:36 noc dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=::1, lip=::1, mpid=789, secured, session=<7Df+KBtpjJgAAAAAAAAAAAAAAAAAAAAB>
    Apr 5 16:57:36 noc dovecot: imap([email protected]): Logged out in=32 out=485
    Apr 5 16:57:36 noc dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=::1, lip=::1, mpid=794, secured, session=<0m//KBtpjpgAAAAAAAAAAAAAAAAAAAAB>
    Apr 5 16:57:36 noc dovecot: imap([email protected]): Logged out in=44 out=592
    Apr 5 16:57:52 noc postfix/smtps/smtpd[807]: connect from localhost[::1]


    I used the ISPConfig test to create a diagnostic report:

    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    [WARN] could not determine server's ip address by ifconfig
    [INFO] ISPConfig is installed.

    ##### ISPCONFIG #####
    ISPConfig version is 3.1dev


    ##### VERSION CHECK #####

    [INFO] php (cli) version is 7.1.15-0ubuntu***.***.***.***

    ##### PORT CHECK #####

    [WARN] Port 465 (SMTP server SSL) seems NOT to be listening

    ##### MAIL SERVER CHECK #####

    [WARN] I found no "submission" entry in your postfix master.cf
    [INFO] this is not critical, but if you want to offer port 587 for smtp connections you have to enable this.
    [WARN] I found no "smtps" entry in your postfix master.cf
    [INFO] this is not critical, but if you want to offer SSL for smtp (not TLS) connections you have to enable this.

    ##### RUNNING SERVER PROCESSES #####

    [INFO] I found the following web server(s):
    Apache 2 (PID 908)
    [INFO] I found the following mail server(s):
    Postfix (PID 17485)
    [INFO] I found the following pop3 server(s):
    Dovecot (PID 17574)
    [INFO] I found the following imap server(s):
    Dovecot (PID 17574)
    [INFO] I found the following ftp server(s):
    PureFTP (PID 17659)

    ##### LISTENING PORTS #####
    (only ()
    Local (Address)
    [localhost]:10024 (17534/amavisd-new)
    [localhost]:10025 (17485/master)
    [localhost]:10026 (17534/amavisd-new)
    [localhost]:10027 (17485/master)
    [localhost]:11211 (10138/memcached)
    [anywhere]:5355 (434/systemd-resolve)
    [anywhere]:110 (17574/dovecot)
    [anywhere]:143 (17574/dovecot)
    [anywhere]:10000 (3155/perl)
    ***.***.***.***:53 (17663/named)
    [localhost]:53 (17663/named)
    [anywhere]:21 (17659/pure-ftpd)
    [anywhere]:22 (693/sshd)
    [localhost]:953 (17663/named)
    [anywhere]:25 (17485/master)
    [anywhere]:993 (17574/dovecot)
    [anywhere]:995 (17574/dovecot)
    [localhost]:10023 (6772/postgrey)
    *:*:*:*::*:10024 (17534/amavisd-new)
    *:*:*:*::*:9000 (3038/hhvm)
    *:*:*:*::*:10026 (17534/amavisd-new)
    *:*:*:*::*:3306 (17282/mysqld)
    *:*:*:*::*:5355 (434/systemd-resolve)
    [localhost]10 (17574/dovecot)
    [localhost]43 (17574/dovecot)
    *:*:*:*::*:8080 (908/apache2)
    *:*:*:*::*:80 (908/apache2)
    *:*:*:*::*:8081 (908/apache2)
    *:*:*:*::*:53 (17663/named)
    *:*:*:*::*:21 (17659/pure-ftpd)
    *:*:*:*::*:22 (693/sshd)
    *:*:*:*::*:953 (17663/named)
    *:*:*:*::*:25 (17485/master)
    *:*:*:*::*:443 (908/apache2)
    *:*:*:*::*:993 (17574/dovecot)
    *:*:*:*::*:995 (17574/dovecot)
    *:*:*:*::*:10023 (6772/postgrey)




    ##### IPTABLES #####
    Chain INPUT (policy ACCEPT)
    target prot opt source destination
    f2b-dovecot-pop3imap tcp -- [anywhere]/0 [anywhere]/0 multiport dports 110,995,143,993
    f2b-pureftpd tcp -- [anywhere]/0 [anywhere]/0 multiport dports 21
    f2b-postfix-sasl tcp -- [anywhere]/0 [anywhere]/0 multiport dports 25
    f2b-sshd tcp -- [anywhere]/0 [anywhere]/0 multiport dports 22

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    Chain f2b-dovecot-pop3imap (1 references)
    target prot opt source destination
    RETURN all -- [anywhere]/0 [anywhere]/0

    Chain f2b-postfix-sasl (1 references)
    target prot opt source destination
    RETURN all -- [anywhere]/0 [anywhere]/0

    Chain f2b-pureftpd (1 references)
    target prot opt source destination
    RETURN all -- [anywhere]/0 [anywhere]/0

    Chain f2b-sshd (1 references)
    target prot opt source destination
    REJECT all -- ***.***.***.*** [anywhere]/0 reject-with icmp-port-unreachable
    RETURN all -- [anywhere]/0 [anywhere]/0
     
  2. Dennis_sp

    Dennis_sp New Member

    I would really appreciate if someone could help me out here because i can't use my ISPConfig installation if e-mail doesn't work. After i made the post above i received this bounce message a few days later:

    The recipient server did not accept our requests to connect. [smtp.suite-crm.nl. ---ipaddress---: unable to read banner] [smtp.suite-crm.nl. ---ipaddress---: unable to read banner]
     
  3. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

    did you skip something? usually you are getting instructed to do some changes in that file to enable TLS for smtp and submission ports?
    Maybe you missed something else aswell?

    Have you tried a second time - really step by step - on a spare machine and compared the main/master cf?
    How do your master/main files look? ( attachement )
    What's in the mail.info after you did restart amavisd/dovecot/postfix ?
     
  4. Dennis_sp

    Dennis_sp New Member

    Thanks for your reply!

    I checked the tutorioal again but i have done the steps mentioned in step 6 correctly. My master.cf looks exactly like in the tutorial.
    I did these 3 commands to restart the services you mentioned:
    service postfix restart
    sudo /etc/init.d/amavis restart
    /etc/init.d/dovecot restart

    See attached the cf files. I can't locate mail.info. Where should it be?
     

    Attached Files:

  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Check the smtps line and the submision line. The tutorial shows that you have to remove the # in front of these two lines while your master.cf has # in front of them.
     
    ztk.me likes this.
  6. Dennis_sp

    Dennis_sp New Member

    Thank you so much! It's working now! The thing is with that file is that i was focused on the lines underneath those 2 sections and didn't notice i had to uncomment the sections themselves as well. Hooray! :)
     
    till and ztk.me like this.

Share This Page