Email not working after clean installation

Discussion in 'Installation/Configuration' started by Blaasbalg, Nov 18, 2013.

  1. Blaasbalg

    Blaasbalg Member

    Hi all,

    I've successfully installed ISPConfig on a CentOS 6.4 server (using this tutorial), and everything appears to be working fine, except for e-mail.

    Unfortunately I'm not very experienced with mail servers, so I don't really know where to start looking.

    Basically, I can not log in on my mail accounts.
    Outlook, nor Squirrelmail seem to work. When I try to login via Squirrelmail it takes a very long time to load, eventually resulting in a Gateway Time-out. Same story for outlook, it's trying to connect for quite some time, without success. (Time-out).

    I've checked my DNS and firewall settings (I use the CentOS firewall), but they appear to be fine.

    Here are my DNS records (using an example IP address and domain):

    @ MX 10 mail.domain.tld.
    mail A
    It's a clean installation. I closely followed the tutorial and I haven't changed anything yet.

    What could be the cause of this issue?

    Thanks in advance!
    Last edited: Nov 18, 2013
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which error messages do you get in /var/log/maillog ?
  3. Blaasbalg

    Blaasbalg Member

    Sorry, I couldn't include the log file as text in my post, I keep getting "The message you have entered is too short. Please lengthen your message to at least 10 characters." when I try to, even though I have enough text (also outside the code tags).

    I couldn't attach it as a .txt either because it's too large, so I had to zip it.
    It's not the entire log file, I've only included the log entries of yesterday, when I tried to log in.

    Anyway, there are a few errors in the log file, but I'm not sure how bad and relevant they are.

    Last edited: Nov 19, 2013
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please execute these commands on your server:

    ln -s /etc/dovecot/dovecot-sql.conf /etc/dovecot-sql.conf
    ln -s /etc/dovecot/dovecot.conf /etc/dovecot.conf
    /etc/init.d/dovecot restart
    /etc/init.d/postfix restart

    and test the mail system again.
  5. Blaasbalg

    Blaasbalg Member

    Working like a charm! :)

    So basically (correct me if I'm wrong), ISPConfig writes the config to /etc/dovecot/dovecot.conf, while the server tries to read from /etc/dovecot.conf?

    Thank you for the awesome support till! :)
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes. I'am not sure if the problem is caused by a change in the last ispconfig version (as it worked at the time we wrote the centos guide) or by a change in the dovecot package from centos. In any way, we will correct it with the next ispconfig update.

Share This Page