Email not flowing...

Discussion in 'Installation/Configuration' started by tonysch, Jun 25, 2009.

  1. tonysch

    tonysch New Member

    I have setup a fresh install of ISPconfig 3 on Ubuntu 9.04, per the perfect server doc... All went well, no problems.
    When I attempt to send or receive email, I am unable to either way. I also do not receive NDRs on either side.
    I can telnet to port 25 with proper results.

    Here is my mail log from a few tests...

    Any help would be greatly appreciated.
    Thanks
    Tony

    Jun 25 01:37:36 srv03 postfix/qmgr[3309]: 8EBE4893F: from=<tschnellbach@gmail.com>, size=1863, nrcpt=1 (queue active)
    Jun 25 01:37:36 srv03 postfix/error[18504]: 8EBE4893F: to=<tony@schnellit.com>, relay=none, delay=0.39, delays=0.33/0.01/0/0.05, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    Jun 25 01:38:06 srv03 postfix/smtpd[18499]: disconnect from mail-ew0-f221.google.com[209.85.219.221]
     
  2. wouterw

    wouterw New Member

    Check this topic. You probably don't have amavis / clamav installed or activated.
     
  3. tonysch

    tonysch New Member

    Is there any where (documentation) on what processes should/shouldn't be installed and running?
    Also, is there any documentation on POST ISPconfig install or admin guides?

    OK I followed the link...
    I restarted clanmav... OK
    I restarted amavis...
    Stopping amavisd: (not running).
    Starting amavisd: Problem in Amavis::DKIM code: Can't locate Crypt/OpenSSL/RSA.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.0 /usr/local/share/perl/5.10.0 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl) at (eval 82) line 27.
    BEGIN failed--compilation aborted at (eval 82) line 27.
    (failed).
     
  4. till

    till Super Moderator

  5. tonysch

    tonysch New Member

    That is what I followed... to the "T". :)
    Even copy/pasted all the scripts... :)

    Thanks
    Tony
     
  6. wouterw

    wouterw New Member

  7. tonysch

    tonysch New Member

    That fixed her right up... :)

    Thank you
     
  8. Stown

    Stown ISPConfig Developer

    I have sort of the same problem on my centOS server.

    This is what i have:
    [root@server1 scripts]# /etc/init.d/amavisd restart
    Shutting down Mail Virus Scanner (amavisd): [ OK ]
    Starting Mail Virus Scanner (amavisd): fetch_modules: error loading optional module Mail/SpamAssassin/Plugin/DKIM.pm:
    Can't locate Mail/DKIM.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8) at /usr/lib/perl5/vendor_perl/5.8.8/Mail/SpamAssassin/Plugin/DKIM.pm line 77.
    BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.8.8/Mail/SpamAssassin/Plugin/DKIM.pm line 77.
    Compilation failed in require at /usr/sbin/amavisd line 197.
    [ OK ]

    I cannot find any package named libmail-dkim-perl for centOS?
     
  9. till

    till Super Moderator

  10. micheal-808

    micheal-808 New Member

    I am having a similar Problem with amavis when following step by step the installation guide from The Perfect OpenSUSE 11.1 Server

    The following error message:

    Code:
    atom035:/usr/sbin # /etc/init.d/amavis start
    Starting virus-scanner (amavisd-new): fetch_modules: error loading optional module MIME/Decoder/BinHex.pm:
      Can't locate Convert/BinHex.pm in @INC (@INC contains: /usr/lib/perl5/5.10.0/i586-linux-thread-multi /usr/lib/perl5/5.10.0 /usr/lib/perl5/site_perl/5.10.0/i586-linux-thread-multi /usr/lib/perl5/site_perl/5.10.0 /usr/lib/perl5/vendor_perl/5.10.0/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl) at /usr/lib/perl5/vendor_perl/5.10.0/MIME/Decoder/BinHex.pm line 43.
      BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.10.0/MIME/Decoder/BinHex.pm line 43.
     [COLOR="DarkGreen"] Compilation failed in require at /usr/sbin/amavisd line 197.
      The value of variable $myhostname is "atom035", but should have been
      a fully qualified domain name; perhaps uname(3) did not provide such.
      You must explicitly assign a FQDN of this host to variable $myhostname
      in amavisd.conf, or fix what uname(3) provides as a host's network name![/COLOR]
    
    I dont know at all what i have to do, only the last part of the error file was fixed by myseld

    Code:
    [COLOR="DarkGreen"]Compilation failed in require at /usr/sbin/amavisd line 197.
      The value of variable $myhostname is "atom035", but should have been
      a fully qualified domain name; perhaps uname(3) did not provide such.
      You must explicitly assign a FQDN of this host to variable $myhostname
      in amavisd.conf, or fix what uname(3) provides as a host's network [/COLOR]name!
    It was not hard to define the hostname in the config file but i still get the whole error message!

    I hope someone can help me out!

    Thanks

    ---

    EDIT:

    Ive worked some of the problems out with installing:

    perl-Convert-BinHex

    The only Problem now is this:

    Code:
    Compilation failed in require at /usr/sbin/amavisd line 197.
      The value of variable $myhostname is "atom035", but should have been
      a fully qualified domain name; perhaps uname(3) did not provide such.
      You must explicitly assign a FQDN of this host to variable $myhostname
      in amavisd.conf, or fix what uname(3) provides as a host's network name!
    But i am wondering! Ive modified the amavisd.conf file and have added the correct host in Line 152 and this error still appears
     
    Last edited: Aug 18, 2009
  11. till

    till Super Moderator

    You have to set the correct hostname in opensuse. You can test the settings with:

    hostname

    and

    hostname -f

    both commands have to return the fully qualified domain name of the server.
     

Share This Page