Email Marked as Spam due to DNS error

Discussion in 'Installation/Configuration' started by Vince Dimanno, Dec 8, 2018.

  1. Vince Dimanno

    Vince Dimanno New Member

    I am new to ISPConfig, but not new to server management. I'm having an issue that is confusing me. I migrated to a new server running ISPConfig 3 and set the server up according to the Perfect Server instructions, etc. All web sites I've moved to the server are behaving properly. However, I'm having issues with some email being marked as spam.

    I currently have all domains on a single IP address, and all of those domains use GoDaddy as their nameservers. Each domain record is correctly formatted with SPF, DKIM and DMARC records. They all have correct MX Records too. However, a client was hearing that his email was being marked as Spam after switching servers and this was not happening prior to the switch. Testing confirmed this and also that some email was not being delivered at all. Likely, this is due to being filtered out by an even more stringent spam filter.

    The only thing I can see that could possible cause this is that the MX records do not have matching IP addresses when attempting a rDNS lookup.

    I can't configure a rDNS entry with GoDaddy, and I don't use their Mail Servers. My machine has a single IP address and I have not configured my own nameservers. So, since I have many domains using the one machine IP address, does anyone have any idea how I might resolve this issue?

    Thanks in advance!!!
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  3. Vince Dimanno

    Vince Dimanno New Member

    Thanks Taleman! The IP is clean and all associated domains. As I've continued my research, I think I can explain this better...

    The provider of my IP address gives me direct control over a single rDNS entry. So, I can make an entry like this:

    123.456.789.000 -->

    and the reverse dns will resolve to the domain name I enter. But I have multiple domains running on the single IP address.

    If I ran my own nameservers, I would then create a DNS zone for "" and enter in all the PTR records for all my domains, as per the instructions in your link above. However, I have all my domain DNS Zones at GoDaddy. They don't provide the option of entering a PTR entry, only TXT entries.

    So, is my only solution the setting up of my own nameservers? Then I can enter my own DNS Zones in ISPConfig and include PTR records, etc. Or is there some way I can make this work with GoDaddy as the Authoritative Name Server for all my domains, but still have web sites and email on my ISPConfig server?
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Make the PTR-record point to your mail server FQDN. Use these to see an examples:
    If you have many mail servers, I believe you need for each its own IP-address.
    Last edited: Dec 9, 2018
  5. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    or just use the same server-name for all domains. there is no need to configure an individiual mailname for each mail-domain
  6. Vince Dimanno

    Vince Dimanno New Member

    I was hoping to avoid that. Having one mail server name for all domains is the way GoDaddy sets up their system. No one uses their own domain as their mail server name. I can do that, or I can become my own nameserver...these seem to be my only options. Of course, that is barring the assigning of a unique IP address to each domain.

    Any other ideas from anyone, or have I pretty much exhausted possibilities here?
    Thank you!
  7. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    You do not say what you hope to avoid.
    If this is the situation now, and if I understood correctly what you wanted to do, you need do what I wrote in #4.
    You wrote you can
    Instead of put there, that is your e-mail servers fully qualified domain name.
    That makes the rDNS match your mail servers hostname, and if you put that fqdn to all MX records of your domains, then mail servers hostname matches MX records, and hopefully also what you put in SPF.

Share This Page