Email links not working

Discussion in 'Installation/Configuration' started by Csaba Bocskai, Aug 12, 2021.

  1. Csaba Bocskai

    Csaba Bocskai New Member

    Hi all,

    Email related links are not working on the left side of the panel.
    Anything else is fine.
    I suspect an update-related issue.
    In case it matters, my webmail is at domain.tld/rainmail
    Thank you!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Check your webserver config, you have probably have an alias for /webmail set somewhere.
     
  3. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Rather, check for a /mail alias ;)
     
    till likes this.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Ahh, yes. /mail of course :)
     
  5. Csaba Bocskai

    Csaba Bocskai New Member

    Which config file has it?
    I checked in sites-available and in alias.conf
    OS is Debian 10
     
  6. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    You need to check and see if you created one, and remove it if so. Ispconfig uses /mail for all the mail tab urls.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    You can try to locate that file using this command:

    grep -r -n '/mail' /etc/apache2/
     
  8. Csaba Bocskai

    Csaba Bocskai New Member

    Thank you!
    I found the Alias. It was in ispconfig.vhost. It was not created by me. At least not in command line.
    I solved that issue but mxtoolbox still presents other issues.
     
  9. Chris_UK

    Chris_UK Active Member HowtoForge Supporter

    I have found mxtoolbox to be very useful in the past, so you have chosen a good tool for it, just deal with one issue at a time. anything dns related leave alone if its a new domain/record that is causing it and recheck it after a day or two.
     

Share This Page