email host name causes spam problem

Discussion in 'Installation/Configuration' started by tjd, Feb 6, 2008.

  1. tjd

    tjd New Member

    I must be thick, but I can't see how to get postfix to simply send an email with a header that ONLY mentions the virtual host as the source host of an email.

    Presently I am getting a lot of trasmissions flagged as spam because they emanate from "serverhostname" (the actual server), and its IP address, while the from line is carrying the the FQDN and IP address of the virtual domain.

    I have external dns servers with each virtual domain having its own IP address and the records in each zone file are like:

    inet A mail.this .dom.tld
    MX 10 mail.this.dom.tld

    reverse pointers for each tld

    My mail header "Received from" shows the mail as being from the ip address of the "serverhostname (101.101`

    I would really like "Received from" in the header to show "mail.this.dom.tld,.com). Then perhaps I wouldn't get spam rated, or spam bucketed emails.

    Does this contravene some rfc or another, and if not, or how to do it?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    It is the normal and correct behavoiur that postfix uses the hostname of the server and not the virtualhost domain for sending. I dont think that you can change that and its not nescessary to change it.

    1) Make sure that your hostname and IP is not blacklisted.
    2) Make sure that your ISP, the one were you get the IP adddress from, sets a reverse record for this IP pointing to the hostname of your server.
    3) Setup SPF records for all virtual domains that authorize the hostname of your server offivially as mail exchanger for these domains.
  3. tjd

    tjd New Member

    Found out the real problem, help!!

    I was misunderstanding my problem (no change there). The problem is in fact in my server config, and has nothing to do with the hostname.

    I created a new user [email protected]
    I set new user up in thunderbird and sent a test mail from a bt user account I have. Nothing received.

    Clicked "get mail" a few times in my normally patient manner and received a message: Can not stat inbox: no inbox for user" from the MTA (I guess)

    Went and had a look in /var/spool/mail - the mailbox was there, indeed, with correct permissions and all. A "ls" says there are 2 or 3k of messages in it, and if I vi it, the messages I sent are in there. But postfix can't see it.

    all this appears to have happened when we hardened the server in response to a BFA the other day. May be coincidental.

    Next question am I right pop3 does not require the use mailbox option to be ticked does it?

    Any ideas?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    If you use courier or dovecot as pop3 / imap server, you will have to enable the maildir checkbox in ispconfig under management > server > settings.

Share This Page