Email help and settings

Discussion in 'General' started by m0ealpha, Dec 16, 2006.

  1. m0ealpha

    m0ealpha New Member

    Hi

    Im having a little trouble with ISPConfig and postfix, first I followed the perfect howto for Dapper and all seemed to of gone well my fist question is this:

    What are the mail settings for email clients like outlook, thunderbird etc etc with my other domain i login to Cpanel and just add the account and it tells you some thing like:
    Code:
    username = user+domain
    mail client settings = mail.domain.com
    My next question is this for some reason some thing is telling me that my main.cf is wrong so i wounder if a postfix guru could take a quick look and see if you can spot any thing wrong?

    Code:
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version
    
    
    # Debian specific:  Specifying a file name will cause the first
    # line of that file to be used as the name.  The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname
    
    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no
    
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    
    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
    
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.
    
    myhostname = phoenix.ixl2.org
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination = phoenix.ixl2.org, localhost.ixl2.org, , localhost
    relayhost = 
    mynetworks = 127.0.0.0/8
    mailbox_command = 
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = ipv4
    smtpd_sasl_local_domain = 
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    
    virtual_maps = hash:/etc/postfix/virtusertable
    
    mydestination = /etc/postfix/local-host-names
    home_mailbox = Maildir/
    
    Thanks for any help you can provide :).
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Mail settings:

    Use the domain name as smtp and pop3 server and the username (web[ID]_user) as username and the password you entered as password.

    2) main.cf problem. Please post the exact error message you got.
     
  3. m0ealpha

    m0ealpha New Member

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Enter [email protected] in the forward field in the settings of [email protected].

    But I guess what you want is a alias, so that both emails get to the same mailbox. In this case add test in the alias field if the email address [email protected]
     
  5. m0ealpha

    m0ealpha New Member

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes. Just add the part before the @ sign in the alias field. have a look at the manuals too, it is described there :)
     
  7. m0ealpha

    m0ealpha New Member

    Sorry i meant to say my main email is [email protected] and i want to receive [email protected] do i add test in [email protected] alias?
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes. Why dont you just try it, its really simple.
     
  9. m0ealpha

    m0ealpha New Member

    I already had, i made a typo lol i was just coming back to edit that post then.

    Thanks trill
     

Share This Page