Email greylisting issue after update to ispconfig 3.1

Discussion in 'Installation/Configuration' started by red281gt, Oct 14, 2016.

  1. red281gt

    red281gt New Member

    After the upgrade I am having this issue with greylisting:

    Previously, before the upgrade, I configured postfix to use postgrey for greylisting. now that ispconfig 3.1 has an option for greylisting I have enabled it for my email account and now i get this error when trying to send mail to that account:

    connect from mail-oi0-f54.google.com[209.85.218.54]
    Oct 14 11:29:00 bhost1 postfix/smtpd[2207]: NOQUEUE: filter: RCPT from mail-oi0-f54.google.com[209.85.218.54]: <gmailname@gmail.com>: Sender address triggers FILTER amavis:[127.0.0.1]:10026; from=<gmailname@gmail.com> to=<me@mydomain.com> proto=ESMTP helo=<mail-oi0-f54.google.com>
    Oct 14 11:29:00 bhost1 postfix/smtpd[2207]: NOQUEUE: filter: RCPT from mail-oi0-f54.google.com[209.85.218.54]: <gmailname@gmail.com>: Sender address triggers FILTER amavis:[127.0.0.1]:10024; from=<gmailname@gmail.com> to=<me@mydomain.com> proto=ESMTP helo=<mail-oi0-f54.google.com>
    Oct 14 11:29:00 bhost1 postfix/smtpd[2207]: warning: connect to 127.0.0.1:10023: Connection refused
    Oct 14 11:29:00 bhost1 postfix/smtpd[2207]: warning: problem talking to server 127.0.0.1:10023: Connection refused
    Oct 14 11:29:01 bhost1 postfix/smtpd[2207]: warning: connect to 127.0.0.1:10023: Connection refused
    Oct 14 11:29:01 bhost1 postfix/smtpd[2207]: warning: problem talking to server 127.0.0.1:10023: Connection refused
    Oct 14 11:29:01 bhost1 postfix/smtpd[2207]: NOQUEUE: reject: RCPT from mail-oi0-f54.google.com[209.85.218.54]: 451 4.3.5 Server configuration problem; from=<gmailname@gmail.com> to=<me@mydomain.com> proto=ESMTP helo=<mail-oi0-f54.google.com>
    Oct 14 11:29:01 bhost1 postfix/smtpd[2207]: disconnect from mail-oi0-f54.google.com[209.85.218.54]
    in the firewall setting of ispconfig port 10023 is added to allow access.

    Now, when i uncheck the enable greylist option for the account the mail is delivered fine.
    my master.cf
    # Postfix master process configuration file. For details on the format
    # of the file, see the master(5) manual page (command: "man 5 master").
    #
    # Do not forget to execute "postfix reload" after editing this file.
    #
    # ==========================================================================
    # service type private unpriv chroot wakeup maxproc command + args
    # (yes) (yes) (yes) (never) (100)
    # ==========================================================================
    smtp inet n - n - - smtpd
    # ==========================================================================
    # Added for hardening
    smtpd pass - - n - - smtpd
    # -o ... # Parameters moved from smtp service to the new smtpd service.(if any)
    #smtp inet n - n - 1 postscreen
    #tlsproxy unix - - n - 0 tlsproxy
    #dnsblog unix - - n - 0 dnsblog
    # ==========================================================================
    submission inet n - n - - smtpd
    -o smtpd_tls_security_level=encrypt
    -o smtpd_sasl_auth_enable=yes
    -o smtpd_client_restrictions=permit_sasl_authenticated,permit_mynetworks,check_relay_domains,reject
    # -o milter_macro_daemon_name=ORIGINATING
    smtps inet n - n - - smtpd
    # -o smtpd_tls_wrappermode=yes
    # -o smtpd_sasl_auth_enable=yes
    # -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    # -o milter_macro_daemon_name=ORIGINATING
    #628 inet n - n - - qmqpd
    pickup fifo n - n 60 1 pickup
    cleanup unix n - n - 0 cleanup
    qmgr fifo n - n 300 1 qmgr
    #qmgr fifo n - n 300 1 oqmgr
    tlsmgr unix - - n 1000? 1 tlsmgr
    rewrite unix - - n - - trivial-rewrite
    bounce unix - - n - 0 bounce
    defer unix - - n - 0 bounce
    trace unix - - n - 0 bounce
    verify unix - - n - 1 verify
    flush unix n - n 1000? 0 flush
    proxymap unix - - n - - proxymap
    proxywrite unix - - n - 1 proxymap
    smtp unix - - n - - smtp
    # When relaying mail as backup MX, disable fallback_relay to avoid MX loops
    relay unix - - n - - smtp
    -o smtp_fallback_relay=
    # -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
    showq unix n - n - - showq
    error unix - - n - - error
    retry unix - - n - - error
    discard unix - - n - - discard
    local unix - n n - - local
    virtual unix - n n - - virtual
    lmtp unix - - n - - lmtp
    anvil unix - - n - 1 anvil
    scache unix - - n - 1 scache
    #
    # ====================================================================
    # Interfaces to non-Postfix software. Be sure to examine the manual
    # pages of the non-Postfix software to find out what options it wants.
    #
    # Many of the following services use the Postfix pipe(8) delivery
    # agent. See the pipe(8) man page for information about ${recipient}
    # and other message envelope options.
    # ====================================================================
    #
    # maildrop. See the Postfix MAILDROP_README file for details.
    # Also specify in main.cf: maildrop_destination_recipient_limit=1
    #
    maildrop unix - n n - - pipe
    flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient} ${extension} ${recipient} ${user} ${nexthop} ${sender}
    #
    # ====================================================================
    #
    # The Cyrus deliver program has changed incompatibly, multiple times.
    #
    #old-cyrus unix - n n - - pipe
    # flags=R user=cyrus argv=/usr/lib/cyrus-imapd/deliver -e -m ${extension} ${user}
    #
    # ====================================================================
    #
    # Cyrus 2.1.5 (Amos Gouaux)
    # Also specify in main.cf: cyrus_destination_recipient_limit=1
    #
    #cyrus unix - n n - - pipe
    # user=cyrus argv=/usr/lib/cyrus-imapd/deliver -e -r ${sender} -m ${extension} ${user}
    #
    # ====================================================================
    #
    # See the Postfix UUCP_README file for configuration details.
    #
    #uucp unix - n n - - pipe
    # flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
    #
    # ====================================================================
    #
    # Other external delivery methods.
    #
    #ifmail unix - n n - - pipe
    # flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
    #
    #bsmtp unix - n n - - pipe
    # flags=Fq. user=bsmtp argv=/usr/local/sbin/bsmtp -f $sender $nexthop $recipient
    #
    #scalemail-backend unix - n n - 2 pipe
    # flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store
    # ${nexthop} ${user} ${extension}
    #
    mailman unix - n n - - pipe
    flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
    ${nexthop} ${user}
    dovecot unix - n n - - pipe
    flags=DROhu user=vmail:vmail argv=/usr/libexec/dovecot/deliver -f ${sender} -d ${user}@${nexthop}
    amavis unix - - - - 2 smtp
    -o smtp_data_done_timeout=1200
    -o smtp_send_xforward_command=yes
    -o smtp_tls_security_level=none

    127.0.0.1:10025 inet n - - - - smtpd
    -o content_filter=
    -o local_recipient_maps=
    -o relay_recipient_maps=
    -o smtpd_restriction_classes=
    -o smtpd_client_restrictions=
    -o smtpd_helo_restrictions=
    -o smtpd_sender_restrictions=
    -o smtpd_recipient_restrictions=permit_mynetworks,reject
    -o mynetworks=127.0.0.0/8
    -o strict_rfc821_envelopes=yes
    -o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
    -o smtpd_tls_security_level=none
    # SPF Checking
    policy unix - n n - 0 spawn user=nobody argv=/usr/bin/perl /usr/lib/postfix/postfix-policyd-spf-perl

    127.0.0.1:10027 inet n - n - - smtpd
    -o content_filter=
    -o local_recipient_maps=
    -o relay_recipient_maps=
    -o smtpd_restriction_classes=
    -o smtpd_client_restrictions=
    -o smtpd_helo_restrictions=
    -o smtpd_sender_restrictions=
    -o smtpd_recipient_restrictions=permit_mynetworks,reject
    -o mynetworks=127.0.0.0/8
    -o strict_rfc821_envelopes=yes
    -o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
    -o smtp_send_xforward_command=yes
    -o milter_default_action=accept
    -o milter_macro_daemon_name=ORIGINATING
    -o disable_dns_lookups=yes

    Any advice?
     

    Attached Files:

  2. red281gt

    red281gt New Member

    May have fixed it. Seems like I needed to change from using the postgrey inet port to using the unix socket in the main.cf.
     

Share This Page