email going to wrong mailboxes

Discussion in 'General' started by shinzou, Dec 15, 2006.

  1. shinzou

    shinzou New Member

    I've got ISPconfig 2.2.8 installed and it works great but I noticed something wrong with the way users on different domains are receiving email that isn't addressed to them.

    Just so you are aware, I got rid of the username prefix all together. usernames are without any "web12" or "domain12" prefix.

    Here's the problem:

    I have an account at rtate@domain1.com

    If I send an email to rtate@domain6.com (and that address doesn't exist for domain6.com) then rtate@domain1.com will get it. This is the case for all the domains on the server.

    Everything in the virtualusertable seems correct . . .

    Any tips would be appreciated!
     
  2. till

    till Super Moderator

  3. shinzou

    shinzou New Member

    domain1.com is not the main domain of the server.
    catchall is not enabled for rtate.

    This behavior is system wide, regardless of catchalls. If I send an email to vross@domain6.com (if vross doesn't exist at that domain), it will get send to vross@domain1.com.

    Yeah, I looked at that page from searching the forum, but it didn't solve my issue.
     
  4. till

    till Super Moderator

    is domain6.com a co-domain of the website domain1.com?
     
  5. shinzou

    shinzou New Member

    no, domain6.com isn't a co-domain.

    if an account exists on the system, and someone sends an email to useraccount@anydomain.com and that account doesn't exist at the domain being sent to, it will go to the domain that does have that account. I hope that makes sense.
     
  6. till

    till Super Moderator

    You are talking about the usernames and not email addresses? This behaviour is normal, that you can send emails to the username, thats one of the reasons of the existance of the username prefix in ISPConfig.
     
  7. shinzou

    shinzou New Member

    This really only has to do with email being sent to addresses that shouldn't be receiving them.

    If anyone sends an email to rtate@domain6.com, but rtate doesn't have an account in domain6.com, then rtate that belongs to domain1.com will get the message.

    The proper behavior should be that the email sent to rtate@domain6.com would be dropped because there is not an rtate at that domain.
     
  8. till

    till Super Moderator

  9. shinzou

    shinzou New Member

    the usename for rtate@domain1.com would be: rtate

    all the usernames for all domains are without any prefix, but they are all unique.
    Their email address may be different from their username, but usually it's the same.
     
  10. till

    till Super Moderator

    Ok, then its exactly what i posted in post #6. If you want to get rid of it,enable the user prefix again.
     
  11. shinzou

    shinzou New Member

    thanks Till!

    I'll try adding the prefix back, create some test accounts and see if the behavior changes.

    is it possible with ISPconfig to add a Postfix filter/recipe for an account to only accept mail sent to rtate@domain1.com, and reject rtate@domain6.com?
    rtate@domain6.com doesn't exist and many of my users are getting spam from other domains on the system.
     
  12. shinzou

    shinzou New Member

    you're right, when I added the prefix to an account, then tried to send an email to it, but via a different domain, the email was returned with an invalid account error.

    this really sucks because I have over 300 accounts on the server and need to go back and add a prefix to their username.

    is there anyway to configure Postfix to drop email not destined for the correct domain?

    is it possible to authenticate an account with an alias? after more testing and reading of this forum, I'll try to find a decent solution to my problem. Thanks for your help Till!


    edit: I think I will use a combination of the [DOMAIN]_ prefix and information from this post for my solution:
    http://www.howtoforge.com/forums/showthread.php?t=7881
     
    Last edited: Dec 18, 2006

Share This Page