email/ftp problem after moving ispconfig

Discussion in 'Installation/Configuration' started by mystix, Sep 13, 2006.

  1. mystix

    mystix New Member HowtoForge Supporter

    email/ftp problem after moving ispconfig

    Hello,

    I moved ispconfig to a new server by copying /etc/passwd, /etc/shadow, /etc/group, Vhosts_ispconfig.conf, /etc/postfix/local-host-names, /etc/postfix/virtusertable, named.conf, the zone files, /etc/proftpd*.conf, /var/www/* the databases etc.

    Now the sites a accessible again on the new server and the login to ispconfig works to.
    But email an ftp users can't connect to the server.

    I've copied the webusers in the original passwd, shadow and user files, but now there is a * and no encripted password ind /etc/shadow:

    admispconfig:!:13401:0:99999:7:::
    web35contact:*:13403:0:99999:7:::
    web35www:*:13403:0:99999:7:::
    web74admin:*:13403:0:99999:7:::

    When I change the userpassword with ispconfig the * is replaced with the encripted password but i still can't login.

    It would be nice I somebudy could help me!

    thanks

    Marc
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Have both servers the same linux distribution and use the same password encryption? have you copied the complete /etc/passw and /etc/shadow files or onyl the ISPConfig accounts starting with web....? Have you copied the gshadow file too, if this exists on your linux server?
     
  3. mystix

    mystix New Member HowtoForge Supporter

    Yes both server have debian sarge installed.

    I've installed debian and ispconfig first, then i copied the part with the web* users into the /etc/passw and /etc/shadow file.

    No i didn't copy that file but the file exists on the new server and the webusers are in the file.

    marc
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Does your new server use the old crypt passwords or the new MD5 passwords?
     

Share This Page