Email from hostname

Discussion in 'Installation/Configuration' started by ejkeebler, Nov 1, 2005.

  1. ejkeebler

    ejkeebler New Member

    Ok I am still confused after reading through a few threads I thought resembled my issue.

    Currently I can send and recieve email from [email protected] I would like it to only be [email protected]. Is this simply a hostname change? Or do I simply change a postfix value?

    I am using Ubuntu 5.1 with, as I stated above, postfix. :(
     
  2. falko

    falko Super Moderator ISPConfig Developer

    How do you send the emails? With an email client such as Thunderbird or Outlook Express, with a command, from a script, etc?
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you use ISPConfig or have you configured your mailusers manually? Is your domain in the file /etc/postfix/local-host-names?
     
  4. ejkeebler

    ejkeebler New Member

    Answers

    Yes I use an email client - Thunderbird and Outlook, and both can send emails to [email protected], but both get return to senders when sending to [email protected]. When I send either from mailx or from thunderbord they arrive as [email protected]

    I am using Maildir, Postfix and Courier if that makes a difference.

    As for the user mail clients setup, I do have ISPconfig installed but do not use it, as I really don't see the point since I just wanted to setup a working mail server, so.... I just create users with adduser and then send an email to that [email protected] and tada, Maildir is created and that user has a mailbox.

    Hope those answer the questions you had, thanks for the help!
     
  5. falko

    falko Super Moderator ISPConfig Developer

  6. ejkeebler

    ejkeebler New Member

    Still Broke

    Thanks falko, I'm guessing I found the problem I checked my /etc/postfix/local-host-names and it had basically every possible domain combination in there:
    localhost
    server.domain
    localhost.server.domain
    localhost.domain
    domain

    so I checked my main.cf and I saw the mydestination line is commented out and does not contain "domain", it does have locahost etc. Could this be the issue?

    I also checked the virtualusertable and did notice an entry probably from when I was messing around with ISPConfig trying to figure it out.

    If this is the issue how does the server know that when mail is sent, to send it out as [email protected] and not one of the others, like [email protected]??

    Thanks again

    --Update
    just uncommented the mydestination line and added domain.com to it, restarted postfix and when i send out mail it still comes as server.domain.com and when sending to [email protected], I have not received a return to sender (as I was before), but have not received the email yet either.
     
    Last edited: Nov 1, 2005
  7. falko

    falko Super Moderator ISPConfig Developer

    Did you run

    Code:
    postconf -e 'virtual_maps = hash:/etc/postfix/virtusertable'
    postconf -e 'mydestination = /etc/postfix/local-host-names'
    Did you run
    Code:
    postmap /etc/postfix/virtusertable
    after you've changed /etc/postfix/virtusertable?
    All the information you need is in this post: http://www.howtoforge.com/forums/showpost.php?p=4&postcount=2
     
  8. ejkeebler

    ejkeebler New Member

    Well thanks anyway

    Email is still not coming from [email protected] but from name[email protected] instead and email still not being received when sending to [email protected], no big deal at least it works which was my goal, im sure I just didn't set a hostname value or something like that somewhere, I plan on setting up a new one again anyway ;)

    Thanks for all the help.
     

Share This Page