email forwarding not working

Discussion in 'Installation/Configuration' started by janneh, Sep 25, 2008.

  1. janneh

    janneh New Member

    hi. i have a problem like this: 2 accounts/sites in same ispconfig, trying to forward mail from one to another. so i have in ispuser->advanced->forward the address i want to forward(the other site in my ispconfig). but if i test from gmail for example(send mail to site that is supposed to forward it) i get mail back like (i have changed the real mail address in following):

    ----- The following addresses had permanent fatal errors -----
    <mail@mail.net>
    (reason: 554 5.7.1 <mail@mail.net>: Relay access denied)

    ----- Transcript of session follows -----
    ... while talking to mail.net.:
    >>> DATA
    <<< 554 5.7.1 <mail@mail.net>: Relay access denied
    554 5.0.0 Service unavailable
    <<< 554 5.5.1 Error: no valid recipients

    Final-Recipient: RFC822; mail@mail.net
    Action: failed
    Status: 5.7.1
    Remote-MTA: DNS; mail.net
    Diagnostic-Code: SMTP; 554 5.7.1 <mail@mail.net>: Relay access denied
    Last-Attempt-Date: Thu, 25 Sep 2008 08:27:25 +0300

    -------------------------------------------------------------------------
    strange thing is if i recreate the site im forwarding from, everything works again. but after ubuntu reboot it goes back go same old error again!? i would appriciate if anyone had any clue about this.
    thx, jh
     
  2. till

    till Super Moderator

    Is the email address mail@mail.net listed in the file /etc/postfix/virtusertable?
     
  3. janneh

    janneh New Member

    thx, problem solved. seem that the site was badly created, when i removed www from co-domain ispconfig wrote the right addresses to virtusertable. so they were like mail@www.mail.net, and now mail@mail.net.
     

Share This Page