Email forwarding default alias

Discussion in 'ISPConfig 3 Priority Support' started by DylanPedro, Mar 15, 2018.

  1. DylanPedro

    DylanPedro Member HowtoForge Supporter


    Scenario 1
    I have a domain hosted with google apps which means all email send to [email protected] will be accepted. On top of this I have setup a catch-all so now [email protected] will also be accepted.

    Then I have setup a forward in gmail so if an email is sent to [email protected] it will be forwarded to [email protected]

    I have set [email protected] up in ISPConfig and it accepts the following as expected:
    mail sent to: [email protected] (due to dns record)
    mail sent to: [email protected] (forwarded by gmail filter)
    mail sent to: [email protected] (forwarded by gmail filter)

    So up to this stage everything is fine but now the issue is, if I setup an alias for the account as [email protected] how do I make sure all mail sent will default from this and not from [email protected] ?

    I can do it in roundcube via setting a default identity and can do it in outlook but this has to be done every time and to every client. Is there a setting in ISPConfig to make it system-wide and default for the account like other service allow after verification e.g Gmail or Microsoft exchange?

    Scenario 2
    The other way I have tried this is to setup an account in ISPConfig as [email protected] then I setup an alias for [email protected] to have all mail delivered to [email protected]

    Now when mail is received by gmail at [email protected] or [email protected] they are correctly sent to the ISPConfig server. All mail sent to [email protected] gets correctly delivered but when sending mail to [email protected] the ISPConfig server mail log has the following error:
    This is the mail system at host
    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.
    For further assistance, please send mail to postmaster.
    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.
    The mail system
    <[email protected]> (expanded from <[email protected]>): mail
    forwarding loop for [email protected]
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The email that is used for sending is defined by the mail client and not the server, so you have to configure your mail client to use the correct sender address. Roundcube is just a normal mail client like any other client, so you have to set the correct sender address there on first use as well. So that's nothing that is server related or configurable by ISPConfig. The second scenario cannot work as you instruct postfix to send email in a loop to itself, so mail will go nowhere.

Share This Page