Email Forward Problem with ISPConfig 3.1.2

Discussion in 'ISPConfig 3 Priority Support' started by vassiskansa, Apr 19, 2017 at 6:36 PM.

  1. vassiskansa

    vassiskansa New Member HowtoForge Supporter

    Hi, i've already posted my issue on the "free" area. Can anyone help me here?
    me:
    ----------------------------------------
    Hi all,
    I'm new of this forum, and sorry for my ugly english!
    I have a big problem: email forwarding doesn't work.
    ISPConfig 3.1.2 with Postfix 2.11.3-1 onto Debian 8.7 .
    I've set an email address into "Send incoming copy to" (ex: source-> myaddress dest-> external_address).
    However, "Send outgoing copy to" works well... and i don't know why...
    Can anyone help me?
    Thank you.
    ----------------------------------------
    me:
    ----------------------------------------
    I figured out where the problem might be. I initially installed the system to work with Dovecot but I had some problems and I returned to Courier. But on ISPConfig was remained Sieve settings as mailfilter syntax . I've changed and I've set Maildrop but it does not work yet. ISPConfig is so determined to create the .sieve files on the user mailbox. How can I do? Sieve is not really installed on my system. Thank you.
    ----------------------------------------
    florian:
    ----------------------------------------
    It's better to fix the problems with dovecot instead of running courier.
    ----------------------------------------
    me:
    ----------------------------------------
    Thank you for reply. Unfortunately I can not replace courier because of some compatibility issues. Can you tell me why ISPConfig continues to write the forward rules on /var/vmail/[DOMAIN]/[USER]/sieve/.sieve folder instead of using the old path /var/vmail/mailfilters/[DOMAIN]/.mailfilter ? Where do I find these configurations?
    ----------------------------------------
    Thank yoy and sorry for this...
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    - Did you set the filter syntax from dovecot to courier under System > Server config?
    - Did you disable the maildeliver plugin under /usr/local/ispconfig/server/plugins-enabled/ and enable the maildrop plugin instead?

    As a side note, courier has just legacy support for old ISPConfig systems, so we did not remove it yet but we also have not added anything since ISPConfig 3.0.5. I won't install courier on any of my servers. S if I were you, I would remove courier and install dovecot again and if you have a problem with dovecot, then post that problem instead of trying to use courier.
     
  3. vassiskansa

    vassiskansa New Member HowtoForge Supporter

    Hi Till, i've already reply to another post here -> https://www.howtoforge.com/community/threads/email-forward-problem-with-ispconfig-3-1-2.76187/ . Sorry for this... However:
    me:
    ---------------------------
    Ok, i've solved my problem. maildrop_plugin.inc.php was disabled in /usr/local/ispconfig/server/plugins-enabled . Probably the initial installation of ISPConfig3 enabling Dovecot/Siege that conflicts with Courier/Maildrop . Thank you all.
    ---------------------------
    Thank you Till...
     

Share This Page