Email Forward Problem with ISPConfig 3.1.2

Discussion in 'Installation/Configuration' started by vassiskansa, Apr 19, 2017 at 4:52 PM.

  1. vassiskansa

    vassiskansa New Member HowtoForge Supporter

    Hi all,
    I'm new of this forum, and sorry for my ugly english!
    I have a big problem: email forwarding doesn't work.
    ISPConfig 3.1.2 with Postfix 2.11.3-1 onto Debian 8.7 .
    I've set an email address into "Send incoming copy to" (ex: source-> myaddress dest-> external_address).
    However, "Send outgoing copy to" works well... and i don't know why...
    Can anyone help me?
    Thank you.
     
  2. vassiskansa

    vassiskansa New Member HowtoForge Supporter

    I figured out where the problem might be. I initially installed the system to work with Dovecot but I had some problems and I returned to Courier. But on ISPConfig was remained Sieve settings as mailfilter syntax . I've changed and I've set Maildrop but it does not work yet. ISPConfig is so determined to create the .sieve files on the user mailbox. How can I do? Sieve is not really installed on my system. Thank you.
     
  3. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    It's better to fix the problems with dovecot instead of running courier.
     
  4. vassiskansa

    vassiskansa New Member HowtoForge Supporter

    Thank you for reply. Unfortunately I can not replace courier because of some compatibility issues. Can you tell me why ISPConfig continues to write the forward rules on /var/vmail/[DOMAIN]/[USER]/sieve/.sieve folder instead of using the old path /var/vmail/mailfilters/[DOMAIN]/.mailfilter ? Where do I find these configurations?
     
  5. vassiskansa

    vassiskansa New Member HowtoForge Supporter

  6. Jesse Norell

    Jesse Norell Well-Known Member

    That should be the 'Mailfilter Syntax' setting under System > Server Config > {server} > Mail. I've not tried using maildrop, but it's the only other option besides sieve.
     
  7. vassiskansa

    vassiskansa New Member HowtoForge Supporter

    Ok, i've solved my problem. maildrop_plugin.inc.php was disabled in /usr/local/ispconfig/server/plugins-enabled . Probably the initial installation of ISPConfig3 enabling Dovecot/Siege that conflicts with Courier/Maildrop . Thank you all.
     

Share This Page