Email error - unknown user

Discussion in 'Installation/Configuration' started by radiox, Oct 29, 2007.

  1. radiox

    radiox New Member

    I'm a newbee so i may post stupid things.

    I have few sites hosted on my Centos. IspConfig configured them and all seems ok.

    However, I cannot send email from an Outlook client. Is in the same network, i can connect to my mail server but I cannot send or receive emails.

    i get this on the root account
    (reason: 550 5.1.1 User unknown)
    A friend tried to explain to me how to setup the users so that they could send/receive emails but I didn't exactly understand. He also created another type of user with different privileges.

    Now, what shall I show you from my wonderful Linux configuration???

    I have no GUI so my Linux for Dummies book is not helping me much.(and I have to learn as you did)

    Thanx in advance for help.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This is not nescessary for ISPConfig. I hope he did not mess up your setup with this.

    ISPConfig IS a GUI and if you want to create just mail and web accounts, you need no other.

    To your mail problem, you should not send email with your root account, create a email user in ISPConfig and a email address and use this to send emails.
  3. radiox

    radiox New Member

    thanx till,

    my friend created a seperate user, no link to my configuration.

    I have users created in ispconfig but their emails don't work.

    is somwhere a problem with the sendmail config, i presume.
  4. radiox

    radiox New Member

    I have a user web28_nick

    In ispconfig it tels me that the email address must be nick@

    but i tried to send email from outside and I get 'user unknown'

    I also try to send email to web28_nick@

    I get this error:

    ----- The following addresses had permanent fatal errors ----- "|/usr/bin/procmail -f-"
        (reason: Service unavailable)
        (expanded from: <[email protected]>)
  5. radiox

    radiox New Member

    I have news:

    I can receive email. I stopped sendmail and started postfix.

    (i need to learn how to make them start at boot.)

    When i try to send emails from outside to my address I get this error:

    [email protected]
    SMTP error from remote mail server after RCPT TO:<[email protected]>:
    host [xx.xx.xx.xx]: 554 <[email protected]>:
    Relay access denied

    any ideas?
  6. falko

    falko Super Moderator ISPConfig Developer

  7. radiox

    radiox New Member

  8. falko

    falko Super Moderator ISPConfig Developer

    Does the MX record for point to the correct server? You can check that with
    dig mx

Share This Page