Email date error

Discussion in 'ISPConfig 3 Priority Support' started by Gaston Girardi, Mar 22, 2021.

Tags:
  1. Gaston Girardi

    Gaston Girardi Member HowtoForge Supporter

    Hi, it's been awhile since i write here, everything has been working perfectly with the panel but due to physical problem on our server we had to reinstall everything, fortunately we had a backup fron a day earlier so we didn't suffer a big lost of data. But after putting all the files again and run a complete sync of the info the emails apear all with the same date, even if when you go into te email shows the right date, but the clients are complaingn about that, there is a way to correct that?!

    Hope somebody can help me because it was a very stressful weekend with the clients and everything, and i don't know what else to do.

    I had Debian 10 and i'm running ISPConfig V 3.2.3, and i also had RSPAMD, but this shouldn't affect, as far a i understand
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    My guess is the date showing incorrectly is probably generated from the file timestamp, so if you reset that to what was in your backup you should be fine. Probably check the tools/pipeline/script/etc you used to restore from and you'll be able to set them correctly as you restore (or if you can't restore again, write a script to read the original timestamp and set the same using maybe "touch -r" or similar).
     
  3. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    If the problem is the datestamp in files containing the e-mails, those can also be fixed by looking inside the file at what time it arrived and then set the file timestamp to match that. There are scripts to do this, though could not find any right now.
     
  4. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Yes, that's another option, though Date: headers are commonly wrong or even missing, it would fix the majority of them.
     
  5. Gaston Girardi

    Gaston Girardi Member HowtoForge Supporter

    Hi, thanks for the responses, i've tried the "touch" command to set the date on a test file and that work for the file but not for the email, as you can se in the images i'm attaching in roundcube is still showing the date i upliad all the emails file and do the synk, but the file date is now the original (i supouse because i toke the date from the Date line inside the file)

    After the change
    [​IMG]
    [​IMG]

    On roundcube after sync
    [​IMG]
    [​IMG]

    As you can see is still showing the wrong date :confused:
     
  6. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Perhaps the you need to reindex the mailbox after changing the file timestamp? Try:
    Code:
    doveadm index -u [email protected] '*'
     
  7. Gaston Girardi

    Gaston Girardi Member HowtoForge Supporter

    I've been running some test, and sometime works, and some time doesn't, the strange thing is that ive been tasting the same 3 files, over and over, so i because of the random succes think is not the files.

    I'm starting to think we are on the right path because of the relative success we got.

    As a comment for the test i was first uploading the files, then change the timestamp of the file, and finally running the doveadm code, in some tests i've even run a mailbox rsync.
     

Share This Page