Email configuration with ispconfig3

Discussion in 'Installation/Configuration' started by QuetzalFirst, Jun 17, 2015.

  1. QuetzalFirst

    QuetzalFirst Member

    Hi

    When create a new mailbox, ispconfig send email from
    From: ISPConfig <[email protected]>
    Reply-To: ISPConfig <[email protected]>
    Where a i can set this to have
    From: ISPConfig <[email protected]>
    Reply-To: ISPConfig <[email protected]>
    Thank you
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    About which email that ispconfig sends are you talking?
     
  3. QuetzalFirst

    QuetzalFirst Member

    "Welcome to your new email account. Your webmaster."
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Check that yiu have set a valid admin email addressin ISPConfig under System > Interface config.
     
  5. QuetzalFirst

    QuetzalFirst Member

    Config is ok... Set to [email protected] and this email is valid
     
  6. QuetzalFirst

    QuetzalFirst Member

    Another few little questions (dummy question for sure) :
    what is the diference between email alias and email forward?
    What is utility of email catchall ? When i enable it, all typo email are not return to sender so sender couldn't see that he has wrong address.
    Thank you
     
  7. webguyz

    webguyz Member HowtoForge Supporter

  8. QuetzalFirst

    QuetzalFirst Member

    Another issue... I cannot change server in spamfilter user...
    Multiserver setup... master CP and a mail server..
    spamfilter server is alway master server not the mail server
     
  9. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    The server for a spam-filter is always the server for the mail-domain. Why do you wan´t to change the spamfilter-server only?
     
  10. QuetzalFirst

    QuetzalFirst Member

    Sure... But my mail server is v04.mydomain and not master.mydomain !
    In SpamFilter -> User / Domain, the server is set to master.mydomain and connot be change to v04.mydomain (which is my mail server). master.mydomain is not a mail server.
    Filters in SpamFilter are set (not sure of that) when I create mailbox and use option to set level of spam...
    I dont understand why server in SpamFilter->User/Domain is not set to n04.mydomain and why it's cannot be change.
     
  11. webguyz

    webguyz Member HowtoForge Supporter

    QuetzalFirst
    That doesn't look right. I have separate cp, mail servers, and websites and the Email / Spamfilter / user/domain has the coprrect mail server for each user and I have more then 1 mail server.

    Are you using a Debian environment or something else? Just wondering as majority of the problems in these forums seems to be ISPConfig in a non Debian or Ubuntu environment or Nginx problems.
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Check the email domain in the ispconfig mail module, probably it is set to the master server and not the mail server.

    These records get generated automatically by the system based on the spamfilter selection that you make in a mail domain or mailbox. the server is the one where the mail domain resides. You can not alter that server manually as it would mean to move a mail domain with all mailboxes to another server. If you have created this record manually, then you can delete it off course and recreate it, but do not delete any records that were created automativ´cally by the system as your spamfilter will fail then.
     
  13. QuetzalFirst

    QuetzalFirst Member

    Hi

    Linux Centos 7
     
  14. QuetzalFirst

    QuetzalFirst Member

    In mail tab, all domains are set to v04.mydomain server
     
  15. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    Did you change something direct in the database? Please check ther server_id in spamfilter_users and in mail_user.

    If you change a entry in the mailfilter, the server_id is set to server_id for the domain (see #9 and #12).
     
  16. QuetzalFirst

    QuetzalFirst Member

    Thank you!

    This is the misconfiguration... Relate to my mail server swicth at the early stage of my configuration!
     
  17. QuetzalFirst

    QuetzalFirst Member

    Suggestion : In a view, if we can't change a setting don't put it in a combobox field but in a label field... This avoid confusion...
     

Share This Page