Email Clients cannot send mail

Discussion in 'Installation/Configuration' started by iverson0881, May 7, 2008.

  1. iverson0881

    iverson0881 New Member

    I just upgraded from 7.10 to 8.04 per the falko guide but I can't seem to send mail from any client, regardless if the password is correct or not. I suspect it's a saslauthd issue but I tried rerunning the steps from the 8.04 perfect server guide but I still have this problem.

    Also saslauthd daemon doesn't seem to start correctly. I'm not 100% sure what's going on.

    Any help would be great. Thanks in advance
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Which error messages do you get in the mail.log when you start saslauthd and when you try to send a email?
     
  3. iverson0881

    iverson0881 New Member

    here is what I get in auth.log

    Code:
    May  7 04:49:28 server sshd[7552]: pam_env(sshd:setcred): Unable to open env file: /etc/default/locale: No such file or directory
    May  7 04:49:28 server sshd[7554]: pam_unix(sshd:session): session opened for user root by root(uid=0)
    May  7 04:49:28 server sshd[7554]: pam_env(sshd:setcred): Unable to open env file: /etc/default/locale: No such file or directory
    May  7 04:50:49 server saslauthd[5166]: server_exit     : master exited: 5166
    May  7 04:50:57 server saslauthd[7597]: detach_tty      : master pid is: 7597
    May  7 04:50:57 server saslauthd[7597]: ipc_init        : listening on socket: /var/run/saslauthd/mux
    May  7 04:54:27 server saslauthd[7736]: detach_tty      : could not lock pid file /var/run/saslauthd/saslauthd.pid: Resource temporarily unavailable
    May  7 04:54:27 server saslauthd[7735]: detach_tty      : Cannot start saslauthd
    May  7 04:54:27 server saslauthd[7735]: detach_tty      : Another instance of saslauthd is currently running
    May  7 04:54:31 server saslauthd[7746]: detach_tty      : could not lock pid file /var/run/saslauthd/saslauthd.pid: Resource temporarily unavailable
    May  7 04:54:31 server saslauthd[7745]: detach_tty      : Cannot start saslauthd
    May  7 04:54:31 server saslauthd[7745]: detach_tty      : Another instance of saslauthd is currently running
    May  7 05:00:01 server CRON[8092]: pam_unix(cron:session): session opened for user root by (uid=0)
    May  7 05:00:01 server CRON[8092]: pam_unix(cron:session): session closed for user root
    May  7 05:03:32 server saslauthd[8242]: detach_tty      : could not lock pid file /var/run/saslauthd/saslauthd.pid: Resource temporarily unavailable
    May  7 05:03:32 server saslauthd[8241]: detach_tty      : Cannot start saslauthd
    May  7 05:03:32 server saslauthd[8241]: detach_tty      : Another instance of saslauthd is currently running
    May  7 05:03:40 server saslauthd[7597]: server_exit     : master exited: 7597
    May  7 05:03:45 server saslauthd[8253]: detach_tty      : master pid is: 8253
    May  7 05:03:45 server saslauthd[8253]: ipc_init        : listening on socket: /var/run/saslauthd/mux
    May  7 05:09:01 server CRON[8444]: pam_unix(cron:session): session opened for user root by (uid=0)
    May  7 05:09:01 server CRON[8451]: pam_unix(cron:session): session opened for user root by (uid=0)
    May  7 05:09:01 server CRON[8444]: pam_unix(cron:session): session closed for user root
    May  7 05:09:01 server CRON[8451]: pam_unix(cron:session): session closed for user root
    
    
    and in mail.log

    Code:
    May  7 05:06:24 server postfix/smtpd[8360]: warning: myip.net[000.000.000.000]: SASL PLAIN authentication failed: generic failure
    May  7 05:06:23 server postfix/smtpd[8360]: warning: myip.net[000.000.000.000]: SASL PLAIN authentication failed: generic failure
    May  7 05:06:24 server postfix/smtpd[8360]: warning: myip.net[000.000.000.000]: SASL PLAIN authentication failed: generic failure
    May  7 05:06:23 server postfix/smtpd[8360]: warning: myip.net[000.000.000.000]: SASL PLAIN authentication failed: generic failure
    May  7 05:06:20 server postfix/smtpd[8360]: warning: myip.net[000.000.000.000]: SASL PLAIN authentication failed: generic failure
    May  7 05:06:20 server postfix/smtpd[8360]: warning: myip.net[000.000.000.000]: SASL PLAIN authentication failed: generic failure
    May  7 05:06:16 server postfix/smtpd[8360]: warning: myip.net[000.000.000.000]: SASL PLAIN authentication failed: generic failure
    
    
     
    Last edited: May 7, 2008
  4. iverson0881

    iverson0881 New Member

    Okay I figured it out.

    Basically my problem was that i was using a very old /etc/init.d/saslauthd script and it doesn't really listen to /etc/default/saslauthd. so basically switched out for the saslauthd.dpkg-dist file and everything now works.

    This post seemed to guide me through what was going on: http://www.howtoforge.com/forums/archive/index.php/t-2199.html

    Since it wasn't obeying /etc/default/saslauthd it wasn't chrooted inside of postfix so it couldn't authenticate anyone since it can't read who to authenticate.
     
    Last edited: May 8, 2008

Share This Page