Email Client Recieves but doesnt send

Discussion in 'Installation/Configuration' started by grandpagenocide, Jul 28, 2008.

  1. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    ok i have been trying to get outlook thunderbird or eudora working with this. recieves fine, but keeps asking for password on sending. Eudora tells me Helo command rejected: host not found? any ideas? telnet connects fine on port 110 on 25 i get
    220 server2.rhwebhosting.com ESMTP Postfix (Debian/gnu)
    and cant seem to login?

    and in the mail clients, yes i put in authenticate with same settings

    220 server2.rhwebhosting.com ESMTP Postfix (Debian/GNU)
    helo rodney.rhwebhosting.com
    250 server2.rhwebhosting.com
    mail from rodney.rhwebhosting.com
    501 5.5.4 Syntax: MAIL FROM:<address>
    mail from:rodney.rhwebhosting.com
    250 2.1.0 Ok
    rcpt to:mail.rhwebhosting.com
    450 4.7.1 <rodney.rhwebhosting.com>: Helo command rejected: Host not found

    502 5.5.2 Error: command not recognized
    quit
    221 2.0.0 Bye


    Connection to host lost.


    im at my wits end so any help would be appreciated
     
    Last edited: Jul 28, 2008
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The domain rodney.rhwebhosting.com seems not to exits in DNS. Please create a DNS-A Record for rodney.rhwebhosting.com in the authoritive DNS server for rhwebhosting.com that points to your server IP.
     
  3. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    Till do i have to do that for all email addresses, the rodney.rhwebhosting.com is rodney@rhwebhosting.com, but it does not accept it with the @ when i try it in telnet?
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    This has nothing to do with mail users. You are trying to send mail to the hostname rodney.rhwebhosting.com and this hostanme does not exist in DNS. So you will have to createit if you want to use it.
     
  5. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    220 server2.rhwebhosting.com ESMTP Postfix (Debian/GNU)
    mail from:<rodney@rhwebhosting.com>
    250 2.1.0 Ok
    rcpt to:<admin@rhwebhosting.com>
    250 2.1.5 Ok
    data
    502 5.5.2 Error: command not recognized
    Data
    354 End data with <CR><LF>.<CR><LF>
    From: "rod" <rodney@rhwebhosting.com>
    to: "admin" <admin@rhwebhosting.com>
    date: today
    subject: test
    testing testing
    .
    250 2.0.0 Ok: queued as 125837E4094

    that went through but i still cant send mail from mail clients, im totally baffled.
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Ok, please try to send a mail from a mail client and then post the exact error message that appeared in the mail log. It might be a misconfiguration in the mail client.
     
  7. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    Till nothing appears in the mail log.
     
  8. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Ok, then you are not connecting to your server.

    Please make sure that you set the smtp and pop3 server in your mail client to:

    rhwebhosting.com

    or the IP address of your server.
     
  9. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    Till i have set it, it recieves email fine, just doesnt authenticate on sending
     
  10. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    If no line appears in the mail log, the your mail client dioes not connect to the right server. Please edit the smtp settings of your mail client and set it to rhwebhosting.com or the IP address of your server.
     
  11. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    till i have double checked, i have tried it with mail.rhwebhosting.com rhwebhosting.com and the IP address. Each time it says host not found
     
  12. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Ok, then please check the firewall on your server, on your client and if both are open for smtp connections, then ask your provider if they block smtp traffic.

    One side note, make sure that you did not enable ssl, tls or any similar setting in your mail client.
     
  13. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    my provider doesnt block it, the server is in a datacenter, no firewall and i checked the tls ssl etc connections arghhh im pulling my hair out lol all for one stupid client lol
     
  14. commentator

    commentator New Member

    Hi

    I tried some things for you:
    telnet rodney.rhwebhosting.com 110
    failed -> no dns record

    telnet mail.rhwebhosting.com 110
    ok
    user: rodney@rhwebhosting.com
    ok
    pass?

    if you can login there and the pass is accepted and you can see the mail with list then it is ok

    open ports:
    Interesting ports on www.rhwebhosting.com (216.128.67.175):
    (The 1592 ports scanned but not shown below are in state: filtered)
    Port State Service
    21/tcp open ftp
    22/tcp open ssh
    25/tcp open smtp
    53/tcp open domain
    80/tcp open http
    81/tcp open hosts2-ns
    110/tcp open pop-3
    443/tcp open https
    10000/tcp closed snet-sensor-mgmt


    can you connect with a webmailclient ?
     
  15. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    yea it works fine from webmail clients just when ur trying to setup outlook thunderbird etc when it messes up
     
  16. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    Jul 28 20:07:02 server2 postfix/smtpd[10651]: connect from ool-18beb074.dyn.optonline.net[24.190.176.116]
    Jul 28 20:07:02 server2 postfix/smtpd[10651]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
    Jul 28 20:07:02 server2 postfix/smtpd[10651]: warning: ool-18beb074.dyn.optonline.net[24.190.176.116]: SASL LOGIN authentication failed: generic failure
    Jul 28 20:07:02 server2 postfix/smtpd[10651]: NOQUEUE: reject: RCPT from ool-18beb074.dyn.optonline.net[24.190.176.116]: 450 4.7.1 <rodney-53f781d6.rhwebhosting.com>: Helo command rejected: Host not found; from=<web50_rodney> to=<admin@rhwebhosting.com> proto=ESMTP helo=<rodney-53f781d6.rhwebhosting.com>
    Jul 28 20:07:02 server2 postfix/smtpd[10651]: disconnect from ool-18beb074.dyn.optonline.net[24.190.176.116]

    is what i can find in the logs, i was trying it with different settings none worked :)

    The message could not be sent because one of the recipients was rejected by the server. The rejected e-mail address was 'jinx11239@aol.com'. Subject 'test', Account: 'mail.rhwebhosting.com', Server: 'mail.rhwebhosting.com', Protocol: SMTP, Server Response: '554 5.7.1 <jinx11239@aol.com>: Relay access denied', Port: 25, Secure(SSL): No, Server Error: 554, Error Number: 0x800CCC79

    more errors and i have SSL turned off so i am miffed
     
    Last edited: Jul 29, 2008
  17. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Please try this:
    Code:
    adduser postfix sasl
    and restart Postfix and saslauthd.
     
  18. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    no that still gives me the same error
     
    Last edited: Jul 29, 2008
  19. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    But the sending for other accounts works with external clients?

    If not, please compare the sasl and postfix configuration of your setup with the one found in the perfect setup guide for your linux distribution. Especially make sure that there are no whitw spaces at the end of the config lines.
     
  20. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    Thanks Till, but its every account on that server, so in the end im transplanting them to a new server.
     

Share This Page