Email appearing sent-- never gets to destination

Discussion in 'Installation/Configuration' started by grandpagenocide, Jul 1, 2007.

  1. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    I used a clean install of fedora core 6, Ispconfig, and uebiMiau, the web server is working fine, now that my cheap ass finally paid the extra to get my isp to open ports 80 and 25. When I send a mail through the uebiMiau webmail, it says mail sent, doesnt give an undeliverable message and the mail never gets to the destination. I am an admitted noob and appreciate any help.
     
  2. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    ok well no one responded. Now appearently I can send email, however I cannot recieve email??? how can I get the recieving workin??
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Dou you get any entries in your mail logfile, when you send a email to your server? If yes, please post the messages in the logfile, if not, please check that the MX record of the domain points to your external IP address.
     
  4. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    Till I checked the mail log and no record of any incoming, in the domain name the mx record is directed to my IP, when i send a mail from yahoo this is the response i get
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Is port 25 open in the firewall? And please check that the MX record is correct:
    Code:
    dig mx xxxxxxxxx.com
     
  6. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    port 25 is open and i checked the firewall which is open as well-- the box itself is on dmz at the moment while i try to get this thing working properly, firewall and selinux are off, and ispconfig firewall has the port forwarded as default.
     
    Last edited: Jul 3, 2007
  7. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    i attached my mail log..... This was so much simpler when i was paying someone else to do it for me arghhh hehe
     
    Last edited: Jul 3, 2007
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    This looks fine so far. Please post the output of:

    dig mail.rhwebhosting.com
     
  9. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    is the output from dig mail.rhwebhosting.com
     
  10. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    odd question should my dns settings in network be set to my isp's dns or to my yahoo's dns? and could that be the problem?
     
  11. falko

    falko Super Moderator ISPConfig Developer

    The DNS settings seem to be ok, and I can connect to your mail server:

    Code:
    mh1# telnet mail.rhwebhosting.com 25
    Trying 24.185.88.195...
    Connected to ool-18b958c3.dyn.optonline.net.
    Escape character is '^]'.
    220 server1.rhwebhosting.com ESMTP Postfix
    ehlo localhost
    250-server1.rhwebhosting.com
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH PLAIN LOGIN
    250-AUTH=PLAIN LOGIN
    250-ENHANCEDSTATUSCODES
    250-8BITMIME
    250 DSN
    quit
    221 2.0.0 Bye
    Connection closed by foreign host.
    What's the output of
    Code:
    postconf -n
    ?

    One thing I noticed is that your server is listed on lots of blacklists because it's using a dynamic IP address: http://www.mxtoolbox.com/blacklists.aspx
     
  12. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    hmmm ok so i have to see if opt will provide a static ip or is there another way around that?
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    Either you need a static IP address or you must relay all emails trough a SMTP relayserver of your provider.
     
  14. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    till dumb question but how do i do that? and will a ddns service handle the static ip issue? I spoke to my provider yesterday and they said its included in my package and I just have to set it up
     
  15. falko

    falko Super Moderator ISPConfig Developer

  16. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    falko ok I did that now do I have to fix anything in my dns settings because of that change? or in ISP config? Im still not able to recieve emails
     
    Last edited: Jul 4, 2007
  17. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    found this in maillog.ispconfigsave
     
  18. falko

    falko Super Moderator ISPConfig Developer

    These are old logs. Sending should now work if you've implemented the relaying correctly.
    Please check with
    Code:
    dig mx yourdomain.com
    that the MX record for the domain you're sending to is correct. Also, is there some action in the mail log when you send a mail to your server?
     
  19. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    falko sending always worked with most email addresses the problem is recieving

    arrrffff falko thanks the relay is working-- if your ever in new york hit me up and ill buy u a beer or 2 or 3 or 4
     
    Last edited: Jul 6, 2007

Share This Page