email/amavis problems

Discussion in 'Installation/Configuration' started by Ovidiu, Dec 3, 2009.

  1. Ovidiu

    Ovidiu Active Member

    got a problem with a contact for on a wordpress site. worked perfectly till yesterday, no system changes doen to the server. The contact form freezes with the message: waiting.

    checked the mail logs and mail.log says:

    Code:
    Dec  3 21:34:05 h1550830 amavis[23120]: (23120-01) lookup_hash(mike@quilombobrasil.com), no matches
    Dec  3 21:34:05 h1550830 amavis[23120]: (23120-01) lookup_acl(mike@quilombobrasil.com), no match
    Dec  3 21:34:05 h1550830 amavis[23120]: (23120-01) lookup (local_domains) => undef, "mike@quilombobrasil.com" does not match
    Dec  3 21:34:05 h1550830 amavis[23120]: (23120-01) query_keys: mike@quilombobrasil.com, @quilombobrasil.com, @.quilombobrasil.com, @.com, @.
    Dec  3 21:34:05 h1550830 amavis[23120]: (23120-01) lookup_sql "mike@quilombobrasil.com", query args: "26", "ARRAY(0x5377108)", "ARRAY(0x2c88590)", "ARRAY(0x7f0228aa1d50)", "ARRAY(0x53846e8)", "ARRAY(0x4f17d20)"
    Dec  3 21:34:05 h1550830 amavis[23120]: (23120-01) lookup_sql, "mike@quilombobrasil.com" no match
    Dec  3 21:34:05 h1550830 amavis[23120]: (23120-01) lookup_sql_field(wb), "mike@quilombobrasil.com" no matching records
    Dec  3 21:34:05 h1550830 amavis[23120]: (23120-01) lookup => undef, "mike@quilombobrasil.com" does not match
    Dec  3 21:34:05 h1550830 amavis[23120]: (23120-01) query_keys: mike@quilombobrasil.com, mike@, quilombobrasil.com, .quilombobrasil.com, .com, .
    Dec  3 21:34:05 h1550830 amavis[23120]: (23120-01) lookup_hash(mike@quilombobrasil.com), no matches
    Dec  3 21:34:05 h1550830 amavis[23120]: (23120-01) lookup (blacklist_sender) => undef, "mike@quilombobrasil.com" does not match
    Dec  3 21:34:05 h1550830 amavis[23120]: (23120-01) query_keys: mike@quilombobrasil.com, mike@, quilombobrasil.com, .quilombobrasil.com, .com, .
    Dec  3 21:34:05 h1550830 amavis[23120]: (23120-01) lookup_hash(mike@quilombobrasil.com), no matches
    Dec  3 21:34:05 h1550830 amavis[23120]: (23120-01) lookup (whitelist_sender) => undef, "mike@quilombobrasil.com" does not match
    Dec  3 21:34:05 h1550830 amavis[23120]: (23120-01) lookup_re("mike@quilombobrasil.com"), no matches
    Dec  3 21:34:05 h1550830 amavis[23120]: (23120-01) query_keys: mike@quilombobrasil.com, mike@, quilombobrasil.com, .quilombobrasil.com, .com, .
    Dec  3 21:34:05 h1550830 amavis[23120]: (23120-01) lookup_hash(mike@quilombobrasil.com), no matches
    Dec  3 21:34:05 h1550830 amavis[23120]: (23120-01) lookup (score_sender<mike@quilombobrasil.com>) => undef, "mike@quilombobrasil.com" does not match
    
    doesn't tell me anything.

    mail.err and mail.warn have no related entries.

    mail.info says:

    Code:
    Dec  3 21:34:05 h1550830 amavis[23120]: (23120-01) check_header: 3, Improper use of control character (char 0D hex): From: ...quilombobrasil.com" <mike@quilombobrasil.com>\\r
    
    it seems the emails are still coming through though...
    any ideas what to check?
     
  2. Ovidiu

    Ovidiu Active Member

    fixed the mail.info entry about the improper usage of control character with a settign of the contact form plugin, activated this option:

    Code:
    cforms produces RFC compliant emails with CRLF (carriage-return/line-feed) as line separators. If your mail server adds additional line breaks to the email, you may want to try and turn on the below option.
      X	Separate lines in email header with LF only (CR suppressed)
    I checked that option, the error in mail.info went away, the form is still hanging with the mesage pelase wait but the lookup entries inside mail.log are still persisting :-(
     
  3. Ovidiu

    Ovidiu Active Member

    the latest system updates that I did were:
    Code:
            libapache2-mod-php5 5.2.6.dfsg.1-1+lenny4
            php-pear 5.2.6.dfsg.1-1+lenny4
            php5 5.2.6.dfsg.1-1+lenny4
            php5-cgi 5.2.6.dfsg.1-1+lenny4
            php5-cli 5.2.6.dfsg.1-1+lenny4
            php5-common 5.2.6.dfsg.1-1+lenny4
            php5-curl 5.2.6.dfsg.1-1+lenny4
            php5-dev 5.2.6.dfsg.1-1+lenny4
            php5-gd 5.2.6.dfsg.1-1+lenny4
            php5-imap 5.2.6.dfsg.1-1+lenny4
            php5-mcrypt 5.2.6.dfsg.1-1+lenny4
            php5-mysql 5.2.6.dfsg.1-1+lenny4
            php5-recode 5.2.6.dfsg.1-1+lenny4
    
    attached was this notice:
    Code:
    php5 (5.2.6.dfsg.1-1+lenny4) stable-security; urgency=high
    
      * Maximum number of file uploads per request limited
    
      To prevent Denial of Service attacks by exhausting the number of
      available temporary file names, the max_file_uploads option
      introduced in PHP 5.3.1 has been backported.
    
      Due to the nature of this new option a default limit has been set
      to 50, hoping it is sensible enough to not to cause disruptions on
      existing services.
      The value of this new limit can be changed in the php.ini file.
    
      If you installed the php5-suhosin extension there was a limiting
      mechanism in place already. In this case you may want to make sure
      the new limit imposed by PHP itself is not smaller than suhosin's.
    
    I didn't change anything. kept my old config files. same when I did the last ispconfig upgrade, kept my settings. anythign wrong with this?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    I dont think that your problem is realted to amavis as amavis scans the messages after they are fully received by postfix, so amavis is not even able to reject ordelay the receiving of the email, its a after queue filter. Additionally, the lookup entries are absolutely fine, its ok if there are no matches as this means that no specific configuration for this email is used, instead the amavis defaults are used.

    Do other mail forms on your server work? Did you use "localhost" as mailserver in the form?
     
  5. Ovidiu

    Ovidiu Active Member

    well, I hsot maily wordpress isntallations on this server. I checked the same contact form on other clients sites all work fine. it seems kind of related to this email/vhost not really sure about it.

    There are no settings regarding localhost. Its using phpmail. alternatively I can switch to smtp but I'd rather avoid that and so far all contact forms have been perfectly working.

    what toehr logs can I check? can I give you any config file content here?
     

Share This Page