Email Aliasing not working - ISPConfig

Discussion in 'General' started by tony_simcock, Mar 3, 2010.

  1. tony_simcock

    tony_simcock New Member

    Upgraded to 3.0.2 - Aliases still not working - Centos 5.4

    Sorry to keep re-opening this thread. Ive upgraded to 3.0.2 in a hope that maybe it'll fix the issue Im having with aliases/forwards, but unfortunatly Im still having the same issue.
    Any help is much appreiciated

  2. tony_simcock

    tony_simcock New Member

    Not sure if this is relevant to my issue but, Ive managed to alias local accounts (ie [email protected] and [email protected]) to my email address, but Im still unable to alias anything using mysql.

    So I've tried adding this line in my to see if I can atleast see the request:
    alias_maps = hash:/etc/aliases, $virtual_alias_maps
    But when I run newaliases I get an error saying:
    postalias: fatal: unsupported map type: mysql
    As I have several domains I would like to get this working. If ANYONE has got portfix working on Centos 5.4 with MySQL support, could you please post me your and so I can run a comparison?

  3. DFen

    DFen New Member

    I have had no problems with aliases on Centos 5.4

    Extract from
    alias_maps = hash:/etc/aliases
    virtual_alias_maps = proxy:mysql:/etc/postfix/, mysql:/etc/postfix/

    I regret I am no export in postfix but I think the postfix config is exactly the same as for any other Centos 5 version.
  4. tony_simcock

    tony_simcock New Member

    Hi Dfen,
    Thanks for the reply. Would it be possible for you to send me your and please so I can just make sure Ive got everything I should have?
    So are your aliases working through mySQL then? ie the ones you create in the ISPConfig control panel?
  5. DFen

    DFen New Member and from Centos 5.4

    Herewith the requested files,
    Note: domain name altered to 'my-domain'

    Attached Files:

  6. estepix

    estepix New Member

    possible solution

    Hi, I'm not sure if it will work for you, but I had a similar error to

    Mar  4 13:58:36 localdomain postfix/pipe[10601]: 4B6DEFEA61: to=<mailbox@localdomain>, relay=maildrop, delay=0.05, delays=0.01/0/0/0.03, dsn=2.0.0, status=sent (delivered via maildrop service)
    Fixed it thanks to this thread

    I uninstalled amavis a while ago and commented this line in /etc/postfix/
    #content_filter = amavis:[]:10024
    Well, it happens that you also need to comment this one:
    #receive_override_options = no_address_mappings
    Because it is preventing address mapping

Share This Page