Email aliases problem

Discussion in 'General' started by rosa hsiao, Dec 9, 2005.

  1. rosa hsiao

    rosa hsiao New Member

    I can send email with "[email protected]" or its alias name "[email protected]". But I can only receive reply email to [email protected]. If the sender puts "[email protected]" as recipient,I can't receive the email and the maillog looks like:

    Dec 9 16:26:37 server1 postfix/smtpd[20380]: connect from webmsr1.webmail.hinet.net[61.220.15.201]
    Dec 9 16:26:37 server1 postfix/smtpd[20380]: NOQUEUE: reject: RCPT from webmsr1.webmail.hinet.net[61.220.15.201]: 550 <[email protected]>: Recipient address rejected: User unknown in local recipient table; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<webmsr1.webmail.hinet.net>
    Dec 9 16:26:52 server1 postfix/smtpd[20380]: disconnect from webmsr1.webmail.hinet.net[61.220.15.201]
    Dec 9 16:27:04 server1 ipop3d[20392]: pop3 service init from 127.0.0.1
    Dec 9 16:27:04 server1 ipop3d[20392]: Login user=web1_pink host=server1.bytelib.com.tw [127.0.0.1] nmsgs=1/1
    Dec 9 16:27:04 server1 ipop3d[20392]: Logout user=web1_pink host=server1.test.com [127.0.0.1] nmsgs=1 ndele=0

    Should I install vm-pop3 instead of ipop3 to get the problem solved?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. rosa hsiao

    rosa hsiao New Member

    Yes. I have the following lines in /etc/postfix/virtusertable:
    [email protected]
    [email protected]
    [email protected]
    [email protected]

    And I have this line in main.cf:
    virtual_maps = hash:/etc/postfix/virtusertable
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    And the domain test.com is in your /etc/postfix/local-host-names and you have this line in your main.cf too:

    mydestination = /etc/postfix/local-host-names
     
  5. rosa hsiao

    rosa hsiao New Member

    The domain test.com is in my /etc/postfix/local-host-names and I find a line in main.cf:
    mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain, mail.$mydomain, www.$mydomain, ftp.$mydomain

    So I change it to
    mydestination = /etc/postfix/local-host-names

    I will let you know if this will solve the problem.

    I also have the following lines in main.cf:
    alias_maps = hash:/etc/aliases
    virtual_maps = hash:/etc/postfix/virtusertable
     
  6. rosa hsiao

    rosa hsiao New Member

    Finally I can receive emails for both [email protected] and alias email [email protected]. I can send emails of other domain name such as [email protected]. But I can't receive alias email for [email protected].


    Which parameter do I need to modify in main.cf ?

    mynetworks = 127.0.0.0/8
    or
    mynetworks = 192.168.1.0/24 ???


    mynetworks_style = subnet
    or
    mynetworks_style = host ???
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Is [email protected] in /etc/postfix/virtusertable? Is test2.com in /etc/postfix/local-host-names?


    You don't have to change these parameters.
     
  8. rosa hsiao

    rosa hsiao New Member

    Yes. I have the following line in /etc/postfix/local-host-names:

    [email protected] web1_pink
    [email protected] web1_pink
    [email protected] web1_pink
    [email protected] web1_pink
    [email protected] web1_sale
    [email protected] web1_sale
    [email protected] web1_sale
    [email protected] web1_sale

    I am using ipop3 daemon now. I also have installed vm-pop3,but not running it.


    In my main.cf I have the following lines:
    #mynetworks_style = class
    #mynetworks_style = subnet
    #mynetworks_style = host
    #mynetworks = 192.168.1.0/28, 127.0.0.0/8
    #mynetworks = $config_directory/mynetworks
    #mynetworks = hash:/etc/postfix/network_table

    Do you mean that I can just leave them alone and don't bother to change or comment out any of those lines?
     
  9. falko

    falko Super Moderator ISPConfig Developer

    :eek: These lines belong into /etc/postfix/virtusertable, not local-host-names!

    ipop3 uses mbox format, so make sure you disabled Maildir under Management -> Server -> Settings -> Email.



    Leave them unchanged for now.
    I don't know if you've told us before, but what distribution do you use, and did you follow any of the "Perfect Setup" tutorials on HowtoForge?
     
  10. rosa hsiao

    rosa hsiao New Member

    Sorry for the mistake! My local-host-names has the following lines:

    www.test.com
    test.com
    www.test2.com
    test2.com

    I have already disabled Maildir!


    I have follow the "Perfect Setup for Fedora Core 3" tutorials on HowtoForge.
    The reason for not using Fedora Core 4 is because FC4 doesn't run some applications such as PHPBB2 very smoothly.
     
  11. falko

    falko Super Moderator ISPConfig Developer

    And what's in your mail log when you send mails to [email protected]?

    If that's your /etc/postfix/virtusertable:

    then mails for [email protected] should arrive in web1_sale's mailbox.
     
  12. rosa hsiao

    rosa hsiao New Member

    I delete user web1_sale from web site "test.com" and create a user web2_sale for web site "test2.com.tw" and give it an alias name "sale". Now the problem get solved. Both [email protected] and [email protected] can receive and send emails successfully.

    Thnaks very much for your patience and help.
     
  13. klaus++

    klaus++ New Member

    A similar Solution

    Thanks a lot for the thread. :) I had a similar Problem. Finally I managed to solve it by deleting existing users and creating them again. Beforehand I had to activate Maildir in ISPConfig - in my case standard pop3 with user Maildirs is running under Postfix.
     

Share This Page