Email account with copy of mail to another email

Discussion in 'General' started by Fantu, Jan 28, 2010.

  1. Fantu

    Fantu New Member

    I not found how i must do in ispconfig3 for send a copy of all mail recived bu one mail account to one mail external
    Someone can help me please?
     
  2. prisfeo

    prisfeo New Member

  3. prisfeo

    prisfeo New Member

    i need some help me too.. :(
    i have tried to do the above (set up the custom rule in order to resend an email sent to an email account configured inside ispconfig3) for testing purpose..
    well..nothing to do..
    email always arrive correctly to the user account email address set up inside ispconfig,
    but never resent to external email address(my account@gmail.com) configured inside the Custom Rules
    tab following this guide:
    http://www.faqforge.com/linux/contr...-copys-of-incoming-emails-to-other-mailboxes/

    i also tried without quotes, single quotes..always same result:
    mail not sent to external email address.
    ..
    in /var/log/maillog
    there are no postfix tries to send to external email address..

    so i have checked inside:
    /var/vmail/mailfilters/mydomain.com/useremailaccount/
    and there is not any file created..:confused:
    (the owner of the /var/vmail/mailfilters/ are "vmail root")

    what am i doing wrong ?

    (i am using ISPconfig 3.0.1.6 in Centos5.4)
     
    Last edited: Jan 28, 2010
  4. prisfeo

    prisfeo New Member

    anyone can tell me why filter file it is not created ?
    ..really a i have to create it manually for each user/filter ?
     
  5. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Check the system log in the monitor and jobqueue for errors. Also you should be aware that the files in /var/vmail/mailfilters/mydomain.com/useremailaccount/ are hidden files, so you dot see them with ls.

    Please post the output of:

    ls -la /var/vmail/mailfilters/mydomain.com/useremailaccount/
     
  6. prisfeo

    prisfeo New Member

    great tip Till! thanks..
    well here it is the output:

    ls -la /var/vmail/mailfilters/mydomain.com/useremailaccount/

    drwxrwx--- 2 vmail root 4096 29 gen 11:05 .
    drwxrwx--- 3 vmail root 4096 28 gen 16:20 ..
    -rwxrwx--- 1 vmail root 26 29 gen 11:05 .mailfilter

    so yes the .mailfilter file does exist!!
    and inside it there's a line with exactly the custom rule:
    cc "!myaccount@gmail.com"

    now i have retried sending an email to useremailaccount@mydomain.com
    and mail is re-sent to that external account..!!:confused:
    and i can see it correctly in the /var/log/maillog..

    i can assure yesterday there was no email trace resent external.
    strange behaviour..
    but i cannot say if yesterday there was inside that folder the .mailfilter file,
    since i have done only the "-lh" flag..:rolleyes:
    however..now it works!

    thanks Till!!
     
  7. tilman

    tilman New Member

    The above settings (cc “!info1@example.tld”) did not work for me.
    Now found a working solution:
    In the "Custom rules" Tab in the eMail Mailbox Settings (only available if logged in as admin and in the German Version) place these two lines:
    redirect "info1@example.tld";
    fileinto "INBOX";

    Line 1: redirect to the given eMail Address
    Line 2: Place a copy in the INBOX folder
     
  8. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    I guess you use dovecot and not courier. The instructions above are for courier imap.
     

Share This Page