Elgg V 1.6 ERROR 500 - Internal Server Error!

Discussion in 'Installation/Configuration' started by toyito, Aug 26, 2009.

  1. toyito

    toyito New Member

    Hi there,

    While im trying to install Elgg V 1.6 on a site hosted under ISPConfig 3 after create the .htaccess file i get this error

    .htaccess file
    Code:
    # Elgg htaccess directives
    # Copyright Curverider Ltd 2008-2009
    # License http://www.gnu.org/licenses/old-licenses/gpl-2.0.html GNU Public License version 2
    # Link http://elgg.org/
    
    <IfModule !mod_rewrite.c>
        # ugly ugly hack to detect missing mod_rewrite
        # RedirectMatch must be to an absolute destination, so forces 500 error...
        ErrorDocument 500 "Elgg error: Apache does not have mod_rewrite loaded. Please check your Apache setup."
        RedirectMatch 302 .* index.php
    </IfModule>
    
    <Files "htaccess_dist">
        order allow,deny
        deny from all
    </Files>
    
    # Don't listing directory
    Options -Indexes
    
    # Follow symbolic links
    Options +FollowSymLinks
    
    # Default handler
    DirectoryIndex index.php
    
    # Turn on expiry
    <IfModule mod_expires.c>
    	ExpiresActive On
    	ExpiresDefault "access plus 10 years"
    </IfModule>
    
    # php 4, apache 1.x
    <IfModule mod_php4.c>
        ErrorDocument 500 "Elgg error: Elgg does not support PHP 4."
        RedirectMatch 302 .* index.php
    </IfModule>
    
    # php 4, apache 2
    <IfModule sapi_apache2.c>
        ErrorDocument 500 "Elgg error: Elgg does not support PHP 4."
        RedirectMatch 302 .* index.php
    </IfModule>
    
    # php 5, apache 1 and 2
    <IfModule mod_php5.c>
    	# default memory limit to 64Mb
    	php_value memory_limit 64M
    	# to make sure register global is off
    	php_value register_globals 0
    	# max post size to 8Mb
    	php_value post_max_size 8388608
    	# upload size limit to 5Mb	
    	php_value upload_max_filesize 5242880
    	# hide errors, enable only if debug enabled
    	php_value display_errors 0
    </IfModule>
    
    # Turn on mod_gzip if available
    <IfModule mod_gzip.c>
    	mod_gzip_on yes
        mod_gzip_dechunk yes
        mod_gzip_keep_workfiles No
        mod_gzip_minimum_file_size 1000
        mod_gzip_maximum_file_size 1000000
        mod_gzip_maximum_inmem_size 1000000
        mod_gzip_item_include mime ^text/.* 
        mod_gzip_item_include mime ^application/javascript$
        mod_gzip_item_include mime ^application/x-javascript$
        # Exclude old browsers and images since IE has trouble with this
        mod_gzip_item_exclude reqheader "User-Agent: .*Mozilla/4\..*\["
        mod_gzip_item_exclude mime ^image/.*
    </IfModule>
    
    ## Apache2 deflate support if available
    ##
    ## Important note: mod_headers is required for correct functioning across proxies.
    ##
    <IfModule mod_deflate.c>
    	AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript application/javascript application/x-javascript
    	BrowserMatch ^Mozilla/4 gzip-only-text/html
    	BrowserMatch ^Mozilla/4\.[0678] no-gzip
    	BrowserMatch \bMSIE !no-gzip
    
    <IfModule mod_headers.c>	
    	Header append Vary User-Agent env=!dont-vary
    </IfModule>	
    	
    	# The following is to disable compression for actions. The reason being is that these
    	# may offer direct downloads which (since the initial request comes in as text/html and headers
    	# get changed in the script) get double compressed and become unusable when downloaded by IE.
    	SetEnvIfNoCase Request_URI action\/* no-gzip dont-vary
    	SetEnvIfNoCase Request_URI actions\/* no-gzip dont-vary
    	
    </IfModule>
    
    # Configure ETags
    <FilesMatch "\.(jpg|jpeg|gif|png|mp3|flv|mov|avi|3pg|html|htm|swf)$">
    	FileETag MTime Size
    </FilesMatch>
    
    <IfModule mod_rewrite.c>
    
    RewriteEngine on
    
    # If Elgg is in a subdirectory on your site, you might need to add a RewriteBase line
    # containing the path from your site root to elgg's root. e.g. If your site is
    # http://example.com/ and Elgg is in http://example.com/sites/elgg/, you might need 
    #
    #RewriteBase /sites/elgg/
    #
    # here, only without the # in front.
    #
    # If you're not running Elgg in a subdirectory on your site, but still getting lots
    # of 404 errors beyond the front page, you could instead try:
    #
    #RewriteBase /
    
    RewriteRule ^action\/([A-Za-z0-9\_\-\/]+)$ engine/handlers/action_handler.php?action=$1
    
    RewriteRule ^export\/([A-Za-z]+)\/([0-9]+)$ services/export/handler.php?view=$1&guid=$2
    RewriteRule ^export\/([A-Za-z]+)\/([0-9]+)\/$ services/export/handler.php?view=$1&guid=$2
    RewriteRule ^export\/([A-Za-z]+)\/([0-9]+)\/([A-Za-z]+)\/([A-Za-z0-9\_]+)\/$ services/export/handler.php?view=$1&guid=$2&type=$3&idname=$4
    
    RewriteRule ^\_css\/css\.css$ _css/css.php
    
    RewriteRule ^pg\/([A-Za-z0-9\_\-]+)\/(.*)$ engine/handlers/pagehandler.php?handler=$1&page=$2
    RewriteRule ^pg\/([A-Za-z0-9\_\-]+)$ engine/handlers/pagehandler.php?handler=$1
    
    RewriteRule xml-rpc.php engine/handlers/xml-rpc_handler.php
    RewriteRule mt/mt-xmlrpc.cgi engine/handlers/xml-rpc_handler.php
    
    RewriteRule ^tag/(.+)/?$ engine/handlers/pagehandler.php?handler=search&page=$1
    
    </IfModule>
    
    Error log for this site:
    Code:
    [Tue Aug 25 22:21:31 2009] [alert] [client 190.86.232.174] /var/www/XXX.com/web/comunidad/.htaccess: Options not allowed here
    

    I have read some posts about htaccess files, but really i can figure how to fix this problem....can you help me pls.

    Hector
     
  2. till

    till Super Moderator

    Remove these lines from the .htaccess file:

    # Don't listing directory
    Options -Indexes

    # Follow symbolic links
    Options +FollowSymLinks

    # Default handler
    DirectoryIndex index.php


    and add them to the apache directives field of the website instead.
     
  3. toyito

    toyito New Member

    Hi there Till:

    Same error.

    Regards,

    Hector
     
  4. till

    till Super Moderator

    Thst not possible if you remoced the lines from the .htaccess file. Check again and delete the lines.
     
  5. toyito

    toyito New Member

    Here is the new htacces:

    Code:
    # Elgg htaccess directives
    # Copyright Curverider Ltd 2008-2009
    # License http://www.gnu.org/licenses/old-licenses/gpl-2.0.html GNU Public License version 2
    # Link http://elgg.org/
    
    <IfModule !mod_rewrite.c>
        # ugly ugly hack to detect missing mod_rewrite
        # RedirectMatch must be to an absolute destination, so forces 500 error...
        ErrorDocument 500 "Elgg error: Apache does not have mod_rewrite loaded. Please check your Apache setup."
        RedirectMatch 302 .* index.php
    </IfModule>
    
    <Files "htaccess_dist">
        order allow,deny
        deny from all
    </Files>
    
    # Turn on expiry
    <IfModule mod_expires.c>
    	ExpiresActive On
    	ExpiresDefault "access plus 10 years"
    </IfModule>
    
    # php 4, apache 1.x
    <IfModule mod_php4.c>
        ErrorDocument 500 "Elgg error: Elgg does not support PHP 4."
        RedirectMatch 302 .* index.php
    </IfModule>
    
    # php 4, apache 2
    <IfModule sapi_apache2.c>
        ErrorDocument 500 "Elgg error: Elgg does not support PHP 4."
        RedirectMatch 302 .* index.php
    </IfModule>
    
    # php 5, apache 1 and 2
    <IfModule mod_php5.c>
    	# default memory limit to 64Mb
    	php_value memory_limit 64M
    	# to make sure register global is off
    	php_value register_globals 0
    	# max post size to 8Mb
    	php_value post_max_size 8388608
    	# upload size limit to 5Mb	
    	php_value upload_max_filesize 5242880
    	# hide errors, enable only if debug enabled
    	php_value display_errors 0
    </IfModule>
    
    # Turn on mod_gzip if available
    <IfModule mod_gzip.c>
    	mod_gzip_on yes
        mod_gzip_dechunk yes
        mod_gzip_keep_workfiles No
        mod_gzip_minimum_file_size 1000
        mod_gzip_maximum_file_size 1000000
        mod_gzip_maximum_inmem_size 1000000
        mod_gzip_item_include mime ^text/.* 
        mod_gzip_item_include mime ^application/javascript$
        mod_gzip_item_include mime ^application/x-javascript$
        # Exclude old browsers and images since IE has trouble with this
        mod_gzip_item_exclude reqheader "User-Agent: .*Mozilla/4\..*\["
        mod_gzip_item_exclude mime ^image/.*
    </IfModule>
    
    ## Apache2 deflate support if available
    ##
    ## Important note: mod_headers is required for correct functioning across proxies.
    ##
    <IfModule mod_deflate.c>
    	AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript application/javascript application/x-javascript
    	BrowserMatch ^Mozilla/4 gzip-only-text/html
    	BrowserMatch ^Mozilla/4\.[0678] no-gzip
    	BrowserMatch \bMSIE !no-gzip
    
    <IfModule mod_headers.c>	
    	Header append Vary User-Agent env=!dont-vary
    </IfModule>	
    	
    	# The following is to disable compression for actions. The reason being is that these
    	# may offer direct downloads which (since the initial request comes in as text/html and headers
    	# get changed in the script) get double compressed and become unusable when downloaded by IE.
    	SetEnvIfNoCase Request_URI action\/* no-gzip dont-vary
    	SetEnvIfNoCase Request_URI actions\/* no-gzip dont-vary
    	
    </IfModule>
    
    # Configure ETags
    <FilesMatch "\.(jpg|jpeg|gif|png|mp3|flv|mov|avi|3pg|html|htm|swf)$">
    	FileETag MTime Size
    </FilesMatch>
    
    <IfModule mod_rewrite.c>
    
    RewriteEngine on
    
    # If Elgg is in a subdirectory on your site, you might need to add a RewriteBase line
    # containing the path from your site root to elgg's root. e.g. If your site is
    # http://example.com/ and Elgg is in http://example.com/sites/elgg/, you might need 
    #
    #RewriteBase /sites/elgg/
    #
    # here, only without the # in front.
    #
    # If you're not running Elgg in a subdirectory on your site, but still getting lots
    # of 404 errors beyond the front page, you could instead try:
    #
    #RewriteBase /
    
    RewriteRule ^action\/([A-Za-z0-9\_\-\/]+)$ engine/handlers/action_handler.php?action=$1
    
    RewriteRule ^export\/([A-Za-z]+)\/([0-9]+)$ services/export/handler.php?view=$1&guid=$2
    RewriteRule ^export\/([A-Za-z]+)\/([0-9]+)\/$ services/export/handler.php?view=$1&guid=$2
    RewriteRule ^export\/([A-Za-z]+)\/([0-9]+)\/([A-Za-z]+)\/([A-Za-z0-9\_]+)\/$ services/export/handler.php?view=$1&guid=$2&type=$3&idname=$4
    
    RewriteRule ^\_css\/css\.css$ _css/css.php
    
    RewriteRule ^pg\/([A-Za-z0-9\_\-]+)\/(.*)$ engine/handlers/pagehandler.php?handler=$1&page=$2
    RewriteRule ^pg\/([A-Za-z0-9\_\-]+)$ engine/handlers/pagehandler.php?handler=$1
    
    RewriteRule xml-rpc.php engine/handlers/xml-rpc_handler.php
    RewriteRule mt/mt-xmlrpc.cgi engine/handlers/xml-rpc_handler.php
    
    RewriteRule ^tag/(.+)/?$ engine/handlers/pagehandler.php?handler=search&page=$1
    
    </IfModule>
    
    The error in log:

    Code:
    [Wed Aug 26 13:16:57 2009] [alert] [client 190.86.232.174] /var/www/XXX.com/web/comunidad/.htaccess: php_value not allowed here
    
     
  6. till

    till Super Moderator

    Ok, but thats a completely different error message now as you see in the log. move all php_value lines to the apache directives field.
     
  7. toyito

    toyito New Member

    Hi Till,

    Thanks again...all is working ok at this time.

    Just for the records here is the config files

    .htacess

    Code:
    # Elgg htaccess directives
    # Copyright Curverider Ltd 2008-2009
    # License http://www.gnu.org/licenses/old-licenses/gpl-2.0.html GNU Public License version 2
    # Link http://elgg.org/
    
    <IfModule !mod_rewrite.c>
        # ugly ugly hack to detect missing mod_rewrite
        # RedirectMatch must be to an absolute destination, so forces 500 error...
        ErrorDocument 500 "Elgg error: Apache does not have mod_rewrite loaded. Please check your Apache setup."
        RedirectMatch 302 .* index.php
    </IfModule>
    
    <Files "htaccess_dist">
        order allow,deny
        deny from all
    </Files>
    
    # Turn on expiry
    <IfModule mod_expires.c>
    	ExpiresActive On
    	ExpiresDefault "access plus 10 years"
    </IfModule>
    
    Server Settings in ISPConfig 3

    Code:
    <Directory /var/www/clients/client2/web4/web>
            AllowOverride All
    		Options -Indexes
    		Options +FollowSymLinks
    		DirectoryIndex index.php
    </Directory>
    
    php_value memory_limit 32M
    php_value upload_max_filesize 64M
    
    # php 5, apache 1 and 2
    <IfModule mod_php5.c>
    	# default memory limit to 64Mb
    	php_value memory_limit 64M
    	# to make sure register global is off
    	php_value register_globals 0
    	# max post size to 8Mb
    	php_value post_max_size 8388608
    	# upload size limit to 5Mb	
    	php_value upload_max_filesize 5242880
    	# hide errors, enable only if debug enabled
    	php_value display_errors 0
    </IfModule>
    
    # Turn on mod_gzip if available
    <IfModule mod_gzip.c>
    	mod_gzip_on yes
        mod_gzip_dechunk yes
        mod_gzip_keep_workfiles No
        mod_gzip_minimum_file_size 1000
        mod_gzip_maximum_file_size 1000000
        mod_gzip_maximum_inmem_size 1000000
        mod_gzip_item_include mime ^text/.* 
        mod_gzip_item_include mime ^application/javascript$
        mod_gzip_item_include mime ^application/x-javascript$
        # Exclude old browsers and images since IE has trouble with this
        mod_gzip_item_exclude reqheader "User-Agent: .*Mozilla/4\..*\["
        mod_gzip_item_exclude mime ^image/.*
    </IfModule>
    
    ## Apache2 deflate support if available
    ##
    ## Important note: mod_headers is required for correct functioning across proxies.
    ##
    <IfModule mod_deflate.c>
    	AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript application/javascript application/x-javascript
    	BrowserMatch ^Mozilla/4 gzip-only-text/html
    	BrowserMatch ^Mozilla/4\.[0678] no-gzip
    	BrowserMatch \bMSIE !no-gzip
    
    <IfModule mod_headers.c>	
    	Header append Vary User-Agent env=!dont-vary
    </IfModule>	
    	
    	# The following is to disable compression for actions. The reason being is that these
    	# may offer direct downloads which (since the initial request comes in as text/html and headers
    	# get changed in the script) get double compressed and become unusable when downloaded by IE.
    	SetEnvIfNoCase Request_URI action\/* no-gzip dont-vary
    	SetEnvIfNoCase Request_URI actions\/* no-gzip dont-vary
    	
    </IfModule>
    
    # Configure ETags
    <FilesMatch "\.(jpg|jpeg|gif|png|mp3|flv|mov|avi|3pg|html|htm|swf)$">
    	FileETag MTime Size
    </FilesMatch>
    
    <IfModule mod_rewrite.c>
    
    RewriteEngine on
    
    # If Elgg is in a subdirectory on your site, you might need to add a RewriteBase line
    # containing the path from your site root to elgg's root. e.g. If your site is
    # http://example.com/ and Elgg is in http://example.com/sites/elgg/, you might need 
    #
    RewriteBase /comunidad/
    #
    # here, only without the # in front.
    #
    # If you're not running Elgg in a subdirectory on your site, but still getting lots
    # of 404 errors beyond the front page, you could instead try:
    #
    #RewriteBase /
    
    RewriteRule ^action\/([A-Za-z0-9\_\-\/]+)$ engine/handlers/action_handler.php?action=$1
    
    RewriteRule ^export\/([A-Za-z]+)\/([0-9]+)$ services/export/handler.php?view=$1&guid=$2
    RewriteRule ^export\/([A-Za-z]+)\/([0-9]+)\/$ services/export/handler.php?view=$1&guid=$2
    RewriteRule ^export\/([A-Za-z]+)\/([0-9]+)\/([A-Za-z]+)\/([A-Za-z0-9\_]+)\/$ services/export/handler.php?view=$1&guid=$2&type=$3&idname=$4
    
    RewriteRule ^\_css\/css\.css$ _css/css.php
    
    RewriteRule ^pg\/([A-Za-z0-9\_\-]+)\/(.*)$ engine/handlers/pagehandler.php?handler=$1&page=$2
    RewriteRule ^pg\/([A-Za-z0-9\_\-]+)$ engine/handlers/pagehandler.php?handler=$1
    
    RewriteRule xml-rpc.php engine/handlers/xml-rpc_handler.php
    RewriteRule mt/mt-xmlrpc.cgi engine/handlers/xml-rpc_handler.php
    
    RewriteRule ^tag/(.+)/?$ engine/handlers/pagehandler.php?handler=search&page=$1
    
    </IfModule>
    
    And thats it, i can continue whit the Elgg V1.6 installation

    Regards,

    Hector
     

Share This Page