[electronico_nc Fixed it] Oops.... php updates broke admin side

Discussion in 'Installation/Configuration' started by Viper_iii, Nov 27, 2018.

  1. Viper_iii

    Viper_iii Member

    Have jessie installed and current 3.1 ispconfig - that was updated to most current as of ~ 60 days ago so should be fully current...
    unfortunately I can't tell unless someone give me a way to very and check via ssh... - currently can't access admin pages.
    Deb 8 that is - so default PHP should be 5.6 I believe...

    months / last year - awhile back installed some of the manual PHP installs - via:
    https://www.howtoforge.com/tutorial/how-to-install-php-7-on-debian/
    thought I did 7.0 and 7.1 but not sure... they were partially working but pretty sure I did not do it perfectly... but mostly...LOL - worked at least for the most part...

    couple weeks ago ran this setup.
    https://www.howtoforge.com/tutorial...fig-3-from-debian-packages-on-debian-8-and-9/
    so php would be updated via apt vs manual updates ---
    initially appeared it was working but after a power failure recently - found that the server was running and client sites - mostly running however admin interface https://<name/ip>:8080 gets a 500 error...

    and is complaining about fcgi I believe...

    Per new article I reset OS php via:
    update-alternatives --config php
    update-alternatives --config php-cgi
    to 5.6 which was not installed only php5
    so i installed / reinstalled 5.6 so it would be there.

    still no go..
    restarting all php services all good except 7.1
    service php7.1-fpm restart
    Job for php7.1-fpm.service failed. See 'systemctl status php7.1-fpm.service' and 'journalctl -xn' for details.
    # systemctl status php7.1-fpm.service -l
    ERROR: An another FPM instance seems to already listen on /var/lib/php5-fpm/web7.sock
    Nov 27 09:41:16 host.srv.com php-fpm7.1[27408]: [27-Nov-2018 09:41:16] ERROR: FPM initialization failed

    pretty sure 7.1 is trying to be the base PHP but not sure how to fix ... not really critcal and nothing major hosted and still have access to all that data anyway.
    ideas?
     
    Last edited: Nov 27, 2018
  2. I would run
    Code:
     php --version
    to know the actual default php version.
    Then manually modify:
    Code:
     /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter
    with right php version.
    Check that permissions are well ispconfig:ispconfig on this file too.
    Your Ispconfig dashboard should be live again.
    Then change values in
    System / server config / web / php settings and
    System / server config / fcgi settings to right php / fcgi / fpm versions
     
    Viper_iii likes this.
  3. ahrasis

    ahrasis Well-Known Member

    Check whether all php updates are properly installed because sometimes they do not. You might need to run e.g. apt-get install php7.2 for the updates to continue fully sometimes.
     
  4. Viper_iii

    Viper_iii Member

    Updates should be good - Pretty sure it was due to multiple versions pf PHP...

    -
    Code:
     php --version
    PHP 7.0.32-2+0~20181015120515.7+jessie~1.gbpa6b8cf (cli) (built: Oct 15 2018 19:38:45) ( NTS )
    Copyright (c) 1997-2017 The PHP Group
    Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
        with Zend OPcache v7.0.32-2+0~20181015120515.7+jessie~1.gbpa6b8cf, Copyright (c) 1999-2017, by Zend Technologies
    can also change to 5.6 just generates different errors in /var/log/apache2/error.log

    checking next.

    Code:
     /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter
    
    #!/bin/sh
    PHPRC=/etc/php5/cgi/
    export PHPRC
    export PHP_FCGI_MAX_REQUESTS=5000
    export PHP_FCGI_CHILDREN=1
    exec /usr/bin/php-cgi \
        -d disable_classes= \
        -d disable_functions= \
        -d magic_quotes_gpc=off \
        -d open_basedir= \
        -d session.save_path=/usr/local/ispconfig/interface/temp
    
    yup that was it...
    old directory pretty much doesn't exist... well since I removed all php versions as well.
    think this box was upgraded from wheezy probably... / maybe sarge not sure...

    testing with new path of PHPRC=/etc/php/7.0/cgi/
    vs old
    PHPRC=/etc/php5/cgi/
    Code:
    # /usr/local/ispconfig/server/server.sh
    finished.

    Code:
     service apache2 restart
    # tail /var/log/apache2/error.log
    
    just some issues with self signed cert and pyton 2.7.5 expected but getting 2.7.9

    and that appears to have resolved it and admin side is back up and working...
    sure I had a snapshot and backups, but appreciate the assistance in correcting my @#[email protected] er... mistakes...
     
    electronico_nc likes this.

Share This Page