Either php5-fpm or php-7.1-fpm, but not on the same time

Discussion in 'Installation/Configuration' started by linus, Jan 12, 2018.

  1. linus

    linus Member

    When I try to start either php5-fpm or php-7.1-fpm once the other is running I get an error:
    php-fpm[26768]: [12-Jan-2018 02:19:02] ERROR: An another FPM instance seems to already listen on /var/lib/php5-fpm/web251.sock

    What might be strange is that both the generated conf files:
    ... both contain the same content:
    listen = /var/lib/php5-fpm/web301.sock
    listen.owner = web301
    listen.group = www-data
    listen.mode = 0660
    The php site settings has PHP-FPM default.

    Shouldn't at least the listen part be different in the configuration files? And why would the same site (web301, but there are other too) have both php-7.1-fpm and php5-fpm configurations? Is it this that occupies the sock and prevents the other start up?

    The php 7-1 version is added with the following configuration:
    Path to the PHP-FPM init script /etc/init.d/php-7.1-fpm
    Path to the php.ini directory /opt/php-7.1/lib
    Path to the PHP-FPM pool directory /opt/php-7.1/etc/php-fpm.d

    The php5 is default and I think it should not be added as an additional version.
    The setup has two servers are replicating and both behaving this way regarding the FPM.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I've never seen that a site has two php-fpm config files. when you switch php version, then one file get's removed and another one is added. Either there is a problem that the old file could not be removed on your system or the pool directories are symlinked somehow? You can use the ispconfig debug mode to see what going on in details when you add a site or when you switch the php mode.

Share This Page