edition of /etc/sysctl.conf

Discussion in 'Installation/Configuration' started by Balbuzard, Mar 18, 2009.

  1. Balbuzard

    Balbuzard New Member

    Hi!

    I have installed OpenVZ on Debian 5.0 Lenny and I am afraid having some trouble with an error-message which comes out during the reboot of the debian-computer;

    Code:
    Setting kernel variables /etc/sysctl.conf line net.ipv4.conf.eth1.proxy_arp=1 is an unknown key failed
    I have followed the steps to install OpenVZ on Debian, except for this line, I have had to change eth0 to eth1 because the eth0 interface is broken.

    I have not configured openvz now, could you please explain to me if this error-message will have consequences during the creation of the containers? And is there any way to fix it?

    Thanks a lot for your answers!!
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Do you see this error also when you run
    Code:
    sysctl -p
    ? What's the output of
    Code:
    ifconfig
    ?
     
  3. Balbuzard

    Balbuzard New Member

    No, there is no error in the output of sysctl -p
    Here is the output of ifconfig:
    Code:
    eth1      Link encap:Ethernet  HWaddr 00:03:2d:09:8a:51  
              inet addr:203.143.170.20  Bcast:203.143.170.255  Mask:255.255.255.0
              inet6 addr: 2402:1800:0:a004:203:2dff:fe09:8a51/64 Scope:Global
              inet6 addr: fe80::203:2dff:fe09:8a51/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:2011 errors:0 dropped:0 overruns:0 frame:0
              TX packets:74 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:206646 (201.8 KiB)  TX bytes:10018 (9.7 KiB)
              Interrupt:18 Base address:0xdc00 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    
    venet0    Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
              UP BROADCAST POINTOPOINT RUNNING NOARP  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    
    Maybe is's just a warning, and there is no real problem with it...
    Thanks for your answer!!

    EDIT:

    I have created my first container, and setted it its IP address:
    Code:
    :~# vzctl start 101
    Starting container ...
    Container is mounted
    Adding IP address(es): 192.168.0.101
    arpsend: 192.168.0.101 is detected on another computer : 00:00:0c:07:ac:00
    vps-net_add WARNING: arpsend -c 1 -w 1 -D -e 192.168.0.101 eth1 FAILED
    Setting CPU units: 1000
    Configure meminfo: 65536
    Set hostname: first
    Container start in progress...
    
    I don't understand the WARNING message, is there any link with the trouble I have had before?
    Thanks for your help, falko!
     
    Last edited: Mar 20, 2009
  4. falko

    falko Super Moderator ISPConfig Developer

    Do you get the error also when you use net.ipv4.conf.eth0.proxy_arp=1 instead of net.ipv4.conf.eth1.proxy_arp=1?
     
  5. Balbuzard

    Balbuzard New Member

    Yes, it's the same. I have not used the eth0 interface because there is a problem on it.
    Thanks for your answer!
     
  6. falko

    falko Super Moderator ISPConfig Developer

    What's in your /etc/sysctl.conf?
     
  7. Balbuzard

    Balbuzard New Member

    Hi!
    Here is my sysctl.conf file (I have not pasted all the comments)
    Thanks again for your help! But maybe this error doesn't mean anything?

    Code:
    # Uncomment the next line to enable packet forwarding for IPv4
    net.ipv4.ip_forward=1
    
    # Uncomment the next line to enable packet forwarding for IPv6
    #net.ipv6.conf.all.forwarding=1
    #-- OpenVZ begin --#
    
    # On Hardware Node we generally need
    # packet forwarding enabled and proxy arp disabled
    net.ipv4.conf.default.forwarding=1
    net.ipv4.conf.default.proxy_arp = 0
    
    # Enables source route verification
    net.ipv4.conf.all.rp_filter = 1
    
    # Enables the magic-sysrq key
    kernel.sysrq = 1
    
    # TCP Explict Congestion Notification
    #net.ipv4.tcp_ecn = 0
    
    # we do not want all our interfaces to send redirects
    net.ipv4.conf.default.send_redirects = 1
    net.ipv4.conf.all.send_redirects = 0
    net.ipv4.conf.eth1.proxy_arp=1
    
    #-- OpenVZ end --#
    
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Looks ok. Not sure what the problem is... :(
     
  9. Balbuzard

    Balbuzard New Member

    OK
    I consider this trouble as solved, I have not had issues when building the internet connection between the containers or between internet and the containers, so maybe it's just a warning, even if it does not look like it.

    Thank you for your help!
     

Share This Page