Edgy Email Relay Access Denied Issues

Discussion in 'HOWTO-Related Questions' started by 3DPeruna, Jan 19, 2007.

  1. 3DPeruna

    3DPeruna New Member

    I've successfully run the The Perfect Setup - Ubuntu 6.10 Server (Edgy Eft)...almost. ISPConfig is up and running with 2 domains (one DNS is at zoneedit, the other is running on the server). I've also successfully installed webmail. Here's a quick rundown:

    1) I can run the "test account" for email accounts from both domains successfully.
    2) I can log in to accounts from webmail and send mail.
    3) I do not receive any mail sent to the email accounts.
    4) If I send mail from other email accounts (hotmail, different domains, etc), I always get: 5.7.1 <user@domain.com>: Relay access denied.

    I've gone through the forum several times, trying the various proposed fixes for similar problems without success.

    I've included my postfix main.cf file for starters, (comments removed):

    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no
    append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.

    myhostname = ohdweb.$mydomain
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydestination = example.server1.com, localhost.example.com, localhost
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    #smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_relay_domains
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    append_at_myorigin = no
    mydomain = server.com

    TIA
     
  2. falko

    falko Super Moderator

    Please run
    Code:
    postconf -e 'mydestination = /etc/postfix/local-host-names'
    postconf -e 'virtual_maps = hash:/etc/postfix/virtusertable'
    /etc/init.d/postfix restart
     
  3. 3DPeruna

    3DPeruna New Member

    That did it! Thank you much...
     

Share This Page