eaccelerator trouble with etch

Discussion in 'Server Operation' started by Ovidiu, Apr 23, 2007.

  1. Ovidiu

    Ovidiu Active Member

    hi there,

    I have been running eaccelerator for quite a while, did severall reinstalls - every time apache or php got upgraded, but after upgrading to etch, I can't get it working anymore.

    tried the old reliable 0.94 version and the new 0.95 but no luck.

    so I recorded my compiling session for anyone who could spare a few minutes to check for errors.

    here is the important part, no sign of eaccelerator:
     

    Attached Files:

  2. falko

    falko Super Moderator ISPConfig Developer

    Have you tried a phpinfo() script in your browser?
     
  3. Ovidiu

    Ovidiu Active Member

    I did not bother as php -v did not yield any results...

    but trying this test shows me its working :confused:

    I'll try and put together those eaccelerator control/test scripts... and see what those tell me...
     
  4. falko

    falko Super Moderator ISPConfig Developer

    I think that php -v uses your command line PHP interpreter, while eAccelerator works with the Apache PHP module only.
     
  5. Ovidiu

    Ovidiu Active Member

    similar problem again:

    updated via apt-get upgrade from php 4.4.8-etch to 4.4.8-etch2 then did the usual compilation/installation steps with eaccelerator, restarted apache2 but when accessing my eaccelerator control panel I get this:

    eAccelerator isn't installed or isn't compiled with info support!

    and when accessign a php page with <?php
    phpinfo();
    ?> I get only these 2 occurences of eaccelerator:

    PWD /usr/local/src/eaccelerator-0.9.5
    _ENV["PWD"] /usr/local/src/eaccelerator-0.9.5

    any clues what could be wrong?
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Did you edit the correct php.ini? Did you restart Apache?
     
  7. Ovidiu

    Ovidiu Active Member

    I did restart apache and I edited this file: nano /etc/php4/apache2/php.ini

    the lines I inserted there are not fresh. they have been in this file since Iused eaccelerator for the first time. these are the entries:

    I compared these settigns with the newest on their site and these all still exist... any other ideas?
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Does the correct eaccelerator.so (the new one) exist in the PHP extensions directory?
    Any errors in Apache's error log?
     
  9. Ovidiu

    Ovidiu Active Member

    I compiled in /usr/local/src/eaccelerator-0.9.5

    cat /var/log/apache2/error.log | grep eaccel
    did not yield any results. what other stuff should I be looking for? shall I record another compiling session and attach it here?
     
  10. falko

    falko Super Moderator ISPConfig Developer

    Can you take a look at the creation date of all those eaccelerator.so files to find out which one is the newest one?
     
  11. Ovidiu

    Ovidiu Active Member

    I just compiled again, and during the compilation process I get this information:

    and btw. its still not working :) I kind of had a weak hope it could work this time...
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Can you copy /usr/local/src/eaccelerator-0.9.5/.libs/eaccelerator.so to /usr/lib/php4/20020429 (make a backup of the old eaccelerator.so before you do this) and restart Apache?
     
  13. Ovidiu

    Ovidiu Active Member

    ok, done so, but now after reloading ther is no trace of eaccelerator in my phpinfo page :-(
     
  14. Ovidiu

    Ovidiu Active Member

    @falko

    interested in solving this as a paid job? should be done in a few minutes :) if you have access.... can you pm me please? I am fairly optimistic I will get a new , big, customer soon, so I would need eaccelerator to be in place when his traffic starts to hit my server.
     
  15. Ovidiu

    Ovidiu Active Member

    finayll I found an error:

    I don't know why but apache2 seems to be still trying to load the old version, although I just compiled again... I am going to copy the fresh compiled .so extension over all other copies...
     
  16. Ovidiu

    Ovidiu Active Member

    this thing is driving me crazy. instead of running phpize like told on the website of eaccelerator, I tried phpize4 but with the saem result :-(

    please somebody help me :-()
     
  17. Ovidiu

    Ovidiu Active Member

    one more related question:

    if I have a cache of 32MB for eaccelerator and also use the apache2 mem_cache module for in-memory-caching which also has 32MB how exactly are these 2 working together? I mean is one cache serving the other cache? Is this setup useless?
     
  18. falko

    falko Super Moderator ISPConfig Developer

    The eaccelerator cache is for PHP scripts only, whereas mem_cache is for all files served by Apache.
     
  19. Ovidiu

    Ovidiu Active Member

    still having trouble with eaccelerator. I compiled and isntalled it and apache2 does not start. in the error logs I have this:

    where can I look? it seems eaccelerator is being loaded multiple times... which config files to check?

    it seems eaccelerator.so get loaded here:

    how does this look in your isntall? (Debian Etch) so I can delete all unneccesary occurances.

    it seems only these lines are active, the others are commented:

     
    Last edited: Aug 19, 2007
  20. falko

    falko Super Moderator ISPConfig Developer

    I'd comment out anything in /etc/php4/conf.d/eaccelerator.ini and try again.
     

Share This Page