eAccelerator - open_basedir restriction. In Unknown on line 0

Discussion in 'Server Operation' started by Focus, Mar 16, 2010.

  1. Focus

    Focus New Member

    SOLVED! eAccelerator - open_basedir restriction. In Unknown on line 0


    I have a webserver with ISPConfig 3 installed and running smoothly but it is very slow. So I decided to install eAccelerator, seemingly without any hazzle.

    Now, when I hit the page, I get this error:

    Can anyone give me a hint about what could possibly be the problem?

    My php looks like this:

    And my eaccelerator.ini file:

    Kind regards
    Last edited: Mar 17, 2010
  2. Focus

    Focus New Member


    Necessity is the mother of invention ;-)

    After a lot of trial and error I took at look inside the /etc/apache2/sites-enabled folder, where ISPConfig saves the individual site configuration in files like this one:


    Here I simply uncommented the line beginning with:

    And eAccelerator started immediately the caching mechanism. Works like a charm and what a performance boost!

    So there is maybe one question left now.

    Can I live without php_admin_value open_basedir ...blablabla..?
  3. lifodesbois

    lifodesbois New Member

    After many days of google-ing, I've found the right solution under F12.
    The pb was at eaccelerator.

    To properly handle both eaccelerator & open_basedir, you have to rebuild php-eaccelerator with the configure option set to:

    I've also found that this option should be unavailable in future release of EA.

    Now, all works well !


Share This Page