eaccelerator installation - can't find php5-config

Discussion in 'Programming/Scripts' started by tom, May 8, 2006.

  1. tom

    tom Member

    I would like install eaccelerator beta2 with php5.

    On the eaccelerator page http://eaccelerator.net/wiki/InstallFromSource they tell to change that path PHP_PREFIX but I can't find the file php5-config. Only php-config and php4-config I can find on debian3.1 with php5.1.4.

    Any ideas how to set the right path for compiling?

    Code:
    export PHP_PREFIX="/usr"
    $PHP_PREFIX/bin/phpize
    ./configure --enable-eaccelerator=shared --with-php-config=$PHP_PREFIX/bin/php-config
    make
    tom
     
  2. falko

    falko Super Moderator

    Maybe php-config belongs to your PHP5 installation?
    How did you install PHP5? As a package, or did you compile from the sources?
     
  3. tom

    tom Member

    As a package
    Code:
    WARNUNG: Die folgenden Pakete können nicht authentifiziert werden!
      php5
    Diese Pakete ohne Überprüfung installieren [j/N]? j
    Wähle vormals abgewähltes Paket php5.
    (Lese Datenbank ... 22663 Dateien und Verzeichnisse sind derzeit installiert.)
    Entpacke php5 (aus .../php5_5.1.4-1.dotdeb.1_all.deb) ...
    Richte php5 ein (5.1.4-1.dotdeb.1) ...
    
    sarge01:/usr/lib/php5# updatedb
    sarge01:/usr/lib/php5# locate php-config
    /root/ispconfig/php/bin/php-config
    /root/ispconfig/php/man/man1/php-config.1
    sarge01:/usr/lib/php5# locate php4-config
    sarge01:/usr/lib/php5#
    I'm even a bit unhappy with php5 package and the disauthenticity.
    Now I've removed php4 and php5 and reinstalled php5 again but now there is no php-config anymore only for ispconfig. Is'nt it?
     
    Last edited: May 9, 2006
  4. falko

    falko Super Moderator

    What's the output of
    Code:
    updatedb
    locate php|grep config
    ?
     
  5. tom

    tom Member


    everything in
    Code:
    /home/admispconfig/
    /root/ispconfig/
    but nothing what I'm searching for.
     
    Last edited: May 10, 2006
  6. falko

    falko Super Moderator

    As you installed PHP5 as a package, you must also install php5-devel (or similar). php-config should be in there.
     
  7. tom

    tom Member


    which on is it?
    I think "php5-dev - Files for PHP5 module development"
    that includes /usr/bin/php-config5

    What for I need php5-dev or similar?
    Only for the installation eaccelerator?
     
    Last edited: May 11, 2006
  8. falko

    falko Super Moderator

    Yes, it's php5-dev.

    Whenever you compile something that needs PHP, you need PHP5-dev.
     
  9. tom

    tom Member

    Now I've installed fastcgi and eaccelerator but I get an error 500 after I've installed eaccelerator.

    Do they work clean together?
     
  10. falko

    falko Super Moderator

    I'm not quite sure if eaccelerator supports PHP5.
    Is there anything in your Apache error log?
     

Share This Page