eaccelerator and PHP

Discussion in 'Server Operation' started by Ovidiu, Nov 21, 2009.

  1. Ovidiu

    Ovidiu Active Member

    running a Debian 5.0 + ISPCFG3 installation.
    I know eaccelerator like tools don't work with suPhp.

    I installed eaccelerator and my sites running on fasCGI do use it.

    Now I wondered why phpinfo() shows eaccelerator enabled on my suPhp vhsots too. Can it be disabled for those? Is it wasting my memory? I have 2 sites running fastCGi and 8 or so using suPhp.

    the fastCGi ones report:

    Code:
    eAccelerator
    eAccelerator support	enabled
    Version 	0.9.5.3
    Caching Enabled 	true
    Optimizer Enabled 	true
    Memory Size 	67,108,800 Bytes
    Memory Available 	21,573,800 Bytes
    Memory Allocated 	45,535,000 Bytes
    Cached Scripts 	412
    Removed Scripts 	0
    Cached Keys 	52 
    the suPhp ones report:
     
  2. Ovidiu

    Ovidiu Active Member

    anyone? Or is this a silly question?
     
  3. falko

    falko Super Moderator

  4. Ovidiu

    Ovidiu Active Member

    So basically I am wasting memory?

    I should either consider switching my suphp vhosts to fastCGI to make use of the eaccelerator memory or switch the fastCGI ones to suPhp and stop using eaccelerator, right?
     
  5. Ovidiu

    Ovidiu Active Member

  6. Ovidiu

    Ovidiu Active Member

    @Falko:

    Have you had a look? Would that work out? To me it looks like its possible, but I am still not sure if there is any gain in this - making extra php.ini's for suPhp so thta eaccelerator isn't loaded?
     
  7. Ovidiu

    Ovidiu Active Member

    any opinions on this? jsut want to know if what I am saying/suspecting makes sense.
     
  8. Ovidiu

    Ovidiu Active Member

    I have two vhosts, one with fastcgi+suexec the other one with suphp.

    I have one info.php file inside each vhost and the output is:

    For the suPHP enabled one:
    Server API CGI/FastCGI
    Virtual Directory Support disabled
    Configuration File (php.ini) Path /etc/php5/cgi
    Loaded Configuration File /var/www/conf/web7/php.ini

    For the FastCGi enabled one:
    Server API CGI/FastCGI
    Virtual Directory Support disabled
    Configuration File (php.ini) Path /etc/php5/cgi
    Loaded Configuration File /etc/php5/cgi/php.ini

    Now why would the first one also claim he is CGI if he is actually running on suPHP? I killed all fastcgi processes and restarted apache a couple of times, still no changes...
     

Share This Page