E-mail Problems All outgoing e-mails @localhost as domain

Discussion in 'Installation/Configuration' started by bentown, Jun 19, 2007.

  1. bentown

    bentown New Member

    Hi,

    This is the first time ive posted on these forums but i have read them alot. I have also used alot of the How to guides.

    I setup my server following the installing A LAMP System With Fedora Core 6 (thanks falko!!!)

    Ive used this guide before and had everything up and running fine.

    I am using roudecube as my webmail client, and on all outgoing e-mails it says @localhost instead of the domain name. Eg [email protected]

    I can still send e-mails but they all come through as [email protected]lhost

    I can change this in the preferences and its it will save it but its a hassel to log into each and every new e-mail account i create and fix it.

    postconf -n produces the following

    Code:
    alias_database = hash:/etc/aliases
    alias_maps = hash:/etc/aliases
    broken_sasl_auth_clients = yes
    command_directory = /usr/sbin
    config_directory = /etc/postfix
    daemon_directory = /usr/libexec/postfix
    debug_peer_level = 2
    html_directory = no
    inet_interfaces = all
    mail_owner = postfix
    mailq_path = /usr/bin/mailq.postfix
    manpage_directory = /usr/share/man
    mydestination = /etc/postfix/local-host-names
    mynetworks = 127.0.0.0/8, 192.168.1.0/24
    newaliases_path = /usr/bin/newaliases.postfix
    queue_directory = /var/spool/postfix
    readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
    sample_directory = /usr/share/doc/postfix-2.3.3/samples
    sendmail_path = /usr/sbin/sendmail.postfix
    setgid_group = postdrop
    smtp_tls_note_starttls_offer = yes
    smtp_use_tls = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_local_domain =
    smtpd_sasl_security_options = noanonymous
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_auth_only = no
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_loglevel = 1
    smtpd_tls_session_cache_timeout = 3600s
    smtpd_use_tls = yes
    tls_random_source = dev:/dev/urandom
    
    Im rather new to linux, but i have looked around and cant really find much, i think its because i dont know what the actual problem is if you get my drift.

    Thanks in advance.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you set a sender and reply address in the options in roundcube?
     
  3. bentown

    bentown New Member

    yes i have, but i want it to automatically pick up the domain which the e-mail address belongs to.

    Eg [email protected] instead of [email protected]

    Im not sure where i have gone wrong, other times ive had this work correctly but in this instance i havent.

    Do you know how roundcube pulls the domain name for the user logging in?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    If roundcube has a plugin for reading a postfix virtusertable file, you might be able to use this to get the nescessary information. If not, you will have to extend roundcube to read the data from the ISPConfig database or the virtusertable file.
     
  5. bentown

    bentown New Member

    it should by default read the virtusertable, well in its config file it is pointed to it. But it doesnt seem to be picking them up. I had a peak in the /etc/postfix/virtusertable and all the correct entries are in there, so atleast i know ISPconfig is entering them as it should be.

    It just seems that roundcube isnt collecting them which is even more odd.

    Im going to have a look over the roundcube config file again.

    Edit: ive looked around and in the how to guide, they say that you just change it, but no reason as to why it doesnt pick ip up automatically.
     
    Last edited: Jun 20, 2007
  6. falko

    falko Super Moderator ISPConfig Developer

    Please run
    Code:
    postconf -e 'virtual_maps = hash:/etc/postfix/virtusertable'
    /etc/init.d/postfix restart
     

Share This Page