E-mail Problem ( Hotmail , yahoo )

Discussion in 'General' started by ibrahimak, Apr 13, 2007.

  1. ibrahimak

    ibrahimak New Member

    Hi ,

    Everything is working fine i can get and send email but when i sent an email to hotmail it doesnt receive my emails.And when i sent mail to yahoo its taking my emails spam folder. Whats the problem??
  2. edge

    edge Active Member Moderator

    1) - Make sure that your MX record is setup okay
    2) - Make sure that your reverse DNS is setup okay.
    3) - Make sure that your SPF record is setup okay.
    4) - CONTACT the Windows Live Hotmail Domain Support, and ASK if they add your domain to the SenderID program.

    More info here: http://www.howtoforge.com/forums/showthread.php?t=11725&highlight=hotmail , and when you do a search on this forum for "hotmail"
  3. ibrahimak

    ibrahimak New Member

    I have checked everything.I made a SPF Record but HOTMAIL dont accept my email yet.And YAHOO taking my emails to bulk folder.

    my domain : lilainsaat.com

    wHats the problem ????
  4. edge

    edge Active Member Moderator

    If all is okay, (which is not the case for lilainsaat.com) your mail should go to Hotmails "Bulk" folder.
    To get it out the "Bulk" folder (again.. when all is setup okay), you WILL need to contact Hotmail, and ask if they add your domain to the SenderID program.

    You will really need to get your DNS fixed for your domain to have any chance to get it to work with Hotmail. Have a look here: http://www.dnsreport.com/tools/dnsreport.ch?domain=lilainsaat.com
    All fails need to be fixed 1st!

    More info: http://postmaster.live.com/
    When you are 100% sure that all is setup okay, use this form and ask if they add your domain to the SenderID program.

    It's the same for Yahoo (and many more email providers). When all is setup okay, ask if they can "white list" your domain(s)
    Last edited: Apr 17, 2007
  5. ibrahimak

    ibrahimak New Member

    I cant fix this problem ;

    Your 1 MX record is:

    10 mail.lilainsaat.com.lilainsaat.com. [TTL=38400] IP=[No Glue, No A record]

    my mail server adress is : mail.lilainsaat.com but DNS Report show this so gave me CANT Connect Mail Servers error.I have looked everywhere for this but i couldnt see any problem with my DNS Records
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The MX record is wrong. You must leave the hostname field empty when you crete the MX record in ISPConfig DNS-Manager.
  7. ibrahimak

    ibrahimak New Member

    So how can i fix this ,

    Missing (stealth) nameservers FAIL: You have one or more missing (stealth) nameservers. The following nameserver(s) are listed (at your nameservers) as nameservers for your domain, but are not listed at the parent nameservers (therefore, they may or may not get used, depending on whether your DNS servers return them in the authority section for other requests, per RFC2181 5.4.1). You need to make sure that these stealth nameservers are working; if they are not responding, you may have serious problems! The DNS Report will not query these servers, so you need to be very careful that they are working properly.


    its added lilainsaat.com. this is wrong. It must be hastane.bayar.edu.tr only.Why its added lilainsaat.com?
  8. falko

    falko Super Moderator ISPConfig Developer

    I get this result:

    mh1:~# dig ns lilainsaat.com
    ; <<>> DiG 9.2.1 <<>> ns lilainsaat.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 54293
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0
    ;lilainsaat.com.                        IN      NS
    lilainsaat.com.         86400   IN      NS      ns1.hastane.bayar.edu.tr.
    lilainsaat.com.         86400   IN      NS      ns2.hastane.bayar.edu.tr.
    ;; Query time: 99 msec
    ;; SERVER:
    ;; WHEN: Tue Apr 17 11:25:47 2007
    ;; MSG SIZE  rcvd: 88
    Are ns1.hastane.bayar.edu.tr and ns2.hastane.bayar.edu.tr your own name servers, or are they owned by someone else? Because that are the name servers where you must create/modify your DNS records.
  9. mitho7

    mitho7 Member

    hotmail problem

    hi till,
    i have added the SPF record. now on gmail headder it is saying
    "Received-SPF: pass (google.com: domain of [email protected] designates as permitted sender)" that means SPF is ok, But still can not send the email to hotmail. yahoo, gmail is working fine.
  10. edge

    edge Active Member Moderator

    Fix your reverse DNS, and try again (you will probably need to contact your ISP to do this)
    When your reverse DNS is fixed, your email should go to Hotmail, but it might end up in the Junk folder.

    If so, contact Hotmail, and ask if they can add you domain to the SenderID program.
    Last edited: Apr 18, 2007
  11. mitho7

    mitho7 Member

  12. falko

    falko Super Moderator ISPConfig Developer

    Ask your ISP (because he's responsible for your IP address and therefore the reverse record) if they can modify your reverse record.
  13. mitho7

    mitho7 Member

    Hi Falko,

    Can you please tell me, what exactly i need to tell them to do? Coz I’m not good at those stuff, that’s why we got till to install the ISPConfig for me.

  14. edge

    edge Active Member Moderator

    Aks your internet service provider (the one who is used by your server) to set the reverse DNS for your IP to desicards.com.au

    But please be aware that this will/might still not fix your Hotmail / Yahoo email problem!
    Last edited: Apr 19, 2007
  15. mitho7

    mitho7 Member

    reverse dns is done, but when i sned the email it goes from abttel.abttel.com, not form mail.desicards.com.au.

    i got the that from google mail header
    "Received: from abttel.abttel.com (ns4.abttel.com [203.....])"

    I have added the SPF record under DNS Manager, but sitll saying that.

  16. edge

    edge Active Member Moderator

    You will need to create a DNS record (with MX) for desicards.com.au in ISPconfig.
    Also. You revers DNS is not correct! It's set to ns3.abttel.com.
  17. mitho7

    mitho7 Member

    So every web site i create i have to add reverse DNS for all of them from my ISP? if it is then, every web site i create i have to call my ISP to add the reverse DNS. Can i have a generic one since it gonna be a shared server. then also i'll need to have different IP for that.

    Till never said anythig about those when he install the ISP config for me.

    Also i have created the create a DNS record (with MX). but sitll email goes from abttel.abttel.com. abttel is host and abttel.com is the domian name of my server.

    I have noticed one thing, every time I add a new site from ISP manager and select "Create DNS:" and "Create DNS-MX:" it creates MX record Mailserver as abttet.abttel.com. Is that suppose to be doing that?

    Please advice.
    Last edited: Apr 30, 2007
  18. falko

    falko Super Moderator ISPConfig Developer

    You only need one reverse record for every IP address you have. It doesn't matter which hostname you use for the reverse record as long as
    dig <hostname>
    points to the IP address and
    dig -x <IP address>
    points to the hostname.

    Yes. If you want another record, you can change this in ISPConfig's DNS Manager.
  19. mitho7

    mitho7 Member

  20. edge

    edge Active Member Moderator

    Is the @xxxxxx.com the same domain as myhostname ?

Share This Page