e-mail issues- can´t send mails to any domain but mine

Discussion in 'Installation/Configuration' started by pewichali, Apr 9, 2009.

  1. pewichali

    pewichali New Member

    Hi, I installed ISPConfig with the perfect setup OpenSuse 10.2 all seems to work fine the domain, the site, i have no problems login and managing accounts; but i have an issue with the email. It happens that i can receive mails to mydomain.net from any domains but when im sending mails it only delivers mail to mydomain.net i cant send mails to any other domain different to mine. What can it be, plz helpme that's the only failure im experiencing with it.

    Checking the log on /var/log/mail it says something like:
    to=<dude@mydomain.net>, relay=none, delay=0.24, delays=0.07/0.01/0.17/0, dsn=5.4.6, status=bounced (mail for www.mydomain.net loops back to myself)
    is it something i did wrong???
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please add:

    www.mydomain.net

    at the end of the file /etc/postfix/local-host-names and restart postfix.
     
  3. pewichali

    pewichali New Member

    Thanks for answering, Ok i did it and still cant send mails to any other domain, if i send mails from yahoo; hotmail, gmail or any other account it is picked up by the mail server and delivered to the intended receiver; but the problem is that if i send an email from mydomain.net to gmail with a cc to mydomain.net I only receive the one that goes to mydomain.net I`m still waiting on the other accounts to get my copy of all those tests mails.

    I've copied another line of /var/log/mail and say:
    postfix/smtp[5574]: connect to mx3.hotmail.com[65.55.37.120]: Connection timed out (port 25)
    Apr 9 14:25:10 dynamic74-131 postfix/smtp[5574]: 57C624386B: to=<dude@hotmail.com>, relay=none, delay=153, delays=2.3/0.47/151/0, dsn=4.4.1, status=deferred (connect to mx3.hotmail.com[65.55.37.120]: Connection timed out)

    and here is some lines when a mails goes to mydomain:
    postfix/local[5597]: E64C44386C: to=<dude@mydomain.net>, orig_to=<dude@mydomain.net>, relay=local, delay=4.2, delays=0.14/2.5/0/1.6, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)

    It seems to me like if my postfix isn't sending some data to mx3.hotmail and that's why sends a timed out conection, am i right? any sugestions? (sorry 4 my english, im trying to be as clear as i can)
     
    Last edited: Apr 10, 2009
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Ask your provider if they block outgoing smtp connections and in case that you run your server on a dynamic IP then hotmail will reject the mails from their side.
     
  5. tebokkel

    tebokkel New Member

    Check with telnet if you can reach any outside port 25:
    telnet mx3.hotmail.com 25

    If not, you could also try to use your providers mailserver to forward your email (in /etc/postfix/main.cf):
    relayhost = smtp.yourprovider.nl

    Paul
     

Share This Page