E-mail in ISPConfig

Discussion in 'General' started by RaalFy, Jan 2, 2014.

  1. RaalFy

    RaalFy New Member


    I have recently installed and configured ISPconfig to host my sites and I've run into an issue with E-mail configuration. When I click on E-mail under "Available Modules", the page shows the white loading box but doesn't open the E-mail section. I've also tried to use the side links, everything e-mail related, from 'Domain' to 'E-mail Routing' all act the same way.

    It worked before as I've already configured some e-mail accounts and those still work, but as of now, I can't do anything e-mail related, regardless of the account I'm logged in with.

    Any help will be greatly appreciated.
    Last edited: Jan 2, 2014
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Check your apache config, it might be that you added a alias /mail somewhere. Change this alias to /webmail.
  3. RaalFy

    RaalFy New Member

    Hello Till, thank you very much.

    Yes, I had added a /mail and /webmail alias. I removed /mail, restarted apache and now everything works again.

    Care to explain to me how a /mail alias affected it?

    Thanks again :)
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    A alias /mail redirects every URL thats starts with /mail (or in other words, ecah site on your server that has a file or folder named named "mail". The ispconfig mail module is in the directory /mail, so you redirected requests for the mail module to your webmail client with that alias.
  5. RaalFy

    RaalFy New Member

    Thank you, Till :)

    Another reply of yours on another thread going back 3 years helped me solve another issue I was having. You're a life saver. Bless you! :)

Share This Page