E-mail domain not working with ISPConfig

Discussion in 'Installation/Configuration' started by fdsg72-lux, Nov 12, 2008.

  1. fdsg72-lux

    fdsg72-lux New Member

    Hi there,

    Background:
    I completed the following How To's to setup fresh install of Ubuntu 8.10 with ISPConfig and RoundCube WebMail:Issue:
    The e-mail domain 'oralab.com' listed in ISPConfig tab when creating users (see screen captures for details) is not working when sending e-mail to [email protected] nor when logging into RoundCube with [email protected]. Sending e-mail and logging in does work when using the full domain name of the website webmail.oralab.com e.g. [email protected] works.

    Here are the entries from my /etc/postfix/virtusertable file:
    ###################################
    #
    # ISPConfig virtusertable Configuration File
    # Version 1.0
    #
    ###################################
    [email protected] web4_fdadmin
    [email protected] web4_fdadmin
    #### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
    I do not see aliases for oralab.com, only for webmail.oralab.com, is this expected? Is there some other config/file where oralab.com is setup as an alias for webmail.oralab.com that I should verify/confirm?

    Help:
    Please let me know where to make the necessary change to allow e-mail to be sent to [email protected] and allow users to login with [email protected]?

    Thanks,
    Faan
     

    Attached Files:

  2. _X_

    _X_ New Member

    You need to define at Basis:
    Hostname: www
    Domain: oralab.com

    then go to Co-Domains and add:
    1)
    Hostname: < empty
    Domain: oralab.com
    2)
    Hostname: mail
    Domain: oralab.com
    Forward: http(s)://www.oralab.com/roudcube_path

    dissable Create DNS and Create DNS MX

    this way your site will be accessable at www.oralab.com and oralab.com (without www.) and webmail (roundcube) can be acccessed at mail.oralab.com since it exists in DNS records
     
    Last edited: Nov 12, 2008
  3. fdsg72-lux

    fdsg72-lux New Member

    Thank you for the suggested solution but I already have oralab.com as a co-domain of www.oralab.com configured exactly the way you described but am not able to actually send e-mail to [email protected], only to [email protected].

    I tried sending e-mail from one oralab.com e-mail account to another oralab.com e-mail account and even this fails.

    Is there some config file that I can verify the contents of to confirm that oralab.com is correctly setup as an alias domain for webmail.oralab.com as the /etc/postfix/virtusertable file do not have any such mappings?

    Thanks,
    Faan
     
  4. _X_

    _X_ New Member

    did you disabled Create DNS and Create DNS MX for webmail.oralab.com?

    btw MX record for oralab.com is mail.oralab.com. check it here:
    http://www.mxtoolbox.com
     
    Last edited: Nov 13, 2008
  5. fdsg72-lux

    fdsg72-lux New Member

  6. _X_

    _X_ New Member

    as far as I can see there are few problems:
    1) ping www.oralab.com and mail.oralab.com: 64.106.152.211
    2) ping webmail.oralab.com: request failed.

    are you using godaddy ?
     
  7. _X_

    _X_ New Member

    all mail errors can be tracked in:
    /var/log/mail.log
     

Share This Page