DVD Drive not showing up

Discussion in 'Technical' started by mphayesuk, Jun 7, 2006.

  1. mphayesuk

    mphayesuk New Member

    Suse 10 64bit
    DVDRW ide drive (no other ide drives connected, using sata for hdd)

    When I go into mycomputer (desktop) there is no dvd drive listed, it will only appear after I put a valid disk in, the same happens from shell prompt.

    This is casuing a slight problem because when I run my backup script it fails at the burn to disk point because when I have a blank disk in the drive is not detected.

    This is my fstab

    /dev/sda3 / ext3 acl,user_xattr,usrquota,grpquota 1 1
    /dev/sda1 /boot ext3 acl,user_xattr 1 2
    /dev/sda2 swap swap defaults 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs noauto 0 0
    usbfs /proc/bus/usb usbfs noauto 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0
    /dev/dvdrecorder /media/cdrom subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
    /dev/fd0 /media/floppy subfs noauto,fs=floppyfss,procuid,nodev,nosuid,sync 0 0
    none /subdomain subdomainfs noauto 0 0
    /dev/sdb1 /tmp ext3 acl,user_xattr 1 2

    On the line /dev/dvdrecorder /media/cdrom

    I added the cdrom word in, to see if that was the problem but it has made no difference, so it works with and without the word cdrom.

    Can anyone point me in the right direction or offer any assistance.

  2. falko

    falko Super Moderator ISPConfig Developer

    Can you mount the drive like this?
    mount /dev/dvdrecorder /media/cdrom
  3. mphayesuk

    mphayesuk New Member

    The mount command does not return any errors.. after typing the command I return to the "command prompt" but when I try and cd to it it fails with an error... not sure what the error says but it something like "cant do that there is no drive there",l type of thing.

  4. falko

    falko Super Moderator ISPConfig Developer

    Yes, because there's no DVD in the drive... ;)
  5. mphayesuk

    mphayesuk New Member

    So why when I put in a blank cdrw OR a dvd-r disk, suse detects it and asks me if I want to open it with k3b. But when I run my backup script (sorry cross post in general) I get the following error:

    :-( unable to open64("backup.iso",O_RDONLY): No such file or directory

    ** note to admins feel free to remove this post if you think I have cross posted in ispconfig general.

    Any help on this would be usefull... its starting to anoy me.

  6. mphayesuk

    mphayesuk New Member

    If the cd/dvd drive is mounted as a read only drive how do I mount it as a read/write drive.

  7. falko

    falko Super Moderator ISPConfig Developer

Share This Page